Wireguard and IPv6

Thank you! I tried that, but then the lan clients get an IPv6 with the Algo prefix (as well as the OpenWRT prefix fd3d:bb21:19a0::1/64), but not the wifivpn clients.

48

(new users can only upload one image per post)
12

put the prefix you're interested in using on the interface where you want clients to USE it.

You can use ip6class to control where the prefixes are used. And you need to use ip6assign on the WiFivpn interface. https://openwrt.org/docs/guide-user/network/ipv6/start

Great, that got me a big step forward.

config interface 'wguk'                    
        option proto 'wireguard'           
        option private_key 'REDACTED'
        list addresses '10.19.49.11/24'                                  
        list addresses 'fd9d:bc11:4021::b/48'                            
                                                                         
config wireguard_wguk                                                    
        option public_key 'REDACTED' 
        list allowed_ips '0.0.0.0/0'                                     
        list allowed_ips '::/0'                                          
        option endpoint_host 'REDACTED'                          
        option endpoint_port 'REDACTED'                                     
        option persistent_keepalive '25'                                 
        option preshared_key 'REDACTED'
                                                                           
config interface 'wguk6'                                                   
        option ifname '@wguk'                                              
        option proto 'static'                                              
        option ip6prefix 'fd9d:bc11:4021::b/48'                            
                                                                           
config interface 'wifivpn'                                                 
        option proto 'static'                                              
        option ipaddr '192.168.2.1'                                        
        option netmask '255.255.255.0'                                     
        option type 'bridge'                                               
        option ip6assign '64'                                              
        list ip6class 'wguk6'      

This works, and I'm getting assigned some v6 IPs when connected to the wifi.
The only thing is that I'm not getting any traffic through IPv6. 100% packet loss on ping6.

Likely a firewall config if "this woks."

1 Like

Also OpenWrt utilizes source routing for IPv6 which may limit some configurations connectivity without an additional default route.