Wired (ethernet) and wireless (WAN) connection issue

Hlo everyone, bit of background first. I have a Linksys WRT1900ACS v2 router. Installed Openwrt (19.07.7) 2 months ago. I am pleased with openwrt it works great. I only have one tower pc connected to my router via ethernet. All of my other devices are connected via wifi. (3 laptops and 2 phones). Rarely are all of my wireless devices connected at the same time because everybody is not usually here at the same time.

My pc that is connected via ethernet is running Linux mint 20.1 (ubuntu 20.04) and has all the latest updates. The only issue I have (and it has become a huge one) is, my linux system checks for updates daily and probably averages installing updates once or twice each week. Of course, anytime it's a kernal update or something else critical, it requires a reboot after the update. Never been an issue before openwrt but now, with each reboot of my pc, It cannot reestablish connection to the internet. Well, actually, it does connect but only for less than one second and then disconnects. it's a constant loop or cycle where it says: connection established followed by disconnected and it continues to do that until I unplug the ethernet cable or power down the router.Then I noticed during this same time period that my laptops (also linux mint) and my phone were connecting normally and staying connected. Then I tried connecting my tower pc via wifi but when I attempt wireless connection it goes through the same cycling as with the wired connection.

If it were not for the updates and reboots of my tower, I would have no issues whatsoever. Because when it's connected before an update it never drops connection. Each time after an update and reboot, I have to keep working with it to establish a connection and I'm not realy even sure what works to reestablish. Sometimes I can just power down my router for 15 minutes and turn it back on and it connects. Sometimes that doesn't work. Other times I unplug my ethernet cable and or reboot the pc several times. Sometimes it works, other times it doesn't. The only real clear idea I've noticed is after each linux mint update it seems to get harder and harder to reestablish a connection.

Lastly, I am a novice in the world of linux and openwrt so if you need some type of error logs I will need guidance/advice. Thank you

Does the Mint get settings by DHCP or do you use Static?

First of all, there is no excuse for wired clients to fail getting an ethernet connection. This should always work - and there is no general issue with OpenWrt in this regard, neither 'should' there be a problem with your router in particular.

The first thing to check, would be the ethernet connection itself - the cable/ sockets, patch cables, etc. If you can, replace the patch cable, if you can - take computer and router into the same room (temporarily) and use a different patch cable for a direct connection (bypassing in-wall infrastructure); also make sure that connectors and plugs are clean on both ends.

If you have a network switch (unmanaged/ managed, speed ratings don't matter - just for a quick test), you can try putting it between router and your PC (this is not necessary, but it can sometimes help if both ends have problems deciding on connecting properly).

Once you have the easy/ hardware issues ruled out, you'll need to continue debugging the software side. The easiest approach would probably be to test a different linux live distribution (temporarily) from a USB stick, Fedora, Ubuntu/ Debian-live come to mind. If either of these work reliably, you'd need to continue debugging Mint; testing with a parallel installed windows can also be interesting.


slh, thank you for the advice. I have cleaned and checked my cable ends and sockets. Even tried different cables on your recommendation. Also, my charter spectrum modem, linksys router and tower pc are all in the same room. No walls in the way to interfere with the connection. None of the hardware related things I have tried have helped correct the issue. Unfortunately I don't have a network switch to place between router and pc.

I will try a ubuntu/Debian live usb stick next time I'm home. I have developed one strategy over the weekend that seems effective. Even though unplugging cables, powering down the router and rebooting my tower are all hit and miss, if I log into my router from my cellphone and click the reboot button in openwrt, after the reboot is complete, my pc always reestablishes internet connection.

Hey guys! Great news! @slh was right. It was not an issue with unbound. Ended up being an issue in Ubuntu 20.04. And my Linux Mint is based on Ubuntu. I had to create a network configuration in Ubuntu netplan. After I saved and applied it I rebooted my tower pc and it automatically connected to the internet. I followed this advice from cyberithub:(https://www.cyberithub.com/solved-no-internet-connection-after-installation-of-ubuntu-20-04/). Thank you for your input.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.