Wired client DHCP lease issue

Hello,

My main router is WRT32X that is connected to a modem, and I have a Archer C7 v2 that I'm using as a dumb AP that is wired to the WRT32X. Both running 21.02.2.

This evening I noticed that I couldn't ping/ssh some of my wired computers, and I also noticed that they didn't have a DHCP lease in my WRT32x. Restarting both routers did not solve the problem, but unplugging and re-plugging in the Ethernet cables of each wired computer fixed that computer. I had no issues connecting several other computers to either router with via wifi. Any ideas what would cause this?

One other issue, unsure if it is related, iperf3 from one router to the other tops out at about 95 Mbits/sec, though I remember previously getting in the 150-250 range.

Here are the system logs showing the dhcp requests when I unplugged and then plugged in "weakhp", "desktop", and then "homeassistant".

Mon Apr  4 23:03:50 2022 daemon.info dnsmasq-dhcp[5030]: DHCPREQUEST(br-lan) 192.168.1.243 x:x:x:x:x:x
Mon Apr  4 23:03:50 2022 daemon.info dnsmasq-dhcp[5030]: DHCPACK(br-lan) 192.168.1.243 x:x:x:x:x:x weakhp
Mon Apr  4 23:03:52 2022 daemon.info dnsmasq[5030]: read /etc/hosts - 4 addresses
Mon Apr  4 23:03:52 2022 daemon.info dnsmasq[5030]: read /tmp/hosts/odhcpd - 6 addresses
Mon Apr  4 23:03:52 2022 daemon.info dnsmasq[5030]: read /tmp/hosts/dhcp.cfg01411c - 3 addresses
Mon Apr  4 23:03:52 2022 daemon.info dnsmasq-dhcp[5030]: read /etc/ethers - 0 addresses
Mon Apr  4 23:09:39 2022 daemon.info dnsmasq[5030]: read /etc/hosts - 4 addresses
Mon Apr  4 23:09:39 2022 daemon.info dnsmasq[5030]: read /tmp/hosts/odhcpd - 8 addresses
Mon Apr  4 23:09:39 2022 daemon.info dnsmasq[5030]: read /tmp/hosts/dhcp.cfg01411c - 3 addresses
Mon Apr  4 23:09:39 2022 daemon.info dnsmasq-dhcp[5030]: read /etc/ethers - 0 addresses
Mon Apr  4 23:09:44 2022 daemon.info dnsmasq-dhcp[5030]: DHCPDISCOVER(br-lan) 192.168.1.208 y:y:y:y:y:y
Mon Apr  4 23:09:44 2022 daemon.info dnsmasq-dhcp[5030]: DHCPOFFER(br-lan) 192.168.1.208 y:y:y:y:y:y
Mon Apr  4 23:09:44 2022 daemon.info dnsmasq-dhcp[5030]: DHCPDISCOVER(br-lan) 192.168.1.208 y:y:y:y:y:y
Mon Apr  4 23:09:44 2022 daemon.info dnsmasq-dhcp[5030]: DHCPOFFER(br-lan) 192.168.1.208 y:y:y:y:y:y
Mon Apr  4 23:09:44 2022 daemon.info dnsmasq-dhcp[5030]: DHCPREQUEST(br-lan) 192.168.1.208 y:y:y:y:y:y
Mon Apr  4 23:09:44 2022 daemon.info dnsmasq-dhcp[5030]: DHCPACK(br-lan) 192.168.1.208 y:y:y:y:y:y desktop
Mon Apr  4 23:14:42 2022 user.info : luci: accepted login on / for root from 192.168.1.185
Mon Apr  4 23:15:18 2022 daemon.info dnsmasq-dhcp[5030]: DHCPREQUEST(br-lan) 192.168.1.140 z:z:z:z:z:z
Mon Apr  4 23:15:18 2022 daemon.info dnsmasq-dhcp[5030]: DHCPACK(br-lan) 192.168.1.140 z:z:z:z:z:z homeassistant
Mon Apr  4 23:15:18 2022 daemon.info dnsmasq[5030]: read /etc/hosts - 4 addresses
Mon Apr  4 23:15:18 2022 daemon.info dnsmasq[5030]: read /tmp/hosts/odhcpd - 10 addresses
Mon Apr  4 23:15:18 2022 daemon.info dnsmasq[5030]: read /tmp/hosts/dhcp.cfg01411c - 3 addresses
Mon Apr  4 23:15:18 2022 daemon.info dnsmasq-dhcp[5030]: read /etc/ethers - 0 addresses

files below (anything wrong here?)

From WRT32X (main router)

root@main:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option localservice '1'
	option ednspacket_max '1232'
	list server '127.0.0.1#5054'
	option confdir '/tmp/dnsmasq.d'
	option noresolv '1'
	option doh_backup_noresolv '-1'
	list doh_backup_server '185.228.168.168'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option dhcpv6 'server'
	option ra 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config domain
	option name 'modem'
	option ip '192.168.100.1'
root@main:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix removed

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'wan'
	option macaddr removed

config interface 'wan'
	option device 'wan'
	option proto 'pppoe'
	option username removed
	option password removed
	option ipv6 'auto'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'

config interface 'vpn'
	option proto 'wireguard'
	option private_key removed
	option listen_port '51820'
	list addresses '192.168.9.1/24'
	list addresses removed

config wireguard_vpn 'wgclient'
	list allowed_ips '192.168.9.2/32'
	list allowed_ips removed
	option description 'myphone'
	option public_key removed
	option route_allowed_ips '1'
root@main:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'
	option country 'FR'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'
	option macaddr removed

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr removed
	option wds '1'
	option ssid 'main'
	option encryption 'psk2'
	option key removed

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option channel '34'
	option band '5g'
	option htmode 'VHT80'
	option disabled '1'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

From C7 (dump AP)

root@second:~# cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ignore '1'
	list ra_flags 'none'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'
root@second:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix removed

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.1.2'
	option gateway '192.168.1.1'
	list dns '192.168.1.1'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 3 4 5 0t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '1 6t'
root@second:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option txpower '20'
	option cell_density '0'
	option disabled '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'second_5g'
	option encryption 'psk2'
	option key removed

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'
	option country 'IL'
	option channel '13'
	option disabled '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'second'
	option encryption 'psk2'
	option key removed
	option wds '1'

Hey you up for adding these for jim

cat /etc/config/network
cat /etc/config/wireless

I'm not sure who Jim is, but sure! I've edited the post. thanks

Jim aka @anon89577378 is a regular that solves issues. Keen on spotting wireless issues and supports the community from a time zone matching that of your posting.

Can you for me ~ tell me if rj-45 connectors are in good working condition, with the locking snap intact, and properly pinned?

Thank you.

They are in good condition, they have the looking snap, and the wire I made (between the 2 routers) passed an ethernet test. This isn't a constant problem. Only happened last night and once a few weeks ago.

This is perplexing. A reboot can fix many issues but not lighting up a port??
WRT32X this looks odd to me, is this your config on the switch? Because I don't see a reference to config switch

So you have a testing tool, if so test the cable between weakhp and the others but i doubt that is the issues. If cable's check out, and you're pretty sure the WRT32X isn't defective. I'm a not leaning anywhere software related, sounds physical, unless you've got some additional hint... I don't think I can be of any assistance.
IMG_20220405_144255

WRT32X is DSA on 21.02.2

Things have been stable since this post. I've got no other clues for now. hopefully it was a fluke. thanks