WiFiX NEXQ6GO and mwan3 on GoldenOrb

hey all,

I'd like to install mwan3 on my new router, running GoldenOrb... but I'm getting an error saying that the kernel is mismatched. I've tried from both the web UI and from the commandline, but I keep getting the same error:

Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for luci-app-mwan3:
  • kernel (= 4.9.211-1-2b8f9dfe583e5c09aadd9474da55137f)
  • opkg_install_cmd: Cannot install package luci-app-mwan3.

...thing is, I'm definitely running kernel 4.9.211! :confused:

I tried forcing the install, but it bricked the device and I had to hard-reset and restore the firmware using the weirdo chinese bootloader interface. back up and running now, but still no mwan3.

any tips? is there something easy I'm missing?

|Model|WiFiX NEXQ6GO|
|Architecture|Qualcomm Atheros QCA9533 ver 2 rev 0|
|Firmware Version|GoldenOrb_2021-09-10|
|Kernel Version|4.9.211|
|Local Time|Fri Dec 24 14:17:31 2021|
|Uptime|0h 21m 3s|
|Load Average|1.16, 0.64, 0.46|

the package version probably doesn't match the kernel version.

but since it's goldenorb, you should really ask them, not us.

Ask them at LteFix for the firmware version with MWan3 in it.

They don't install it by default but they have a version with it.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.