Wifidog or Apfree wifidog installation

Hello,

My router is a TP Link Archer C2 750 V1.

I'm trying to install a captive portal, I found Wifidog and «apfree wifidog».

  • I tried to install wifidog but I had the error see bellow :
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for wifidog:
 *      kernel (= 4.4.14-1-5616196ae8f3aaba70ef256bd4ea1ce1) *  kernel (= 4.4.14-1-5616196ae8f3aaba70ef256bd4ea1ce1) *  kernel (= 4.4.14-1-5616196ae8f3aaba70ef256bd4ea1ce1) *

  • I tried to search «apfree wifidog», but the package is not available.

If I correctly understood, the issue with wifidog is due to the openWrt version. I'm using a snapshot version because the stable version is not compatible with my router.

Is there a way to install it ?

Packages on snapshots (“daily builds”) are best installed the same day as the ROM. Download and flash a new ROM, then install the packages.

1 Like

Thanks for your help.

Just to be sur to understand correctly, I must go the page https://openwrt.org/toh/tp-link/archer_c2_ac750 to download the «Firmware OpenWrt snapshot Upgrade». Then use the «Flash new firmware image» function on openWrt ?

I'm sorry about this stupid question but I don't have so much knowledge on the linux system.

For my information : what's the difference between a snapshoot and an installation of the latest release (regarding my problem of package installation) ?

1 Like

https://openwrt.org/faq/difference_between_a_release_and_a_trunk_build

2 Likes

How are you running a snapshot with a 4.4 kernel? The latest stable release (18.06) was a mixed kernel 4.9/4.14 release. 19.07 will be all 4.14.

Sounds like a very old snapshot. Are you sure your device isn't supported by a stable release in the meantime?

2 Likes

Thanks for your help.

Hostname	      OpenWrt
Model	          TP-Link Archer C2 v1
Architecture	  MediaTek MT7620A ver:2 eco:6
Firmware Version  OpenWrt SNAPSHOT r11591-c5497ebb1c / LuCI Master git-19.333.26981-88cdda4
Kernel Version	  4.14.155

Error excepted my device is not present on the page : http://archive.openwrt.org/releases/18.06.4/targets/ramips/mt7620/

Can you try the 19.07 RC2 binary?

From there, you can upgrade to the final 19.07 stable release and so on. It's recommended to read the device page on the wiki as well (has pointers on what works and what not etc).

Please see below the message displayed when I'm trying to update openWrt.

Device tplink,archer-c2-v1 not supported by this image Supported devices: tplink,c2-v1 Image check failed.

When you are a brave guy, try
sysupgrade -F ....

I did it ..... and ...... and ..... all is working fine :wink: Thanks a lot.

1 Like

"Thumbs up" and "Solved" appreciated.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.