Wifi works on laptops only? Looking for correct cascading router setup

Hi there! I'm very new to networking, and know very little. I have setup a Linksys WRT 3200acm connected via powerline ethernet to a telecom router/modem that I have no access to (Cascading). I have installed the latest OpenWRT build for the device (Linksys), and everything seems to be working correctly. I am using LUCI. I need this router to utilize advanced functions, so a dumb AP passthrough will not qualify. I have kept almost everything default on the network/wifi configuration, and it seems to work, but only on laptops/desktops. Mobile phones can connect to the network but have a no internet error. I suspect this is because the LAN ipv4 gateway or LAN ipv4 address are incorrect? The modem/router from the telecom uses as an IP, so I configured the LAN with an ipv4 address as and its gateway as Everything else is default, but I can provide if needed. Clearly this is an incorrect setup lol, but I don't know why it works fine for laptops. I also am looking for the correct setup haha. Thanks.

Obtain standard instructions/recommendations from ISP, that should be freely available, and check if your settings comply.

Also be sure that your Regulatory domain settings comply and confirm with your country / region.

If the problem persist you will then have to start digging deeper. Also scour the forum for similar threads.

This does not make any sense.
Should be something like this

ISP MODEM/ROUTER -> LAN = (OK) , set static route to Linksys LAN
YOUR LINKSYS -> WAN = reserve static dhcp lease on your ISP router for this
YOUR LINKSYS -> LAN = for example enable dhcp for this interface

Ok, thanks for the reply. Unfortunately, I cannot modify any settings at all on the isp modem/router. Can I just change the LAN settings on the linksys router to something else? Also, why would it work fine on computers as is, but not on phones? Thanks so much for helping an idiot like me.

Just setup the liksys with standard settings


You have to have the LAN and WAN be different networks. So set your LAN to, all your LAN clients will be 192.168.2.X, then obtain a 192.168.1.X address from the ISP router by DHCP.

As you are using IPv4 only, make sure to turn off the IPv6 features in OpenWrt, particularly the IPv6 DHCP server. Having the router issue an IPv6 address which goes nowhere can confuse some devices.

"Advanced features" that require an incoming connection, such as a VPN server, cannot work if you can't configure the ISP router to allow incoming connections.

Thanks mk24. I disabled the ipv6 dhcp server. So, under LAN networking settings, I need to make the ipv4 address What should the gateway be, just Do I need to touch WAN settings? I am just confused because the wireless network is providing internet for some devices but not others. Sorry, I know this is basic, but I couldn't seem to get the openwrt userguide default settings work because of the cascading setup. Do I need to add the WAN network to the wireless network? I previously had this exact same setup working running ddwrt but a driver was apparently working better on OpenWRT.

You said you want to actually route in your OpenWrt router, that is not a dumb AP. So you have a LAN and a WAN network and forwarding between them. This is the default configuration.

LAN set to an address that does not conflict with the WAN. Do not set a gateway or DNS on the LAN. Everything gets forwarded to WAN, so if you needed a non-default gateway or DNS you would set it there. Generally though you just leave WAN at its default mode of DHCP client.

Really the less you do here the better the chance of it working. I suggest resetting the router to defaults and make only the following changes:

  • Set a root password
  • Change LAN IP to
  • Turn off LAN DHCPv6 server (leave v4 server on)
  • Configure a wifi AP connected to LAN

Ok I'm trying to follow those steps but when I get to the edit ipv4 address, it times out and rolls back. All I am doing is changing the ipv4 address field from Leaving the ipv4 gateway field empty. Should I do the later steps first or something? Thanks.

Protocol: static address (default)
Ipv4 address:
Ipv4 netmask: (default)
Ipv4 gateway: (default)

I find the roll back feature confusing as well.

You might just need to close the browser and open a new page at the new address.

Somehow I just can't get it to stick. I tried opening a new window with Do you know why this might be happening?