WiFi wont authenticate with VLAN

Asus RT88U, running 22.03. Was trying to add IOT & Guest VLANs, but shrunk it down to this most basic config to test.

  • Added VLAN 10 (via Bridge VLAN Filtering) to the default br-lan bridge. Untagged all ports
  • Changed the default lan device to the new software VLAN
  • br-lan is allowed through the firewall default lan rule
  • Saved changes - wired connnections work (internet access, ping other devices, DHCP & DNS), but WiFi devices can't authenticate. Tried Android, another Windows laptop and iPhone all with the same results

Remove WiFi authentication, make the SSID auth open, and the devices connect fine and can browse the network. Tried the various auth options all had the same issue.

In the system log can see the Wi-Fi devices trying to associate
Sat Aug 6 08:37:47 2022 daemon.info hostapd: wlan1: STA 5c:17:cf:89:2d:7f IEEE 802.11: associated
Sat Aug 6 08:37:51 2022 daemon.info hostapd: wlan1: STA 5c:17:cf:89:2d:7f IEEE 802.11: disassociated

Factory reset router, did the above steps as the most basic test - same results.

Am I missing something?

Seems this is a known issue on github: link

Will watch for that to be resolved before trying again.