WIFI up, device connected but no internet

Hi everyone,

I see both WIFI 2.4 and 5 are up, I have connected my devices (tried iphone 6s and Samsung TV KS9 series) to both wifi's and no internet.

Only after rebooting the router the internet was up again.

Note that I have tried my pc which is wired connected to the router and everything was fine.

Any thoughts ?

Thanks.

Please, post your network, firewall, and wireless (watch out for the passwords) config files here.

How do I download my config file?

Connect to the router using SSH, execute "cat filename", then copy the result and paste it here.

root@LEDE:~# ls /etc/config
dhcp      firewall  network   sqm       ubootenv  uhttpd
dropbear  luci      rpcd      system    ucitrack  wireless
root@LEDE:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd5b:ec13:3ee9::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth0'
        option proto 'dhcp'
        option peerdns '0'
        option dns '23.21.43.50 54.229.171.243 195.28.181.161'

config interface 'wan6'
        option ifname 'eth0'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 0'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6'

root@LEDE:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp udp'
        option src_dport '64000'
        option dest_ip '192.168.1.120'
        option dest_port '64000'
        option name 'Torrents'

root@LEDE:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option htmode 'VHT40'
        option country 'IL'
        option channel '40'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid '****** 5Ghz'
        option encryption 'psk2+ccmp'
        option key '**********'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option htmode 'HT20'
        option country 'IL'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid ''****** 2.4Ghz'
        option encryption 'psk2+ccmp'
        option key '*********'

Note that I also experience connection drop now for all devices for a few minutes/seconds then the network is up again, happen when watching Plex yesterday and today.

I don't see anything weird on those files, and wireless is bridged to wired, so there should be no difference. I would try to guess out why are the wifi devices not reaching internet: is it a DNS issue? or is all traffic blocked? can you reach the router?

There is 2 issues:

  1. I can reach the router - devices show they connected but no internet (note that I had this issue with dd-wrt as well, last dd-wrt build seems to fix it). This issue was from the beginning.
  2. I can't reach the router - sudden drop of network for all devices after few minutes/seconds network is up again. This issue started only yesterday.

For both issues it seems that router reboot solve it for a few good hours.

Perhaps your hardware is not fully supported?

You mean the router?

It's an Archer C7 V2 it is supported.

Investigate your FIrewall rules to see if you have blocked the DHCP ports 67-68 . If you did ( i.e. when setting up a new WIFI network those ports are not enabled by default through the firewall ) , then the clients will connect but not get an IP address, therefore "no internet" .

If this is happening, your clients would be getting a 169.x.x.x IPV4 address.

I am not familiar with Plex, but does Plex use multicast by any chance? If so, igmp snooping is required to be set in your network configuration file on all the LAN bridges/interfaces. This makes sure the multicast traffic only reaches the devices that are actually using it. If you don't set that option, the multicast packets will be broadcast over all interfaces. This is especially troublesome for wifi connections. For some they become extremely slow, and for others (me included) multicast traffic outright kills the wifi connection. Try to see if the issues persists if Plex is disabled. If disabling Plex solves your issues, try to set igmp snooping by adding this to (all) your LAN interface (s):

option igmp_snooping 1

You got me thinking that is one of the devices which kill the network/internet.

@Mushoz
Maybe you can help me investigate by looking at the devices and their use:
2 iPhone devices - regular use.
1 iPad - regular use.
Samsung KS9500 TV - Consume Plex, Netflix, Hulu.
Xbox One - Consume games (some online).
2 Laptops - regular use.
1 PC - torrents + Plex Media Server + regular use.
2 YI Home Camera (720p version) - Consume constant bandwidth in order to transit output video.

  • regular use = nothing that I see that can kill the network/internet

I don't have those ports block and I got 192.x.x.x IPV4 address.

@Nivg I don't know some of those devices, so I am not sure what kind of protocol they use. It doesn't hurt to try igmp snooping though. Try to enable igmp_snooping by following the instructions in my previous post. You can post your network config file here if you would like me to check whether you did it correctly. Then reboot the router and see if the issue is gone. Good luck!

config interface 'lan'
option type 'bridge'
option ifname 'eth1'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option igmp_snooping '1'

If that is your only LAN interface, then it looks good :slight_smile: Are the issues gone? Make sure you reload the settings to apply them by running:

/etc/init.d/network reload

Or by simply rebooting the router.

Since this issues are not always presenting and they are not always come when streaming something to Plex client on the Samsung TV we will have to wait and see.

Thanks for the help, I will update this post in a few days if Network is stable :slight_smile:

It's been a while, but it seems the "igmp snooping" solved the issue.

Thanks :slight_smile:

I had the same issue that OP had (only difference I have KODI instead of plex) and which I assume got solved by adding the snooping in the network config
I am not sure if it makes sense, but I think that adding a note under wifi troubleshooting or network config might help other users.
I don't mind doing it, I assume I can get an account to edit the relevant page, just felt like asking before doing anything...I am no router expert and I don't want to suggest something that has worked for me but might have other implications on other routers....

if you reckon I should proceed please let me know

M

wow, I have been having the same issue for a week
l was frustrated about not knowing why my wifi wasn´t connecting to the internet. wired devices had no issue to connect to the net.

this one line "option igmp_snooping ‘1’" on network.config solved all the problem
i don´t know what it does, it works! .....THX!

My Vlan config:

config interface 'lan0'
	option force_link '1'
	option proto 'static'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ipaddr '10.10.11.1'
	option _orig_ifname 'eth1.2'
	option _orig_bridge 'true'
	option ifname 'eth1.2'
	option delegate '0'

config interface 'lan10'
	option proto 'static'
	option ifname 'eth1.3'
	option ipaddr '192.168.10.1'
	option netmask '255.255.255.0'
	option delegate '0'
	option type 'bridge'
	**option igmp_snooping ‘1’**

config interface 'DMZ'
	option proto 'static'
	option ifname 'eth1.4'
	option ipaddr '11.11.11.1'
	option netmask '255.255.255.0'
	option delegate '0'
	option type 'bridge'