Wifi transfer speed drops. your opinion please, suggestions welcome

I installed openwrt 3-4 years ago on my Linksys Wrt1900ac v2.
from NAS to laptop (same devices today) I could see wifi transfer speeds in 5Ghz/500mbps and 2Ghz/120mbps. transfer of videos, 2 to 10 Gb files
recently the speeds went down to 5Ghz/150mbps and 2Ghz/40mbps

openwrt release was 19.07.05
today it is 23.05.2

I installed nordvpn openvpn 2 years ago but this local speed transfer speed should not have much to do with vpn If I am not wrong.

any idea or suggestion very welcome, in luci preferably….
the linksys is a good machine equipped with linksys high gain antennas for a large house, it does the job well and I'd like to keep it if possible.

see a few screencaps below during tests with video transfers. these show the 2021 wifi speeds and today's wifi speeds. did i do something wrong? thanks to comment and suggest what i can try

thank you



wifi_wrt1900ac trf OpenWrt fw5Ghz_2.4Ghz 20240322

When did you update?
When you updated, did you keep the settings from 19.07.05?

Might as well show this:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

thank you for the return. i hope i did right in ssh, not used to this.
19.07.05 refs appears on an old screencap.
i did update almost all openwrt firmwares (20 updates?) since.
my modifications were mostly to include port forwarding for synology applications, and create openvpn with the nordvpn configuration
thank you for taking the time to go through this

root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.137",
"hostname": "OpenWrt",
"system": "ARMv7 Processor rev 1 (v7l)",
"model": "Linksys WRT1900AC v2",
"board_name": "linksys,wrt1900ac-v2",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.2",
"revision": "r23630-842932a63d",
"target": "mvebu/cortexa9",
"description": "OpenWrt 23.05.2 r23630-842932a63d"
}
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd84:43df:5c29::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
list ports 'lan3'
list ports 'lan4'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device
option name 'wan'
option macaddr 'XXXXXXXXXXX'

config interface 'wan'
option device 'wan'
option proto 'pppoe'
option username 'XXXXXXXXXXX'
option password 'XXXXXXXXXXX'
option ipv6 'auto'

config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'

config interface 'nordvpntun'
option proto 'none'
option device 'tun0'

config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
option channel '36'
option band '5g'
option htmode 'VHT80'
option country 'LA'
option cell_density '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'XXXXXXXXXXX'
option encryption 'psk-mixed'
option macaddr 'XXXXXXXXXXX'
option key 'XXXXXXXXXXX'

config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option channel '6'
option band '2g'
option htmode 'HT20'
option country 'LA'
option cell_density '0'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'XXXXXXXXXXX'
option encryption 'psk-mixed'
option macaddr 'XXXXXXXXXXX'
option key 'XXXXXXXXXXX'

config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'XXXXXXXXXXX'
option encryption 'psk-mixed'
option key 'XXXXXXXXXXX'
option disabled '1'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option localservice '1'
option ednspacket_max '1232'
list server '103.86.96.100'
list server '103.86.99.100'
option noresolv '1'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'

config zone
option name 'wan'
list network 'wan'
list network 'wan6'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'

config zone
option name 'vpnfirewall'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'nordvpntun'

config forwarding
option src 'lan'
option dest 'vpnfirewall'

config redirect
option dest 'lan'
option target 'DNAT'
option name 'synoTorrents'
list proto 'tcp'
option src 'wan'
option src_dport '7890'
option dest_ip 'XXXXXXXXXXX'
option dest_port '7890'

config redirect
option dest 'lan'
option target 'DNAT'
option name 'XXXXXXXXXXX'
list proto 'tcp'
option src 'wan'
option src_dport 'XXXXXXXXXXX'
option dest_ip 'XXXXXXXXXXX'
option dest_port 'XXXXXXXXXXX'

config redirect
option dest 'lan'
option target 'DNAT'
option name 'synoMule UDP'
option src 'wan'
option src_dport 'XXXXXXXXXXX'
option dest_ip 'XXXXXXXXXXX'
option dest_port 'XXXXXXXXXXX'
list proto 'udp'

config redirect
option dest 'lan'
option target 'DNAT'
option name 'XXXXXXXXXXX'
list proto 'tcp'
option src 'wan'
option src_dport 'XXXXXXXXXXX'
option dest_ip 'XXXXXXXXXXX'
option dest_port 'XXXXXXXXXXX'

config redirect
option dest 'lan'
option target 'DNAT'
option name 'XXXXXXXXXXX'
list proto 'udp'
option src 'wan'
option src_dport 'XXXXXXXXXXX'
option dest_ip 'XXXXXXXXXXX'
option dest_port 'XXXXXXXXXXX'

root@OpenWrt:~#

You did fine with the SSH; some results are questionable, but you managed it fine.

I'm sorry, I think you are trying to answer

But let me rephrase:

When did you upgrade? Did you upgrade once release at a time from 19.07.05 to 23.05.2 or did you do it in one jump?

When you did the upgrade(s), did you click the box to keep your settings or did you wipe the settings and reapply them manually?

I understand there is a translator or English is not your first language and you are doing your best but I need direct answers two the two questions:

When did you do your last update?
What version did you update from, the last time?
Did you try to save your configurations when you updated?
When did the slowdown occur in relation to the update? The moment you updated, a day after, a week after, etc.

Your whole wireless is in your network config. How did that happen; did you, accidently, merge network and wireless when posting??
What return did you get with cat /etc/config/wireless?
Run it again and post it alone.

I think you upgraded and saved settings. I could be wrong but at this point I lack the skills to detangle all of it.

23.05.03 just released so we may have to start fresh with that and we will need some help from others but until you answer those questions I asked people are just going to wait so they know what they are getting into or to just start over.

I really do not know how your wireless and network merged in one file and that makes me think configs were saved across updates.

thanks again. no issues with english discussion here. issues would be more on the ssh side where i feel a stranger
i make the updates regularly when they come online, in sequence.
19.07.03 was the initial change from the linksys firmware to openwrt in august 2020.
i updated today to 23.05.3
23.05.2 came early december
23.05.0 with several rc's between june and nov 2023 etc....

i update with the settings by default, i.e. i do not tick any box except the "browse" and "upload". is it my mistake?
i have backups made since 2020. the earliest from 2020, would be happy to send some if useful to understand the issue
i cannot say when this started. i usually transfer videos on the laptop when i go on travel, i may have noticed the very slow speed about end of December. i took a long time to post here since i was busy and not sure to be able to follow instructions in ssh.

it might be that during my vpn proton, wireguard or openvpn installations i jammed the system... today i have openvpn based on nordvpn config files. would you advise to reload a 2020 or 2021 backup and reinstall all versions that came after one by one?

anything you need that i can do i will be happy to send. thank you very much

find the config you requested:

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
option channel '36'
option band '5g'
option htmode 'VHT80'
option country 'LA'
option cell_density '0'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'XXXXXX'
option encryption 'psk-mixed'
option macaddr 'XXXXXX'
option key 'XXXXXX'

config wifi-device 'radio1'
option type 'mac80211'
option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
option channel '6'
option band '2g'
option htmode 'HT20'
option country 'LA'
option cell_density '0'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'XXXXXX
option encryption 'psk-mixed'
option macaddr 'XXXXXX'
option key 'XXXXXX'

config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'ap'
option ssid 'visiteur'
option encryption 'psk-mixed'
option key 'XXXXXX'
option disabled '1'

root@OpenWrt:~#

Use LuCI:
Status/Channel Analysis

Scratch out your SSIDs but post the rest on 5HGz and 2.4GHz.
Let's see how congested it is.

You might have to click Refresh Channels.

Hi, here are screencaps of the 5Ghz and 2.4Ghz channel analysis in Luci.


from my home in this quiet neigbourhood in Vientiane, i do not believe that wifi networks shall be as busy as if i was in Paris busy city buildings.

hope it helps
thank you

Okay, I do not think this is OpenWrt related problem, right now. You mention NAS but not SAMBA so maybe your NAS needs to be looked at.
That said:

Windows has had a very bad year or so with its updates affecting wifi on both 10 and 11.
I can think of at least three times I read about this.

Here is a most recent discussion about it.

Now, if you come back and say you don't use Windows on your laptop or any device, you are using SAMBA or can get higher numbers on speedtest.net then we can bump this and hopefully they can see how VPN would/could affect your network speed or point to something else in the config but intranet (local network) traffic should have very little overhead unless the radio drivers for the routers have an issue or Windows messed up.

Also, a bad ethernet cord could decimate transfer speeds.

Good afternoon,

the system is windows on desktop, laptops, tablets. the synology DS918+ is configured by default, (samba?), and the drives are mapped into windows with the defaut protocol i guess. in Kodi i connect to the syno through the "windows SMB" option. samba i assume.
i did try to download wifi from other synos DS412+ and DS409+ with the same speed results.
speedtest does give me the fiber speed available here around 70-80mbps (there is some price to pay to live in a sunny country, although next door Vietnam has 300mbps available)

reading through the forum i see i can reload an old firmware so i flashed 19.07.5 without keeping the config. no issue with that, 1mn to revert to 19.07.5 for those who ask if it is possible to revert. but the intranet speeds keep showing around 100mpbs.
i don't get why my 2021 "wifi" screencaps above show 500 or 700mbps.
can the WRT1900ACv2 degrade its performance? is it a known situation?
is it the laptop? i did a reformat few months ago.
i guess i will bang my head on this until i find a solution.
i will read your link to a discussion, and try the cable thing.

any comments welcome