WiFi stops working when PPPoE authenticates

This is going to sound crazy... I know.

I have 2 different routers - Archer C60 v2 and a 1043ND - and both are behaving the exact same way.
The C60 v2 is running OpenWrt latest version and my 1043ND is running the last release version of LEDE.

Yesterday, out of nowhere, my mobile phones wifi stopped working, always giving me issues when obtaining IP address.

If I reset all the router configs and DO NOT plug it to the PPPoE into them, I can connect to the router no problem, from the moment I connect the PPPoE(eth) cable and it authenticates everyone drops from the WiFi.

It is happening on both my routers... I have a very old TPLink that I don't even know the model number that is running it's original firmware and it is working normally.

Has anyone ever seen such an absurd behavior?

I tried removing IPV6 interface from OpenWRT.
I tried removing NTP client.
I tried changing all WiFi configuration (from SSIDs to passwords)
I tried changing the router IP address.

I am getting crazy already... and I can't seem to find a solution to this.

Which version of OpenWrt (18.06.4?) and LEDE (17.01.6 ?) are you using?

OpenWrt 18.06.4 on the C60 and LEDE 17.01.6 on the 1043ND. Yes.

Do you witness similar behaviour if you go to
LuCI > Network > Interfaces

Then press 'Stop' for WAN interface, and press 'Connect' to re-establish the PPPoE connection?

(If you have the 1043nd v4/v5, they use same QCA656x family SoC as C60 v2)

Post your network and dhcp config files here, please.

Tried stopping the WAN and then connecting, did not work.
As soon as the WAN is reestabilished and connects, all mobile phones get dropped from the network (strangely enough, my PC - that uses a Wireless card - is able to mantain connection without any issues).

It must be an SOC issue... I'm more and more convinced is something related to time/region... I don't know what to do anymore.

My 1043ND is version 1.11, so maybe a different, older SOC than my C60.

One sad thing is that I can't put my C60 back in the original firmware... it keeps giving me errors.
I'm going to try to rollback the 1043ND to the original firmware and see if it works.


config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr ''
	option netmask ''

config globals 'globals'
	option ula_prefix 'fd89:b0b3:3ff2::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth1.1'
	option proto 'static'
	option ipaddr ''
	option netmask ''
	option ip6assign '60'

config interface 'wan'
	option ifname 'eth0'
	option proto 'pppoe'
	option username 'mylogin'
	option password 'mypass'
	option ipv6 'auto'
	option delegate '0'
	option peerdns '0'
	option dns ''

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 0t'


config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_protection '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'server'
	option ra 'server'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

I tried forcing the DNS ( and as you can see). But nothing changed.

Which router are these config files for?
Can you post the contents of the /etc/config/network for C60 v2?

The C60 v2 wiki

What messages are shown in the System Log when your mobile phone apparently loses connection?

As a test, what happens when you change the LAN IP address of one of your routers (call it router 2), and then connect the WAN port (use DHCP) to LAN port of your other internet wired router (call it router 1?

internet -- router 1 -- router 2 -- mobile

Then stop and start(connect) WAN interfaces on router 1 and router 2?

The posted files are in the C60 V2. Reseted the device, changed access password, changed the WAN mode to PPPoE, inserted pppoe login and password, turned on wifi with wpa2 security.
Thats all. No other boxes checked or alterations made.

The same with 1043ND, but I just flashed Gargoyle on it and it's working.
But I have no alterantives to my C60... OpenWrt is not even allowing me to flash the stock firmware on it.

How are you trying to revert C60v2 back to OEM firmware?

The wiki page doesn't provide specific recovery instructions. If it is like other modern TPlink routers, you have to use TFTP method.

Also, the OEM firmware file may or may not have to be modified and stripped of its header before using TFTP to transfer the firmware image.

I found this thread for recovering C60 v2 back to OEM firmware, but I don't know if any owner has successfully returned their C60v2 to OEM firmware....

ie. I'm afraid you may be stuck with OpenWrt on your C60v2 for now.

I tried flashing the OEM firmware in LuCI, but it gives me an error saying it's the wrong firmware file... but if I try and flash OpenWrt back into it, it also gives me the error.
So I am not being able to upgrade to anything and not being able to downgrade.

About the stripping the firmware before flashing it, I did not try it yet and I am afraid of bricking my C60.

Right now I have boxed the C60 and am using the 1043ND, but not having my 5Hz radio is terrible.

I presume C60v2 has OpenWrt 18.06.4. To install OpenWrt (eg. 18.06.x) via LuCI, did you use the squashfs-sysupgrade.bin file?

It is generally not possible to return to OEM firmware using LuCI on any openwrt router, as you have discovered.

Yes, I used the sysupgrade file, but it still throws the error saying the file is incorrect.