Wifi speed settings

so i get the ISP router and i get x10 more wifi speed that on mine

ISP router

Wi-Fi status on
Wi-Fi MAC address xxx
SSID xxx
Wi-Fi key xxx
channel mode Auto
current channel 108
standard 802.11ac
channel bandwidth 80
security mode WPA/WPA2 Mixed
encryption TKIPAES 
MAC filter deactivated
WPS PBC activated 5.13
TX power 100%

my router is Linksys WRT1900ACS

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option country 'ES'
	option htmode 'VHT80'
	option channel '161'
	option cell_density '2'
	option distance '30'
	option txpower '13'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr 'xxx'
	option dtim_period '2'
	option wpa_group_rekey '600'
	option max_inactivity '300'
	option max_listen_interval '65432'
	option ieee80211w_max_timeout '1000'
	option ieee80211w_retry_timeout '202'
	option wpa_disable_eapol_key_retries '1'
	option encryption 'sae-mixed'
	option ssid 'xxxx'
	option wmm '0'
	option key 'xxxxx'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option country 'ES'
	option channel 'auto'
	option txpower '20'
	option cell_density '2'
	option distance '30'
	option htmode 'HT40'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option macaddr 'xxxxx'
	option key 'xxxx'
	option ssid 'xxxx'
	option wmm '0'
	option encryption 'sae-mixed'
	option ieee80211w_max_timeout '1000'
	option ieee80211w_retry_timeout '201'
	option wpa_disable_eapol_key_retries '1'
	option dtim_period '2'
	option wpa_group_rekey '600'
	option skip_inactivity_poll '1'
	option max_inactivity '300'
	option max_listen_interval '65432'

so where did i made the mistake?

If I read this correctly, I think you might be using a slower wifi standard (802.11a or 802.11g as compared to 802.11ac).

See https://en.wikipedia.org/wiki/IEEE_802.11 for explanation of wifi standards.

i can enable 1 wifi for the older stuff and another for the new stuff, currently running both of them in the same time

i made more tests and enabling WMM mode for radio1 doubled the speed

Enabling WMM mode for radio0 places the speed on 300-350

atm i am on OpenWrt 21.02.1 r16325-88151b8303 so maybe i need to bump the version if this bug get fixed

Quick things to fix:

  • Remove option distance
  • Ensure your option txpower is 7 dB higher¹ in your 5 GHz (11a) interface, not the other way around, and make it at least 18 dB, as this is the usual transmission power of mobile devices.
  • option wmm '1' must be set for getting more than 54 Mbps on 5 GHz.
  • You can increase option dtim to 3 or even 4 to save some battery on your mobile devices on your 5 GHz network. In your 2.4 GHz network and if you have IoT devices it will be better set to 1.
  • Ideally in España go with channels between 32 and 48, 161 is limited to SRD and only 25 mW (that's why your maximum power is only 13 dB, mate).

¹ Only if you use a unique SSID for 2.4 GHz and 5 GHz, otherwise it doesn't matter. This is to ensure proper roaming from 2.4 GHz to 5 GHz.

1 Like

That’s a red flag on your old device by the way.

1 Like

do you have a v1 or v2?

on the larger siblings 3200 and 32x, this country setting is a large red flag causing bad WiFi range and should not be customized, but left to driver default, as the country is hard coded in chip and the firmware goes nuts when country gets custom-set.
I vagely remember that this could possibly also apply to at least 1900v2

Also keep in mind in general when customizing too much on any of the WRT series, as the WRT WiFi driver does not support all UCI/LUCI settings.

V2

u mean usa?

There is a „driver default“ value for WiFi in Luci, try that. (might be that that effectively corresponds to removing the country code line)

Other than that, I would recommend, to reset all Wifi settings and start over

  • begin with LuCi for initial WiFi config
  • start with bare minimum configs in LuCi, when enabling WiFi
  • then do a first simple speed check for reference
  • then one by one, add your optimizations via UCI file or LuCi, doing another simple speedtest after each.

Other than that, I have doubts, if your path of adding all kinds of custom UCI WiFi settings is a good choice:

  • Where did you find those WiFi optimization settings that you mention in the first post?
  • has someone else confirmed these WiFi optimizations as being a good match for the 1900v2 before?

i changed stuff around and the only meaningful change was WMM mode

yes i did pick channel 161 because there are no wifis above 144 on my area and channel 3

Apparently some ISP in spain have locked channel at 1,6,11 for 2.4 GHz and 36, 40, 44, 48 52, 56, 60, 64, 100, 104,108, 112, 116, 120, 124, 128, 132, 136, 140

uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='mac80211'
wireless.radio0.hwmode='11a'
wireless.radio0.path='soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
wireless.radio0.htmode='VHT80'
wireless.radio0.cell_density='0'
wireless.radio0.channel='161'
wireless.default_radio0=wifi-iface
wireless.default_radio0.device='radio0'
wireless.default_radio0.network='lan'
wireless.default_radio0.mode='ap'
wireless.default_radio0.macaddr='x'
wireless.default_radio0.ieee80211w_max_timeout='1000'
wireless.default_radio0.ieee80211w_retry_timeout='202'
wireless.default_radio0.wpa_disable_eapol_key_retries='1'
wireless.default_radio0.ssid='x'
wireless.default_radio0.key='x'
wireless.default_radio0.encryption='psk2+tkip+ccmp'
wireless.default_radio0.ieee80211w='1'
wireless.default_radio0.dtim_period='3'
wireless.radio1=wifi-device
wireless.radio1.type='mac80211'
wireless.radio1.hwmode='11g'
wireless.radio1.path='soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
wireless.radio1.cell_density='0'
wireless.radio1.htmode='HT40'
wireless.radio1.txpower='20'
wireless.radio1.channel='3'
wireless.default_radio1=wifi-iface
wireless.default_radio1.device='radio1'
wireless.default_radio1.network='lan'
wireless.default_radio1.mode='ap'
wireless.default_radio1.macaddr='x'
wireless.default_radio1.key='x'
wireless.default_radio1.ssid='x'
wireless.default_radio1.ieee80211w_max_timeout='1000'
wireless.default_radio1.ieee80211w_retry_timeout='201'
wireless.default_radio1.wpa_disable_eapol_key_retries='1'
wireless.default_radio1.encryption='psk2+tkip+ccmp'
wireless.default_radio1.ieee80211w='1'
wireless.default_radio1.dtim_period='3'
1 Like

those were the fruits of despair after testing things out from google results, above i posted the current setting while more "cleaner" said cleaning did not do much, 99% was just WMM

are you using separated SSIDs for 2.4 and 5?

yes those are separated

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.