Wifi speed keeps getting reduced randomly

Ever since i have installed OpenWrt on my TP-Link Archer C6 v3 router, the wifi speed keeps getting reduced randomly from time to time. All this while, i always get full speed using ethernet cable on my desktop. Note that i am not talking about extremely high speeds over a distance, i am literally sitting 15 cms away from the router, the internet speed through LAN is always 100 MBPS ( which is my max speed) but on wifi its like 50-60 atm and yes i am using 5ghz. Morever, this issue almost always gets resolved when i restart the router or just wait for sometime.

i would also like to add the that optical fiber from my ISP isn't directly connected to my router. There is another device in between


Among these 3 ports, the right one is the power one. My ISP's optical fiber just connects to the left port and than a ethernet cable connects the middle yellow port and WAN port of my router. i have never had such random speed drop issues while using tp link's stock firmware but at that time, i wasn't using any such intermediary device either. Can someone please help me find the cause of this issue

Seems nothing wrong with the device in your mugshot :wink:
Please run speed tests in all ways connected
[https://www.waveform.com/tools/bufferbloat]

  • directly to converter
  • wired to router
  • 5GHz wifi
  • Then last 2 when speed falls

Post links, they dont contain your IP or anything private.

thanks, i will post the results as soon as the face the speed drop again. On another note, how can i connect to the internet directly to converter ?

Plug your pc-s ethernet cable in the yellow port

1 Like

i couldn't get internet to work when the ethernet cable from my cpu was directly connected to the yellow port of this device so that is excluded

The below test was carried out when my wifi speed had dropped

wired to router - https://www.waveform.com/tools/bufferbloat?test-id=6ed2caba-ebfb-447c-a60e-16e5e1dd1a6a

5 GHz Wifi - https://www.waveform.com/tools/bufferbloat?test-id=ac793c83-36aa-4c75-8b75-6a63a9483b37

The below test was done merely 5 minutes after the above one once i had removed and replugged the ethernet cable in the router and the other device

wired to router - https://www.waveform.com/tools/bufferbloat?test-id=9688f4e3-7b0f-49f8-87f1-e52c87ca78de

5 GHz Wifi - https://www.waveform.com/tools/bufferbloat?test-id=c67dd297-81be-495d-b7ca-9aa9cf889627

From wiki page:

DFS is not supported by the radio driver. Only a few 5GHz channels can be used in most countries.

i'd speculate when your neighbour does 4k internet TV you have to wait... best you can do is to have same name+password in both bands and usteer or dawn to steer you to 2.4 if 5ghz band gets too crowded. Not ideal, but bad luck with device as it is.

In SSH connection:

iw list | less

There find frequency selection (this is EU typical, one channel usable with your router):

                Frequencies:
                        * 5180 MHz [36] (23.0 dBm) -80mhz start
                        * 5200 MHz [40] (23.0 dBm)
                        * 5220 MHz [44] (23.0 dBm)
                        * 5240 MHz [48] (23.0 dBm) -80mhz end
                        * 5260 MHz [52] (20.0 dBm) (radar detection) -radio unsupported start
                        * 5280 MHz [56] (20.0 dBm) (radar detection)
                        * 5300 MHz [60] (20.0 dBm) (radar detection)
                        * 5320 MHz [64] (20.0 dBm) (radar detection)
                        * 5500 MHz [100] (26.0 dBm) (radar detection)
                        * 5520 MHz [104] (26.0 dBm) (radar detection)
                        * 5540 MHz [108] (26.0 dBm) (radar detection)
                        * 5560 MHz [112] (26.0 dBm) (radar detection)
                        * 5580 MHz [116] (26.0 dBm) (radar detection)
                        * 5600 MHz [120] (26.0 dBm) (radar detection)
                        * 5620 MHz [124] (26.0 dBm) (radar detection)
                        * 5640 MHz [128] (26.0 dBm) (radar detection)
                        * 5660 MHz [132] (26.0 dBm) (radar detection)
                        * 5680 MHz [136] (26.0 dBm) (radar detection)
                        * 5700 MHz [140] (26.0 dBm) (radar detection)
                        * 5720 MHz [144] (13.0 dBm) (radar detection) -radio unsupported end
                        * 5745 MHz [149] (13.0 dBm) - too weak to use start
                        * 5765 MHz [153] (13.0 dBm)
                        * 5785 MHz [157] (13.0 dBm)
                        * 5805 MHz [161] (13.0 dBm)
                        * 5825 MHz [165] (13.0 dBm)
                        * 5845 MHz [169] (13.0 dBm)
                        * 5865 MHz [173] (13.0 dBm) - too weak to use end
                        * 5885 MHz [177] (disabled)

thanks for the input but the problem gets resolved immediately once i restart my router/onu device so i highly doubt it has to do anything with networks in my surrounding area. My ISP is asking me to get a new router to fix the issue. i just want to ensure that my router is at fault 100% & not the ONU device. Although logically speaking i only have issue with the wireless network so it must be the router, i will flash the stock firmware and see if it fixes my issue just in case

Performance problems occur only with 5ghz radio. As long as it is 100mbps connection you can use 2.4 as fallback.

Yeah i understand but i have never had this issue prior to flashing OpenWrt. I would like to test if reverting to stock firmware fixes this. Is there a guide somewhere which lays down a tutorial for reverting back to stock firmware of my TP-Link Archer C6 v3.2 ?

wiki> Note: TFTP boot can be activated only from u-boot serial console.

Try snapshot - backup configuration, flash snapshot (add luci-mod-admin-full in package list to have web) - check if it still suffers - if yes, flash back 23.05.3 resetting configs and restore config.

Or you can try 23.05.0 (slightly older mt76 driver version), backup likely not needed, but keep it at hand anyway.

In principle next release is not planned so soon, you can also try V22, reset checkbox certainly needed to go revision backwards.

I am currently on stable release v23.05.2
I had tried solarwinds tftp software before reading your message. I pasted the stock firmware bin file into the tftp directory in C drive and reset my router before starting the tftp server. But it didn't worked out as expected

I am trying to find how to access uboot serial console but can't really find much info on this

You need to open the case and connect low voltage serial adapter, sometimes even solder.
Lets first check if the issue is introduced to OpenWRT at dome point, will be fixed tomorrow etc.

1 Like

I am not really into networking so sounds pretty daunting to me. Nevertheless, i couldn't find any other thread reagrding this procedure so i have opened a new thread titled reverting back to the stock firmware on this router so that incoming users in future could also benefit from all the helpful inputs

1 Like

If you succeeded at revert and do not need any further research you can close this ticking any of your comments, if not lets start with 22.03.6. You see your router is not ideal due to partially supported radio, and odds are high new patches/releases were not directly tested tested against it...

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.