WiFi signal on Linksys WRT32X

I've a Linksys WRT32X which has OpenWrt on it. Overall I am impressed with the device and the firmware but there is one area of the house and garden that has terrible wifi signal whatever frequency I choose.

The distance is no more than 30 feet from the router and it is practically visible with doors open. Other areas of the house dont have this issue and I think it is because this area is the extension to the house and the insulation used has a foil on it.

Anyway doe sanyone use a wifi extender ot have any other tips to improve the signal in this area (the router cant be moved).

Please, post your current "/etc/config/wifi" file here (but mask all private information), please.

The file appears to be called wireless in my case (there's no wifi)

Contents are listed below. I notice the 'optiion distance '25''. I am sure I set that to higher. Should it be? An dis there anything else?

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option country 'GB'
        option htmode 'VHT80'
        option channel '36'
        option distance '25'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option ssid 'xxxxxxx'
        option encryption 'psk-mixed'
        option key 'xxxxxxxxx'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option country 'GB'
        option channel '9'
        option htmode 'HT20'
        option distance '25'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option macaddr 'xx:xx:xx:xx:xx:xx'
        option ssid 'xxxxxxxx'
        option encryption 'psk-mixed'
        option key 'xxxxxxxxxxxx'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option htmode 'VHT80'
        option disabled '1'
        option country 'GB'

the distance option is not set in default openwrt or davidc builds.
you might try removing that option.

1 Like