WiFi roaming: suggestion for main router to pair with C7 v2

2.4 will not be part of the roaming setup, only 5Ghz; all mobile devices effectively don't connect to 2.4 which is used for a few legacy devices (they don't move anyways).

I did some testing today (R7800 as router+AP and C7 as AP); this is what I found:

  1. Android 9 does not support 802.11r, nor WPA3 (personal)
  2. Apple devices will refuse to connect when 802.11r is enabled (they probably see the FT flag and go bonkers) AND WPA2+WPA3; they will connect to an AP with 802.11r only if it has WPA3
  3. in the end I just disabled 802.11r and reduced the station inactivity limit to 15 seconds, and roaming for some unknown reason is now working perfectly (I don't think the change to station inactivity limit has anything to do with it)
  4. I left "Dissociate on low ACK" enabled and set a reasonable "distance optimization" value
  5. reduced beacon intervals to 300ms
  6. didn't change pretty much anything else

I tested moving around with mobile devices and wifi signal is always 4/4 and I can see the client moving from one AP to the other.

I also tuned down the transmission power of the APs but didn't spend too much time on it, it seems good enough now. Not sure why the defaults are set to max transmission power but it definitely works fine with a few notches down.

Thanks all for the help!

I've heard it said, that the distance parameter probably does more harm than good, unless you are a pretty long distance away, like 100m or more. Not sure on that.

I did try the shared WPA2/3 recently, worked fine with everything except for one older Tivo recorder not being able to xfer files to the newer one, a non starter in my household! Connected, had net access, but it did not appear to the other Tivo's device list. Odd... Now running snapshot, may try it again.

Discard everything I said before, clients are sticking to whatever AP they are connecting first. I do not know what I observed before but cannot reproduce it.

As for the chipset choice: @eginnc I know have 2 APs that both use the ath10k driver and all Apple devices are disconnecting/reconnecting with the dreadfule "deauthenticated due to inactivity (timer DEAUTH/REMOVE)". I might ditch OpenWRT and use their stock firmware, since this issue has been around for years and can't find a solution.

Sorry to hear you're having trouble.

Both our home AP's are ath10k OpenWrt devices (an EA8500 and an EA6350v3). Currently they are running recent OpenWrt SNAPSHOT (r18394-962c585580); however, our Apple iPhone 8's and M1 Silicon Macbook Air have never had WiFi issues.

Does the "deauthenticated due to inactivity (timer DEAUTH/REMOVE)" issue occur only with roaming? As noted, we don't use roaming in our home.

I didn't enable roaming because the Apple devices would show other issues with it (I commented earlier about it), so this is without roaming. I created a new post about this: Ath10k: the dreadful bug "deauthenticated due to inactivity (timer DEAUTH/REMOVE)"

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.