Wifi repeater with WDS

Hello,

I have my AP running on the official Xiaomi R3P chineese firmware.
I have convert my Xiaomi AC2100 to openwrt.

Now, I want to make a wifi relay with the AC2100. All over wifi, so I try to use WDS howto https://openwrt.org/docs/guide-user/network/wifi/atheroswds#luci

It doesn't work. I only succeed by creating a new network, with new DHCP on the new range IP etc..

But I want to use my AP DHCP, DNS etc...

My Xiaomi R3P seems to be OK with WDS, so I think I'm wrong somewhere...

When I join my AP wifi with client(WDS) : I don't have internet on the openwrt ssh.
But If I join with Client mode ( not WDS ) : I have internet.

So I think, my problem is there...

Any ideas ?

Thank you

If it works without wds then use it !!!

my model config for wireless

=
config wifi-device 'radio1'
option type 'mac80211'
option channel '36'
option hwmode '11a'
option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0+1'
option htmode 'VHT80'
option cell_density '0'

config wifi-iface 'wifinet0'
option device 'radio1'
option mode 'sta'
option network 'lan'
option ssid 'Z100AX-186_58GHZ' master ap wifi
option encryption 'psk2'
option key 'mykeywifi'
option wds '1'
*

You can also add luci-proto-relay & use relayd

--
Remove DHCP for lan

Thank you.

But with my config I have a New range of IP and I have to change IP of my domotic.

If I use relayd, it's thé same problem. New range too :confused:

I think it's possible to work because I was using it before (stock xiaomi firmware) as wifi repeater and all was ok...

Both the AP and the station have to support WDS. Stock firmware does not support WDS. The "wifi repeater" mode found in stock firmware is usually based on something like relayd.

With relayd in repeater mode it is the same IP range

There is only for access to the Openwrt web page or it is not the same range

You have to disable the dhcp on the lan
Firewall is only for lan

ex:

IP computers group = 192.168.1.xxx same as my ISP router 192.168.1.1
Access to OpenWrt web page = 192.168.2.xxx
Master router ( AP ) is Livebox-954A
Also used for a printer connected via USB to the MT300

wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'MT300N-V2-230'
	option encryption 'psk2'
	option key '1234567890'
	option wpa_disable_eapol_key_retries '1'

config wifi-iface 'wifinet0'
	option device 'radio0'
	option mode 'sta'
	option network 'wwan'
	option ssid 'Livebox-954A'
	option key '1234567890'
	option encryption 'psk2'

network:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd5a:f069:7d4c::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.230'
	option delegate '0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '6t 1 0'

config interface 'STABRIDGE'
	option proto 'relay'
	list network 'lan'
	list network 'wwan'
	option delegate '0'

config interface 'wwan'
	option proto 'static'
	option ipaddr '192.168.1.230'
	option netmask '255.255.255.0'
	list dns '192.168.1.1'
	list dns '8.8.8.8'
	option delegate '0'
	option gateway '192.168.1.1'

Ok. I have to convert mu xiaomi r3p to openwrt too :slight_smile:
Thank you

Ok, I understand. I will try relayd.

After that, I think I will convert my r3p as AP in order to use wds and leave stock firmware.

Ps :
I have a livebox too. But I don't use it, I prefere to have my own box and use isp box as bridge.
I easier when I want to change ISP when deals come :slight_smile: