Wifi radio blocked when exchanging extra traffic

I'm working on a project that requires tests of connection via wifi.

by default my device wireless config is:


config wifi-device 'radio0'  
        option type 'mac80211'
        option channel '36'                                                                  
        option hwmode '11a'       
        option path 'scb/fd500000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0/usb2/2-1/2-1:1.0'
        option htmode 'VHT80'
        option disabled '0'       
                              
config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan' 
        option mode 'ap'        
        option ssid 'OpenWrt'
        option encryption 'none'

I added following iface station to be able to connect to the internet via radio0:


config wifi-iface 'wwan'        
        option network 'wwan'   
        option mode 'sta'    
        option country 'US'     
        option encryption 'psk2'
        option ssid 'myssid'
        option bssid 'xx:xx:xx:xx:xx:xx'
        option key 'mypassword'
        option device 'radio0'

and I added to the network config the section:


config interface 'wwan'
	option proto 'dhcp'

the connection to the internet works fine with this configuration.
my app call in an infinite loop the command "speedtest-cli --json" periodically (each 3 minutes)
After some time I remarked that I lose the connection.

if I check the ubus method network.wireless status I found that the radio0 is up
I tried to fix the issue by making up the interfaces wlan0 and wlan0-1 (ifconfig wlan0 up, ifconfig wlan0-1 up) but that doesn't fix the issue
I tried also by restarting network service, but unfortunately it doesn't fix the issue.
if I reboot the device the issue disappear.

the command that I called many times (speedtest-cli --json) exchange a lot of traffic with the internet so my first re-flexion is that i think for security purposes openwrt blocks access to radio0
I guess there's some option that I should set to my wifi-device 'radio0' section

Has someone an idea how I can fix this issue ?