WiFi on Xiaomi AX3000T is too weak when installing openWrt

Hello,
I bought a new router Xiaomi AX3000T chinease version i install openWrt on it without changing the boot (i am using the OEM one) the problem is my wifi signal i have a weak signal in same place the signal is good hwen using the stock rom.
alson when i do test speed with speed test i achieve 105Mbps with old rom and the new one i only get 96Mbps.
Please help me to got a good wifi signal because i don't find how to disable WPS in the stock rom.

Thank you OpenWrt Community

Go to luci/nwtwork/wireless and set your country code for each radio in upper section of access point editor.

i already set the country in both 2.5ghz and 5ghz

Post output of

ubus call system board
cat /etc/config/wireless <- take out wifi passwords

root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.150",
"hostname": "OpenWrt",
"system": "ARMv8 Processor rev 4",
"model": "Xiaomi Mi Router AX3000T",
"board_name": "xiaomi,mi-router-ax3000t",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.3",
"revision": "r23809-234f1a2efa",
"target": "mediatek/filogic",
"description": "23.05.3 240325"
}
}

and

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/18000000.wifi'
option channel 'auto'
option band '2g'
option htmode 'HT40'
option country 'US'
option cell_density '0'
option txpower '26'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'AP 2.4GHz'
option encryption 'sae-mixed'

config wifi-device 'radio1'
option type 'mac80211'
option path 'platform/18000000.wifi+1'
option channel '36'
option band '5g'
option htmode 'HE160'
option disabled '0'
option country 'US'
option cell_density '0'
option txpower '23'

config wifi-iface 'default_radio1'
option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'AP 5GHz'
option encryption 'sae-mixed'

Set 5GHz channel to auto and set both AP names to same. Client will choose best. Likely you get that from 2.4GHz which is busier one day than other.

the problem is even when i set a param it not applied to router for example th 40mhz channel width in 2.4g when i monitor the wifi with a phone it show me 20mhz

40MHz on 2.4GHz should only be used if there are no other networks. You can try forcing 40MHz by enabling "Force 40MHz mode" in the "Advanced settings" tab.

When using 802.11ax (wifi 6) using 20MHz on 2.4GHz with a similar device (same wifi chip, same SoC), with a wifi 6 client, I routinely get ~140Mbps.

i goin back to stock rom evn it has few customisations but the main feature of the router is wireless stability which is better in stock stock firmware