WiFi on x86_64, been at this for several hours, need help

I've never really played with linux and something like this is a bit out of my expertise. I thought it would be decently simple to just install OpenWRT on my old desktop PC and add a 4 port ethernet card, take my old router I was using, which is an Asus AC88U running Merlin, and turn it into a wireless access point, but this is actually a lot harder than I thought. It took me a few hours, but I was able to setup everything for my desktop PC to get internet. But my wireless just doesn't want to work. I tried, without knowing too much about what I was doing, setting it up as a dummy AP. But that didn't work. And then I tried just selecting the wireless AP option in the Asus menu. But everytime I go to connect wirelessly, it just says "couldn't get IP address" or "connected without internet" on any wireless device. Is there a specific thing I'm supposed to do to get this old router running as a wireless access point on my new X86 desktop router? I'm not even really sure on how the interface ethernet port option should be set up for Wifi. It automatically did it for me for WAN and LAN so I was pretty set but WiFi is getting me confused. Setting it to static or DHCP did not work either. Been at this for a few hours, any help would be appreciated.


First u need to make sure the router is working properly, only then start working on the AP.

From ur description, it looks like the AP isn't bridging the connection to the router so that the device get a IP address lease from the router's DHCP server.

Try to connect a device directly to the router and set it to receive IP automatically, this way u can test if router's DHCP server is working. Preferably, do it with a laptop that has a RJ45 port, so that u can use it to test the router now and also use it later to test WiFi.

1 Like

A router port for a dumb AP is just a LAN port. If you can connect Ethernet from a laptop to the port and have it automatically obtain an IP address in the LAN range, and connect to the Internet, the port is ready to use for an AP.

In other words, in the "dumb AP" role, the AP device is merely a wireless to wired converter. Since your AP is not running OpenWrt we can't help much there.

In the typical home network you don't want a separate network for wifi. All users wired or wireless should be part of the same LAN so they can readily share files, printers, etc. To do this on an x86, expand the existing LAN network in bridge mode by adding ports to it on the Physical Devices tab. This is a software based equivalent to an unmanaged hardware switch.


Welcome! Based on the quote above, it may be better for you to ask a question on the Merlin forum on how to turn a Merlin-flashed router to a dumb AP. It shouldn't be that hard, you'll need to figure out how to turn off dnsmasq on Merlin and then just make sure you connect LAN port on your new "wired" router to the LAN port on the Merlin router.

1 Like

Link to instructions of configuring ASUS brand routers as access point: ASUS and another ASUS

1 Like

Got it working! Thank you everyone! I wasn't configuring the ports correctly. Reading the comments above clued me in and I got done with it. Everything is running great!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.