WIFI not working - Could not find PHY for device

Hi guys,
I was playing with my old router D-LINK DSL 2741-EU-F1 version and flashed it to OpenWrt 18.06.1 but I have problem with starting wifi and scanning for wireless network too. Wifi was working before, I have tested it before flashing. In LUCI GUI scanning is also not working but this is probably expected because wlan interface is not started. In GUI

I see :
Network -> Wireless:

phy0
Generic 802.11 Wireless Controller
Channel: ? (? GHz) | Bitrate: ? Mbit/s

Signal
SSID: openWrt | Mode: Master
Wireless is not associated

Trying to resolve this issue for 3 days but no luck. Maybe somebody had similar issue with
enabling wifi on this router.

My configuration is:
OpenWrt 18.06.1
Linux OpenWrt 4.9.120 #0 Wed Aug 15 20:42:39 2018 mips GNU/Linux

/etc/config/wireless

config wifi-device 'phy0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '11'
	option txpower '18'
	option htmode 'HT40'
	option country '00'
	option phy 'phy0'
	option disabled '0'

config wifi-iface 'wlan0'
	option device 'phy0'
	option mode 'ap'
	option ssid 'openWrt'
	option macaddr '14:D6:4D:F3:BD:92'
	option network 'lan'

cat /etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd84:9f36:3e18::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 8t'

config interface 'wlan0'
	option proto 'static'
	option ipaddr '192.168.1.9'
	option netmask '255.255.255.0'

When trying wifi up I get:

Thu Dec 07 21:18:48 2018 daemon.notice netifd: phy0 (1603): Could not find PHY for device 'phy0'
Thu Dec 07 21:18:48 2018 daemon.notice netifd: phy0 (1610): WARNING: Variable 'data' does not exist or is not an array/object

wifi status:

root@OpenWrt:~# wifi status
{
	"phy0": {
		"up": false,
		"pending": false,
		"autostart": true,
		"disabled": false,
		"retry_setup_failed": true,
		"config": {
			"hwmode": "11g",
			"path": "pci0000:00\/0000:00:00.0\/0000:01:00.0",
			"channel": "11",
			"txpower": 18,
			"htmode": "HT40",
			"country": "00",
			"phy": "phy0",
			"disabled": false
		},
		"interfaces": [
			{
				"section": "wlan0",
				"config": {
					"mode": "ap",
					"ssid": "openWrt",
					"macaddr": "14:D6:4D:F3:BD:92",
					"mode": "ap",
					"network": [
						"lan"
					]
				}
			}
		]
	}
}

Anyway I am not sure about "txpower": 18 and "htmode": "HT40" but I have also tried various
config combinations with no luck either.
I have also tried to flash it to different versions LEDE or OWrt but still same issue.

If would be very appreciated if somebody help with this.
Thanks

After you've backed up and downloaded your config to a safe spot...

I'm guessing you upgraded from an older version of OpenWrt. If so, the entries in that old config may "just wrong" for the newer version. This is especially true if you have come from a version prior to v17.

Resetting your config will generate new defaults, that you can then configure from there.

1 Like

Hi Jeff, thanks for the reply. No, I was not upgrading from old OpenWrt, I had original firmware from D-Link. Shame is, that I don`t have backup from original firmware. Probably I might find something on D-link webpages but I want to have router "Opened".

I think it maybe related to driver issue, another thread on this forum also mentioned about installing Openwrt on a Dlink 2750 where wifi driver was not available and wifi wouldn't load, so a custom image was the only option. You may wanna try search to see if you can fix it through a custom image with those drivers included.

Please use the code option to put your config in the thread, </> icon on top.

Thanks. I`ll have a look again for similar thread.

So, I have tried to flash it back to stock version but again with no luck, and ended up with "bricked" router :slight_smile: Anyway, was able to re-flash it back after it was stuck on some weird loop, via serial/UART. I was surprised how easy it was. I checked few forums regarding the generic flashing but they did not covered the process. Anyway, problem with WIFI still persists and probably I will not be able to start it up. :worried:

Also read few threads here but nothing what I have found worked in my case.
Today I have also tried to flash it back to 15.05.1, connected it to internet and tried to "opkg update" and install packages related to wifi "kmod-ath9k ....but still no WIFI.

Is there somebody who was able to compile custom image for this router?
Jan

Do you know what wifi chip is in there? It might be helpful to identify the correct driver.

yes, there is Atheros AR9287.

I have a similar problem with a similar wifi-chip (AR9580). Could you please post your Kernel-Log ?

maxl95

Kernel.log

[    0.000000] Linux version 4.9.120 (buildbot@builds-03.infra.lede-project.org) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r7102-3f3a2c9) ) #0 Wed Aug 15 20:42:39 2018
[    0.000000] Detected Broadcom 0x6328 CPU revision b0
[    0.000000] CPU frequency is 320 MHz
[    0.000000] 64MB of RAM installed
[    0.000000] board_bcm963xx: Boot address 0xb8000000
[    0.000000] board_bcm963xx: CFE version: 1.0.37-106.5
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0002a075 (Broadcom BMIPS4350)
[    0.000000] board: board name: AW4339U
[    0.000000] MIPS: machine is D-Link DSL-2740B/DSL-2741B rev F1
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 04000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 16 bytes.
[    0.000000] Primary data cache 32kB, 2-way, VIPT, cache aliases, linesize 16 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000] free_area_init_node: node 0, pgdat 80432a64, node_mem_map 81005750
[    0.000000]   Normal zone: 128 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 16256
[    0.000000] Kernel command line: rootfstype=squashfs,jffs2 noinitrd console=ttyS0,115200
[    0.000000] PID hash table entries: 256 (order: -2, 1024 bytes)
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Memory: 59104K/65536K available (3484K kernel code, 180K rwdata, 576K rodata, 1256K init, 217K bss, 6432K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=16, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:256
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 11945377789 ns
[    0.000021] sched_clock: 32 bits at 160MHz, resolution 6ns, wraps every 13421772796ns
[    0.008112] Calibrating delay loop... 319.74 BogoMIPS (lpj=639488)
[    0.046792] pid_max: default: 32768 minimum: 301
[    0.051831] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.058627] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.076235] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 7645041785100000 ns
[    0.086314] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.092757] pinctrl core: initialized pinctrl subsystem
[    0.101392] NET: Registered protocol family 16
[    0.113591] Can't analyze schedule() prologue at 80373764
[    0.349863] registering PCI controller with io_map_base unset
[    0.390975] PCI host bridge to bus 0000:00
[    0.395239] pci_bus 0000:00: root bus resource [mem 0x10f00000-0x10ffffff]
[    0.402305] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.409291] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.416280] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.424506] pci 0000:00:00.0: [14e4:6328] type 01 class 0x060400
[    0.424638] pci 0000:00:00.0: PME# supported from D0 D3hot
[    0.425082] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.433684] pci 0000:01:00.0: [168c:ff1c] type 00 class 0x020000
[    0.433761] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x0000ffff 64bit]
[    0.433969] pci 0000:01:00.0: supports D1
[    0.433989] pci 0000:01:00.0: PME# supported from D0 D1 D3hot
[    0.434430] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.434472] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 01
[    0.434541] pci 0000:00:00.0: BAR 8: assigned [mem 0x10f00000-0x10ffffff]
[    0.441570] pci 0000:01:00.0: BAR 0: assigned [mem 0x10f00000-0x10f0ffff 64bit]
[    0.449107] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.454206] pci 0000:00:00.0:   bridge window [mem 0x10f00000-0x10ffffff]
[    0.469387] clocksource: Switched to clocksource MIPS
[    0.477588] NET: Registered protocol family 2
[    0.484167] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.491460] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.498062] TCP: Hash tables configured (established 1024 bind 1024)
[    0.505084] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.511196] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.518206] NET: Registered protocol family 1
[    0.522832] pci 0000:01:00.0: invalid calibration data
[    0.528134] PCI: CLS 0 bytes, default 16
[    0.537277] Crashlog allocated RAM at address 0x3f00000
[    0.546003] workingset: timestamp_bits=30 max_order=14 bucket_order=0
[    0.569269] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.575312] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.615670] io scheduler noop registered
[    0.619732] io scheduler deadline registered (default)
[    0.626871] bcm6328-pinctrl 10000080.pin-controller: registered at mmio b0000080
[    0.636011] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[    0.642712] 10000100.serial: ttyS0 at MMIO 0x10000100 (irq = 36, base_baud = 1562500) is a bcm63xx_uart
[    0.652462] console [ttyS0] enabled
[    0.659616] bootconsole [early0] disabled
[    0.685096] m25p80 spi1.0: mx25l6405d (8192 Kbytes)
[    0.691052] bcm63xxpart: Partition 0 is CFE offset 0 and length 10000
[    0.697714] bcm63xxpart: Partition 1 is nvram offset 7e0000 and length 20000
[    0.704951] bcm63xxpart: Partition 2 is linux offset 10000 and length 7d0000
[    0.712277] 3 bcm63xxpart partitions found on MTD device spi1.0
[    0.718384] Creating 3 MTD partitions on "spi1.0":
[    0.723306] 0x000000000000-0x000000010000 : "CFE"
[    0.731637] 0x0000007e0000-0x000000800000 : "nvram"
[    0.740874] 0x000000010000-0x0000007e0000 : "linux"
[    0.751333] parser_imagetag: rootfs: CFE image tag found at 0x0 with version 6, board type AW4339U
[    0.760616] parser_imagetag: Partition 0 is kernel offset 100 and length 15b3c4
[    0.768135] parser_imagetag: Partition 1 is rootfs offset 15b4c4 and length 674b3c
[    0.775924] parser_imagetag: Spare partition is offset 3a0004 and length 42fffc
[    0.783542] 2 bcm963xx-imagetag partitions found on MTD device linux
[    0.790100] Creating 2 MTD partitions on "linux":
[    0.794936] 0x000000000100-0x00000015b4c4 : "kernel"
[    0.803609] 0x00000015b4c4-0x0000007d0000 : "rootfs"
[    0.812963] mtd: device 4 (rootfs) set to be root filesystem
[    0.819964] 1 squashfs-split partitions found on MTD device rootfs
[    0.826369] 0x0000003a0000-0x0000007d0000 : "rootfs_data"
[    0.837207] libphy: Fixed MDIO Bus: probed
[    0.886775] b53_common: found switch: BCM63xx, rev 0
[    0.892425] bcm63xx-wdt bcm63xx-wdt:  started, timer margin: 30 sec
[    0.903479] NET: Registered protocol family 10
[    0.920663] NET: Registered protocol family 17
[    0.925423] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    0.938763] 8021q: 802.1Q VLAN Support v1.8
[    0.955403] VFS: Mounted root (squashfs filesystem) readonly on device 31:4.
[    0.979603] Freeing unused kernel memory: 1256K
[    0.984281] This architecture does not have kernel memory protection.
[    0.998874] random: fast init done
[    2.091443] init: Console is alive
[    2.095323] init: - watchdog -
[    3.612320] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.747384] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.765590] init: - preinit -
[    5.188676] random: jshn: uninitialized urandom read (4 bytes read)
[    5.279186] random: jshn: uninitialized urandom read (4 bytes read)
[    5.525345] random: jshn: uninitialized urandom read (4 bytes read)
[    6.397900] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 2, 100Mbps, full-duplex
[    6.407003] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    6.413195] IPv6: ADDRCONF(NETDEV_UP): eth0.1: link is not ready
[    6.419901] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[    6.545988] urandom_read: 2 callbacks suppressed
[    6.546004] random: procd: uninitialized urandom read (4 bytes read)
[    7.401435] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   10.035298] jffs2: notice: (347) jffs2_build_xattr_subsystem: complete building xattr subsystem, 0 of xdatum (0 unchecked, 0 orphan) and 0 of xref (0 dead, 0 orphan) found.
[   10.055314] mount_root: switching to jffs2 overlay
[   10.123449] urandom-seed: Seeding with /etc/urandom.seed
[   10.371425] procd: - early -
[   10.374602] procd: - watchdog -
[   11.110720] procd: - watchdog -
[   11.114479] procd: - ubus -
[   11.271573] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.284786] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.292071] random: ubusd: uninitialized urandom read (4 bytes read)
[   11.300516] procd: - init -
[   12.113574] kmodloader: loading kernel modules from /etc/modules.d/*
[   12.130037] ip6_tables: (C) 2000-2006 Netfilter Core Team
[   12.158186] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[   12.166466] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[   12.179668] ip_tables: (C) 2000-2006 Netfilter Core Team
[   12.203731] nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
[   12.314763] xt_time: kernel timezone is -0000
[   12.446641] PPP generic driver version 2.4.2
[   12.456205] NET: Registered protocol family 24
[   12.546698] kmodloader: done loading kernel modules from /etc/modules.d/*
[   16.985576] random: crng init done
[   16.989029] random: 1 urandom warning(s) missed due to ratelimiting
[   29.021894] bcm63xx_enetsw bcm63xx_enetsw.0: link UP on Port 2, 100Mbps, full-duplex
[   29.039960] br-lan: port 1(eth0.1) entered blocking state
[   29.045554] br-lan: port 1(eth0.1) entered disabled state
[   29.051912] device eth0.1 entered promiscuous mode
[   29.056867] device eth0 entered promiscuous mode
[   29.068962] br-lan: port 1(eth0.1) entered blocking state
[   29.074552] br-lan: port 1(eth0.1) entered forwarding state
[   29.080605] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[   29.929771] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

A little google search shows that you need at least kernel 3.6 for the driver to work and that you also need mac80211 with it to identify the device. AFAIK v18.06.1 has kernel 4.* so it should probably work but maybe you are missing a driver somewhere.

You can also check what modules are availae in /etc/modules.d by ls /etc/modules.d/.

Here it is:


root@OpenWrt:/etc/modules.d# ls -alitr
    169 -rw-r--r--    1 root     root             6 Aug 16 07:51 pppoe
    175 -rw-r--r--    1 root     root            10 Aug 16 07:51 ppp
    174 -rw-r--r--    1 root     root            15 Aug 16 07:51 nf-reject6
    173 -rw-r--r--    1 root     root            15 Aug 16 07:51 nf-reject
    184 -rw-r--r--    1 root     root            58 Aug 16 07:51 nf-nat
    182 -rw-r--r--    1 root     root            11 Aug 16 07:51 nf-ipt6
    171 -rw-r--r--    1 root     root            19 Aug 16 07:51 nf-ipt
    170 -rw-r--r--    1 root     root            33 Aug 16 07:51 nf-conntrack6
    179 -rw-r--r--    1 root     root            67 Aug 16 07:51 nf-conntrack
    183 -rw-r--r--    1 root     root            10 Aug 16 07:51 lib-crc-ccitt
    181 -rw-r--r--    1 root     root            46 Aug 16 07:51 ipt-nat
    180 -rw-r--r--    1 root     root           150 Aug 16 07:51 ipt-core
    172 -rw-r--r--    1 root     root            28 Aug 16 07:51 ipt-conntrack
    177 -rw-r--r--    1 root     root             6 Aug 16 07:51 ath9k
    176 -rw-r--r--    1 root     root            56 Aug 16 07:51 42-ip6tables
    178 -rw-r--r--    1 root     root            20 Aug 16 07:51 30-gpio-button-hotplug
    367 drwxr-xr-x    2 root     root           294 Aug 16 07:51 .
    169 drwxr-xr-x    1 root     root             0 Aug 16 10:14 ..

Do you have kmod-mac80211 installed?

Yes, this is installed:

root@OpenWrt:~# opkg list
base-files - 192-r7258-5eb055306f
busybox - 1.28.3-4
dnsmasq - 2.80test3-1
dropbear - 2017.75-5
firewall - 2018-07-26-aa8846bb-1
fstools - 2018-04-16-e2436836-1
fwtool - 1
hostapd-common - 2018-04-09-fa617ee6-5
ip6tables - 1.6.2-1
iptables - 1.6.2-1
iw - 4.14-1
iwinfo - 2018-07-24-94b1366d-1
jshn - 2018-07-25-c83a84af-1
jsonfilter - 2018-02-04-c7e938d6-1
kernel - 4.9.120-1-7a4b0f906e06395a70836273e362965a
kmod-ath - 4.9.120+2017-11-01-9
kmod-ath9k - 4.9.120+2017-11-01-9
kmod-ath9k-common - 4.9.120+2017-11-01-9
kmod-cfg80211 - 4.9.120+2017-11-01-9
kmod-gpio-button-hotplug - 4.9.120-2
kmod-ip6tables - 4.9.120-1
kmod-ipt-conntrack - 4.9.120-1
kmod-ipt-core - 4.9.120-1
kmod-ipt-nat - 4.9.120-1
kmod-lib-crc-ccitt - 4.9.120-1
kmod-mac80211 - 4.9.120+2017-11-01-9
kmod-nf-conntrack - 4.9.120-1
kmod-nf-conntrack6 - 4.9.120-1
kmod-nf-ipt - 4.9.120-1
kmod-nf-ipt6 - 4.9.120-1
kmod-nf-nat - 4.9.120-1
kmod-nf-reject - 4.9.120-1
kmod-nf-reject6 - 4.9.120-1
kmod-ppp - 4.9.120-1
kmod-pppoe - 4.9.120-1
kmod-pppox - 4.9.120-1
kmod-slhc - 4.9.120-1
libblobmsg-json - 2018-07-25-c83a84af-1
libc - 1.1.19-1
libgcc - 7.3.0-1
libip4tc - 1.6.2-1
libip6tc - 1.6.2-1
libiwinfo - 2018-07-24-94b1366d-1
libiwinfo-lua - 2018-07-24-94b1366d-1
libjson-c - 0.12.1-1
libjson-script - 2018-07-25-c83a84af-1
liblua - 5.1.5-1
liblucihttp - 2018-05-18-cb119ded-1
liblucihttp-lua - 2018-05-18-cb119ded-1
libnl-tiny - 0.1-5
libpthread - 1.1.19-1
libubox - 2018-07-25-c83a84af-1
libubus - 2018-07-26-40e0931e-1
libubus-lua - 2018-07-26-40e0931e-1
libuci - 2018-08-11-4c8b4d6e-1
libuclient - 2018-08-03-ae1c656f-1
libxtables - 1.6.2-1
logd - 2018-02-14-128bc35f-2
lua - 5.1.5-1
luci - git-18.228.31946-f64b152-1
luci-app-firewall - git-18.228.31946-f64b152-1
luci-base - git-18.228.31946-f64b152-1
luci-lib-ip - git-18.228.31946-f64b152-1
luci-lib-jsonc - git-18.228.31946-f64b152-1
luci-lib-nixio - git-18.228.31946-f64b152-1
luci-mod-admin-full - git-18.228.31946-f64b152-1
luci-proto-ipv6 - git-18.228.31946-f64b152-1
luci-proto-ppp - git-18.228.31946-f64b152-1
luci-theme-bootstrap - git-18.228.31946-f64b152-1
mtd - 23
netifd - 2018-07-30-a0a1e52e-1
odhcp6c - 2018-07-14-67ae6a71-14
odhcpd-ipv6only - 1.10-1
openwrt-keyring - 2018-05-18-103a32e9-1
opkg - 2017-12-07-3b417b9f-2
ppp - 2.4.7-12
ppp-mod-pppoe - 2.4.7-12
procd - 2018-03-28-dfb68f85-1
rpcd - 2018-08-16-41333abe-1
rpcd-mod-rrdns - 20170710
swconfig - 11
ubox - 2018-02-14-128bc35f-2
ubus - 2018-07-26-40e0931e-1
ubusd - 2018-07-26-40e0931e-1
uci - 2018-08-11-4c8b4d6e-1
uclient-fetch - 2018-08-03-ae1c656f-1
uhttpd - 2018-06-26-796d42bc-1
usign - 2015-07-04-ef641914-1
wireless-regdb - 2017-10-20-4343d359
wpad-mini - 2018-04-09-fa617ee6-5

Well as it seems, it's a driver related issue. Does your device get identified through ls pci? You may need to install pciutils for this. And according to this your device should be supported so I have no idea why it is not working yet.

I have installed pciutils and with lspci command I see this:

root@OpenWrt:~# lspci
00:00.0 PCI bridge: Broadcom Limited Device 6328
01:00.0 Ethernet controller: Qualcomm Atheros AR5008 Wireless Network Adapter (rev 01)

Any idea why it is still not ok?
Thanks

The above linked page refers to AR5008 as supported device but also lists some devices which are supported. I am not sure if your device is within those listed as supported so it is possible that the device is not supported at all or the device was supported with some earlier version of kernel (because it was working within the OEM firmware) and is not working now. I have seen most OEMs use around v2.6 or above for Linux kernels so it is possible there is no further support but I could be wrong.

My advice to you is to flash the OEM firmware and use that until you get a fix for the Wi-Fi because without Wi-Fi a router is pretty much not usable.

Hi Guys
Is the router maybe running out of RAM?
I have had very similar symptoms with Ubiquiti Bullet/airGateway/Nanostation devices with 32MB ram caused by not enough free ram to load the wifi driver once I had installed a couple of other packages.
I fixed it using Imagebuilder and making an image with luci and ipv6 removed.
Just a thought.

Hi mates I got same problem like you but with different hardware, you must install kernel driver for your device AR5008, by me it was for wireless device QCA9984 and when I installed "opkg install kmod-ath10k-ct" the radio started working.

AR5008 (draft-N) would need ath9k, not ath10k-ct.