WIFI not turning on Repeater / Client Mode

Device: WAVLINK WN570HA1 AC600
OpenWRT Version: 23.05.0
(Screenshots Attached & Logs)

ISSUE: Not Broadcasting Wi-Fi after following the guide for setting up "Connect to client Wi-Fi network"

Details
I successfully flashed OpenWrt on to this device using TFTP.

I then followed the official guide to setup the router as a repeater which would be "Connect to client Wi-Fi network" I believe...

Unfortunately after following the guide, the router is not broadcasting any Wireless ssids. Also at the end of that guide it shows that there should be a network or something showing up underneath " Associated stations" in the wireless tab, and mine shows nothing.

I tried resetting the router back to OpenWrt defaults and following the a few times but still have the same outcome...

I've attached some screenshots of both the Instances Tab & Wireless Tab. The System and Kernel logs are posted a few msgs below.

So if somebody could please help I would greatly appreciate it. Thx Alot

Instances Tab

Wifi Tab

Please replace your images with text based configs:

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

OK I'll post them shortly

The wireless file is missing. Please post thst, too.

root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.134",
"hostname": "OpenWrt",
"system": "MediaTek MT7628AN ver:1 eco:2",
"model": "Wavlink WL-WN570HA1",
"board_name": "wavlink,wl-wn570ha1",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.0",
"revision": "r23497-6637af95aa",
"target": "ramips/mt76x8",
"description": "OpenWrt 23.05.0 r23497-6637af95aa"
}
}

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fd42:redacted:3b20::/48'

config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'

config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'

config device
option name 'eth0.2'
option macaddr 'hidden'

config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'

config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'

config interface 'wwan'
option proto 'dhcp'


root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'

config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'

config dhcp 'wan'
option interface 'wan'
option ignore '1'

config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'


root@OpenWrt:~# cat /etc/config/firewall

config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'

config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan6'
list network 'wwan'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'

config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'


root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
option type 'mac80211'
option path 'platform/10300000.wmac'
option channel '1'
option band '2g'
option htmode 'HT20'
option disabled '1'

config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

config wifi-device 'radio1'
option type 'mac80211'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option channel '36'
option band '5g'
option htmode 'VHT80'
option cell_density '0'

config wifi-iface 'wifinet2'
option device 'radio1'
option mode 'sta'
option network 'wwan'
option ssid 'CheApAss'
option encryption 'psk2'
option key 'hidden'

The MT7610E driver (I presume the driver, but can be something related) has been really bad up until now. There has been outstanding bugs preventing it from being usable, including client mode, although it might have manifested itself differently to a number of people.Try searching on github for more information.

But it has been mostly fixed in snapshot or 23.05-snapshot, meaning the fixes are not in the current 23.05.3 release but will be in 23.05.4.

I have a rp-ac52 (same as rp-n53 but with mt7610e ac radio instead of the N-radio. It’s not officially supported in OpenWrt yet) which had the same problems. Although the tx power is a little higher than before, it still seems much lower than what you’d normally expect (9-12dBm, you’d expect 20-23-ish dBm, but I don’t know if it’s actually accurate or not), it seems to work fine although I haven’t tested it’s actual range yet.

Try to flash 23.05-snapshot and report back.

Hey thx Alot!

Upon finding 23.05.03 (stable) for the WN570HA1 using the Owrt Firmware Selector, there is 2 options to download.

KERNAL OR SYSIMAGE

Im assuming I just need to download the SYSIMAGE correct?

Im currently on firmware 23.05.0

Thx!

Sysupgrade file.
But the fix isnt in 23.05.3. You have to choose 23.05-snapshot until 23.05.04 is released.

Seems 23.05-snapshot isnt supported by the online firmware selector. Just use snapshot instead.

1 Like

I think I found the right file...

releases/23.05-SNAPSHOT/targets/ramips/mt76x8

https://openwrt.tetaneutral.net/releases/23.05-SNAPSHOT/targets/ramips/mt76x8/

I believe I need to download the latest correct? There are other options as well so just wanted to confirm...

The above link is not from the OpenWrt project.

Use the one below if you want the latest official snapshot:
https://firmware-selector.openwrt.org/?version=SNAPSHOT&target=ramips%2Fmt76x8&id=wavlink_wl-wn570ha1

Oh, It looked like it was... Well im glad I asked then... :stuck_out_tongue_winking_eye:

Thank you for link. I really appreciate your help!

Yup...
just always make sure you're using stuff obtained from the domain openwrt.org (unless you have a specific reason to use a build from another source).

And the firmware selector makes it super easy to find and download the right images -- including customizing the included packages if/when needed.