Wifi not starting despite configuration seeming correct

Hi, I am trying to set up the wifi on OpenWrt so I can use the LuCi interface on my browser at I have edited the config file in /etc/config/wireless to set this up, and have ensured that radio0 and radio1 are not disabled. When I run the wifi command, nothing happens. I've noticed on startup it stalls and skips over all the br-wan set ups. It hangs for about 25 seconds so I presume it attempts to start these up, but fails. Is there any way I can check what the cause of this is? Or is there a setup step I missed? Any help would be appreciated, thank you.

Just log into LuCI and do it?

How can I log into LuCi? I have tried connecting an ethernet cable but it still does not allow me access in the browser.

Assuming you have LuCI installed then the next most likely thing is the web browser is probably interfering. Make sure the address is http not https. Try clearing the web browser cache and turning off auto complete. Also turning the NIC on/off will reinitialize it and help establish a connection.

Which OpenWrt release are we talking about?

Does LuCi not come preinstalled with the image? I am using version 17.01. I did try earlier to use the command 'opkg install luci' but it said it's not possible due to an unsatisfied dependency. However I assumed this didn't matter, as I have another machine that is set up with the wifi and it does not have the luci package installed, but I can use the LuCi browser interface. I have tried clearing cache and resetting the NIC, but no success.

What model hardware?

If you're using official builds (from downloads.openwrt.org), upgrade to a current version: 19.07 or 21.02-rc3.

If it's a third party or manufacturer build it may be quite different from the official builds that are discussed here.

So you can SSH to the device, but not access LuCi? Which means the core networking is OK but wireless is not.

Look closely at the wireless config for correct matching of quotes, and that some clever editor hasn't made changed single-quote(') for backtick (`), etc.

Hi, sorry for the late response. Just to say that I'm still exploring this issue, and the device I'm working with uses OpenC2X, which is based off of OpenWrt so I cannot update the OpenWrt version myself. I've got in contact with the developer and hoping to find a solution to it through his help.