Wifi no internet connection for a few minutes when waking device

Someone please help me figure out what is going on with my wifi. I run openwrt on a linksys 3200acm in bridge mode which seemed fine a while back but now the wifi (and seemingly only the wifi) is screwy. For example when you unlock a phone it will say connected to wifi but internet will not work for up to a minute or two (no pages load, apps like discord say connecting) but once it does get going its fine. Issue is most noticeable on my phone (android) and ipad i use but smart devices like my google homes will also have issues (sometimes they wont work properly when you talk to them, theyll say there was a glitch try again, or not that they cant find network, or to hold on while they reconnect). It's incredibly frustrating.

https://forum.openwrt.org/t/how-to-format-logs-scripts-configs-and-general-console-output/88905?u=flygarn12
First of all we need to handle your screen dump picture that only you can read.
Please follow the instructions in above link.

And you haven't much of the dhcp config in the picture.

The first thing that comes to my mind based on your description with the time of about 1minute is that about 1minute is in the zone for the dhcp server address lease agreement?
When this is done your internet starts to work?

Do you have something in the system log when this happens?

But the wrt3200acm also has a faulty wifi driver from factory and it will have that forever.

1 Like

Run logread -f while waking up the client.

I had initially tried to copy output but powershell doesnt keep that formatting so it was impossible to read. I don't have any logs from this right now, i was trying the logread -f but the issue seems like it doesnt always happen, or maybe device needs to be unused for a long enough period of time or something. I will try to update with those I don't know the timing of how long it takes for the device to get internet back either as it varies, sometimes takes 10-30s sometimes it seems like at least a minute. Sometimes my phone will actually say "connected without internet" but sometimes it doesnt show there is any issue, things just dont load for a bit.

cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ip6assign '60'
        option ipaddr '192.168.0.219'
        option gateway '192.168.0.1'
        list dns '1.1.1.1 '
        list dns '1.0.0.1'
        list dns '192.168.0.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1.2'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

cat /etc/config/firewall

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option synflood_protect '1'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fc00::/6'
        option dest_ip 'fc00::/6'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option htmode 'VHT80'
        option beacon_int '100'
        option channel 'auto'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option htmode 'HT20'
        option channel '7'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option key 'rumbluecircleroof'
        option ssid 'Wi_Fu'
        option encryption 'psk2'
        option wmm '0'
        option disassoc_low_ack '0'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wi_Fu'
        option wmm '0'
        option key 'rumbluecircleroof'
        option encryption 'psk2'
        option disabled '1'

config wifi-iface 'wifinet3'
        option encryption 'psk2'
        option device 'radio0'
        option mode 'ap'
        option key 'rumbluecircleroof'
        option ssid 'Wi_Fu_5GHz'
        option network 'lan'
        option dtim_period '3'
        option disassoc_low_ack '0'

cat /etc/config/dhcp

config dhcp 'lan'
        option start '100'
        option leasetime '12h'
        option limit '150'
        option interface 'lan'

Not really sure it has that much to do with the actual fault but is those lines all there is in the dhcp config file?
From OpenWRT 19.07.6 it should be a lot more config lines for the dnsmasq also in that file.

What version of openwrt do you run?

If you run this in Windows I recommend PuTTy instead.

Yes those dhcp are all the output, could it be because this is router in bridge mode? I did see these space errors while watching but i didnt really notice the issue happen. It looks like i'm on 19.07.5

OpenWrt 19.07.5, r11257-5090152ae3

Wed Oct 20 14:59:36 2021 daemon.notice hostapd: wlan0: AP-STA-DISCONNECTED d4:f5:47:3e:c3:d9
Wed Oct 20 14:59:36 2021 kern.debug kernel: [4431408.020706] ieee80211 phy0: staid 1 deleted
Wed Oct 20 14:59:43 2021 daemon.info hostapd: wlan0: STA d4:f5:47:3e:c3:d9 IEEE 802.11: associated (aid 1)
Wed Oct 20 14:59:43 2021 daemon.notice hostapd: wlan0: AP-STA-CONNECTED d4:f5:47:3e:c3:d9
Wed Oct 20 14:59:43 2021 daemon.info hostapd: wlan0: STA d4:f5:47:3e:c3:d9 WPA: pairwise key handshake completed (RSN)
Wed Oct 20 14:59:44 2021 daemon.info hostapd: wlan0: STA d4:f5:47:3e:c3:d9 IEEE 802.11: authenticated
Wed Oct 20 15:00:13 2021 kern.err kernel: [4431444.240212] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:14 2021 kern.err kernel: [4431445.138715] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:17 2021 kern.err kernel: [4431448.521444] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:17 2021 kern.err kernel: [4431448.527758] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:17 2021 kern.err kernel: [4431448.534061] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:17 2021 kern.err kernel: [4431448.540745] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:17 2021 kern.err kernel: [4431448.547042] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:18 2021 kern.err kernel: [4431449.784366] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:18 2021 kern.err kernel: [4431449.790703] ieee80211 phy0: fast: space 3774(46633) is not enough
Wed Oct 20 15:00:19 2021 kern.err kernel: [4431450.895403] ieee80211 phy0: fast: space 3774(46633) is not enough

I don’t remember seeing those kernel errors here in the forum before?
But we do know that the drivers for this device wifi has real issues. You could try upgrade to latest 19.07 or 21.02 (21.02 means DSA for that device so it demands a complete reconfig).
I believe there has been some work with the wifi drivers for 21.02 but I don’t know the status for those as for today.

I replaced my wifi on the wrt3200acm with external access point a couple of years back as the earlier releases of 19.07 made the wifi unstable.

You will want to follow this discussion in the forum. The 21.02 release has some incompatibility with the WRT3200ACM, 32X, and 1900 related to WiFi. One big issue is that the WiFi chipset firmware is a proprietary "blob" and the chip vendor is not making any updates to it.

In bridge / dumb AP mode, you shoud not be running a DHCP server at all...

Wrt3200acm wifi has incompatibility problems with everything, including Linksys original firmware.