WiFi lost in HG556a because of OpenWrt 18

What you have done looks OK

maybe try a renaming the file to something shorter e.g dummy.bin

hi @mbo2o
I did it but...

I obtain this from the console, with TFTP server active in IP

*** Press any key to stop auto run (3 seconds) ***
Auto run second count down: 3
web info: Waiting for connection on socket 0.
CFE> f
Loading ...
Loading failed.: CFE error -21
*** command status = -21

I have to say, I did this before and worked with this same model. I don't understand.

what does print command show ?


*** Press any key to stop auto run (3 seconds) ***
Auto run second count down: 3
web info: Waiting for connection on socket 0.
CFE> p
Board IP address                  :
Host IP address                   :
Gateway IP address                :
Run from flash/host (f/h)         : f
Default host run file name        : vmlinux
Default host flash file name      : bcm963xx_fs_kernel
Boot delay (0-9 seconds)          : 3
Boot image (0=latest, 1=previous) : 0
Board Id (0-5)                    : 96368MVWG_hg622
Number of MAC Addresses (1-32)    : 11
Base MAC Address                  : 00:e0:fc:09:09:09
PSI Size (1-64) KBytes            : 64
Main Thread Number [0|1]          : 0

*** command status = 0

Have you tried using the CFE miniweb interface

Yes. It doesn't work, it depends of CFE version and manufacturer options. This one doesn't have this option. That is the reason why you are advised to flash with "CFE_HG622-dummy_firmware.bin", to have a web interface in the future.
Anyway I got it finally.
I really do not know how. I have done the same thing more than twenty times, and now it has worked. What I believe is that the time window for the TFTP client to connect to the TFTP server is very small. What I think I can assure you, is that the TFTP client only activates if we have pressed the reset button before turning it on, and after turning it on we continue to press it until we reach the CFE console. I mean, if we turn on the router without pressing the reset button, we also access the CFE console, but the TFTP client will not be active.
Thank you anyway.

1 Like

Hey @tmomas
Can any moderator update the page https://openwrt.org/toh/huawei/hg622 with the information of this post?
The page https://openwrt.org/toh/huawei/hg655d has similar information. And it helped me a lot.
Thank you

You don't need an admin to update the page. It's a wiki, i.e. you can do it yourself. :slight_smile:

1 Like

Thank you to all the people who have read this topic, to all the people who wrote in this topic and, of course, to Willy. I'm very thank you. I'm looking forward to trying the procedure with my broken Huawei HG556a type C. Perhaps next monday. Thank you.

I guess you've been very careful, but be sure of the exact model. Model C has printed on the sticker VER.A, and if you follow the instructions of the Spanish website, it will work for you. But I have version 17.01.4 in that model, the later versions have not worked for me.
By the way, to the developers I would like to ask them why the stable versions 18.06.1 and 18.06.2 completely delete the partition cal_data, and the snapshot versions create it.

I opened the router and I know is the HG556a MX29GL128EH. I will try to recover WiFi now. Tomorrow I will write about the resukt. Thank you.

Be careful, Ralink use MX29GL128EH, but there is an Atheros with the same chip.
So if Ralink


But if Atheros



You are right. I was in mistake. My router is HG556a C (HG56BZRB VER.A) with chip MX29GL128EHT2I-90G and wireless Ralink RT3062F 802.11b/g/n (onboard).

@acamba This topic is about HG622. Feel free to open a new topic for HG556a.

friends hg556a 18.06 version and after the faulty calldata is deleted from you please request the next release

Hello Tmomas. I don't know how title changed but I think the post was started by me and my router :slight_smile:

Oooops :slight_smile: This is indeed suboptimal.
Please edit and change the topic according to your needs (something better than your initial topic).

My original title was different. Anyway, done :slight_smile:

Thank you for all. I'm very happy. Now I have functional WiFi again. Thank you to all and specially to Willy.

You are welcome @acamba . In these days I modified the web page of the HG622 router, and in the next few days, when I have less work, I will modify the web page of the HG556a router, to try to help to all that happened the same thing.