WiFi issues with Linksys WRT3200ACM

I have been using OpenWRT for quite long time and everthing was working fine. Recently, I upgrade to a new firmware and then I had WiFi issues.

Unfortunately, I haven't backup the setting before the upgrade and I don't remember what version I had.

I reset the router to default settings, as OpneWRT comes, but still no luck (can't find the networks, nor 5GHz neither 2.4GHz. when I do find, cannot connet to the network,.
My current settings:

Router: Linksys ACM3200WRT
OpenWRT version: 23.05.0

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
        option channel '36'
        option band '5g'
        option htmode 'VHT80'
        option country 'US'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'homeNet_5G'
        option encryption 'sae-mixed'
        option macaddr '60:38:e0:be:62:ea'
        option key 'q5oABwciUcmdQelpC'

config wifi-device 'radio1'
        option type 'mac80211'
        option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'
        option country 'US'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'homeNet'
        option encryption 'none'
        option macaddr '60:38:e0:be:62:e9'

config wifi-device 'radio2'
        option type 'mac80211'
        option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
        option channel '34'
        option band '5g'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'homeNet'
        option encryption 'none'

Any idea what went wrong?

These boxes are dual-partition devices.

Go back to your previous partition. luci/system/advanced reboot. Select Reboot to Alternate Partition.

This should put you back to your previous build, and from there you can Backup your old configuration.

Reboot back to 23.05.0, and then use your backup to restore your previous network settings.

FWIW, wifi is pretty well borked on this router series. Get yourself an access point and you’ll be a much happier user long term.

On the router, execute wifi status, and post the results here.

wifi status

{
        "radio0": {
                "up": true,
                "pending": false,
                "autostart": true,
                "disabled": false,
                "retry_setup_failed": false,
                "config": {
                        "path": "soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0",
                        "channel": "36",
                        "band": "5g",
                        "htmode": "VHT80",
                        "country": "US",
                        "cell_density": 0
                },
                "interfaces": [
                        {
                                "section": "default_radio0",
                                "ifname": "phy0-ap0",
                                "config": {
                                        "mode": "ap",
                                        "ssid": "homeNet_5G",
                                        "encryption": "sae-mixed",
                                        "macaddr": "60:38:e0:be:62:ea",
                                        "key": <masked>,
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap"
                                },
                                "vlans": [

                                ],
                                "stations": [

                                ]
                        }
                ]
        },
        "radio1": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": true,
                "retry_setup_failed": false,
                "config": {
                        "path": "soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0",
                        "channel": "1",
                        "band": "2g",
                        "htmode": "HT20",
                        "country": "US",
                        "disabled": true
                },
                "interfaces": [
                        {
                                "section": "default_radio1",
                                "config": {
                                        "mode": "ap",
                                        "ssid": "homeNet",
                                        "encryption": "none",
                                        "macaddr": "60:38:e0:be:62:e9",
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap"
                                },
                                "vlans": [

                                ],
                                "stations": [

                                ]
                        }
                ]
        },
        "radio2": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": true,
                "retry_setup_failed": false,
                "config": {
                        "path": "platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1",
                        "channel": "34",
                        "band": "5g",
                        "htmode": "VHT80",
                        "disabled": true
                },
                "interfaces": [
                        {
                                "section": "default_radio2",
                                "config": {
                                        "mode": "ap",
                                        "ssid": "homeNet",
                                        "encryption": "none",
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap"
                                },
                                "vlans": [

                                ],
                                "stations": [

                                ]
                        }
                ]
        }
}

After hours, the post here is the last try before buying a new WiFi APs.

It was just an option to recover your previously working wifi from your prior partition.

Are you only using the 5g radio? Radios1 and 2 are set disabled.

My final setup includes 3 networks: 5G for home users, 2.4G for home users and a Guest network.
But the 5G, neither the 2.4G are working. so I didn't configure it yet before I manage to get a stable network.

WPA2-PSK/WPA3-SAE (mixed mode) doesn’t play well with mvebu. WPA2-PSK would a better alternative.

4 Likes

For starters, both radio1 (2.4GHz) and radio2 (auxiliary) are explicitly disabled; you will not find anything on this band.

2 Likes

thank you guys.
I downgrade to 22.03.0-rc5
and also select for encryption WPA2-PSK as RuralRoots suggested.
Now it seems to be stable.

23.05.0, Is working well on my WRT 3200 here.
WPA3 does not work on the 3200 as stated above.
I would try the 23.05 again, with a full system reconfiguration and that should get you up and running.

Ken

3 Likes

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.