Wifi issue with r23769 on mt7621

R6220 (mt7621)
OpenWrt SNAPSHOT r23769-324673914d / LuCI Master git-23.223.85458-f7583b6

There is no wifi with latest snapshot. radios are not detected (device unkown). I used wifi config to reset, but the file is empty :face_with_raised_eyebrow:. I have reversed to a previous snapshot and everything is back to normal, so this is clearly software related. Could it be related to this recent commit?

I did a short test on a DAP-X1860 with OpenWrt 22.03.5 r20134-5f15225c1e / LuCI openwrt-22.03 branch git-23.119.80898-65ef406, there Wifi is working. MT7621 but with different wifi chips.

Issue is with the latest main snapshot, not 22.03.5. Something has changed lately that causes the issue, it had happened many times before.

You're right, I downloaded the latest release from the firmware selector. My bad :frowning:
Now I tried the current snapshot from the firmware selector and wifi is working

1 Like

Your device hasn't the same wifi chip (mt7915) than mine (mt7612). I remember another issue in june that affected mt7915 while not mt7612. Everyone gets a turn :wink:

1 Like

Which version are you upgrading from. I think at some point in owrt 23 the radio name in /etc/config/wireless changed from “wlan” to “wifi”.

A previous snapshot about one week old.
OpenWrt SNAPSHOT r23727-e6f8b69918 / LuCI Master git-23.223.85458-f7583b6

Hmmm that wouldn’t be it then.

I've just installed successfully 23.05.0.rc3 with kernel 5.15.127. It works fine, so it's not a kernel issue. The wifi part is 3 months old.
My guess is still that something has changed lately in the snapshot drivers. I'll try a snapshot again in a few days when wifi parts be updated.

Still the same issue with 30/08/2023 snapsnhot.

It's caused by https://github.com/openwrt/openwrt/commit/5356462ce54734afd32fce83ad118c58cfeb2a55.

More details:

1 Like

Oh thanks !
To keep it simple, radios do not get a MAC adress anymore? Any workaround possible?

Just revert the ref commit build your firmware again.

Actually it's not worthy, I can run 23.05rc3 instead. I mean that I'll wait for any next snapshot that includes the reversion. You have found the reason of the issue, it's fair enough.

@rmilecki Hi! Could you please rework this commit? It broke some devices with nvmem-base in dts.

1 Like

A commit has been released. This issue should be solved at next build. Thank you.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.