WiFi goes offline and then back online again intermittently

Hello, I've noticed an issue whereby my WiFi goes offline, and then back online again after ~30 seconds which happens about once per day.

This started happening after having added a second SSID (The 'xxx guest' SSID) to my access point. Prior to adding the second access point there were no such issues.

Any help would be much appreciated.

Details of my setup & logs are as follows:
Access point: TP Link EAP245v3
OpenWRT: 21.02.02

/etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd4e:648e:4872::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth0.1'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t 2 5'
	option vid '1'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 2t 5t'
	option vid '2'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'eth0.2'
	option bridge_empty '1'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'guest'
	option proto 'dhcp'
	option device 'br-guest'
	option hostname 'xxx-ap-1-guest'

/etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'pci0000:00/0000:00:00.0'
	option band '5g'
	option htmode 'VHT80'
	option country 'ZA'
	option cell_density '0'
	option channel '116'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/ahb/18100000.wmac'
	option band '2g'
	option htmode 'HT20'
	option country 'ZA'
	option cell_density '0'
	option channel '7'

config wifi-iface 'wifinet0'
	option device 'radio1'
	option mode 'ap'
	option ssid 'xxx'
	option encryption 'psk2'
	option key 'xxx'
	option network 'lan'

config wifi-iface 'wifinet1'
	option device 'radio0'
	option mode 'ap'
	option ssid 'xxx guest'
	option encryption 'none'
	option network 'guest'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'xxx'
	option encryption 'psk2'
	option key 'xxx'
	option network 'lan'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'xxx guest'
	option encryption 'none'
	option network 'guest'

Relevant logs:

Tue Mar 29 12:43:35 2022 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy1.conf (phy wlan1) --> new PHY
Tue Mar 29 12:43:35 2022 kern.info kernel: [   36.434146] br-lan: port 2(wlan1) entered blocking state
Tue Mar 29 12:43:35 2022 kern.info kernel: [   36.439734] br-lan: port 2(wlan1) entered disabled state
Tue Mar 29 12:43:35 2022 kern.info kernel: [   36.445538] device wlan1 entered promiscuous mode
Tue Mar 29 12:43:36 2022 daemon.notice hostapd: wlan1: interface state UNINITIALIZED->COUNTRY_UPDATE
Tue Mar 29 12:43:36 2022 kern.info kernel: [   36.626742] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
Tue Mar 29 12:43:36 2022 kern.info kernel: [   36.633542] br-lan: port 2(wlan1) entered blocking state
Tue Mar 29 12:43:36 2022 kern.info kernel: [   36.639077] br-lan: port 2(wlan1) entered forwarding state
Tue Mar 29 12:43:36 2022 daemon.notice hostapd: Configuration file: /var/run/hostapd-phy0.conf (phy wlan0) --> new PHY
Tue Mar 29 12:43:37 2022 kern.warn kernel: [   37.900610] ath10k_pci 0000:00:00.0: 10.4 wmi init: vdevs: 16  peers: 48  tid: 96
Tue Mar 29 12:43:37 2022 kern.warn kernel: [   37.908547] ath10k_pci 0000:00:00.0: msdu-desc: 2500  skid: 32
Tue Mar 29 12:43:37 2022 kern.info kernel: [   37.984539] ath10k_pci 0000:00:00.0: wmi print 'P 48/48 V 16 K 144 PH 176 T 186  msdu-desc: 2500  sw-crypt: 0 ct-sta: 0'
Tue Mar 29 12:43:37 2022 kern.info kernel: [   37.995876] ath10k_pci 0000:00:00.0: wmi print 'free: 31080 iram: 23028 sram: 9596'
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.343055] ath10k_pci 0000:00:00.0: rts threshold -1
Tue Mar 29 12:43:37 2022 kern.warn kernel: [   38.349062] ath10k_pci 0000:00:00.0: Firmware lacks feature flag indicating a retry limit of > 2 is OK, requested limit: 4
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.366378] br-guest: port 2(wlan0) entered blocking state
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.372249] br-guest: port 2(wlan0) entered disabled state
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.378257] device wlan0 entered promiscuous mode
Tue Mar 29 12:43:37 2022 daemon.notice hostapd: wlan0: interface state UNINITIALIZED->COUNTRY_UPDATE
Tue Mar 29 12:43:37 2022 daemon.notice hostapd: wlan0: interface state COUNTRY_UPDATE->HT_SCAN
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.394563] ath10k_pci 0000:00:00.0: NOTE:  Firmware DBGLOG output disabled in debug_mask: 0x10000000
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.432651] br-guest: port 3(wlan1-1) entered blocking state
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.438613] br-guest: port 3(wlan1-1) entered disabled state
Tue Mar 29 12:43:37 2022 kern.info kernel: [   38.444796] device wlan1-1 entered promiscuous mode
Tue Mar 29 12:43:38 2022 kern.info kernel: [   38.491122] br-guest: port 3(wlan1-1) entered blocking state
Tue Mar 29 12:43:38 2022 kern.info kernel: [   38.497020] br-guest: port 3(wlan1-1) entered forwarding state
Tue Mar 29 12:43:38 2022 kern.info kernel: [   38.549914] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1-1: link becomes ready
Tue Mar 29 12:43:38 2022 daemon.notice hostapd: wlan1: interface state COUNTRY_UPDATE->ENABLED
Tue Mar 29 12:43:38 2022 daemon.notice hostapd: wlan1: AP-ENABLED
Tue Mar 29 12:43:38 2022 kern.info kernel: [   38.987698] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Tue Mar 29 12:43:38 2022 kern.info kernel: [   38.994637] br-guest: port 2(wlan0) entered blocking state
Tue Mar 29 12:43:38 2022 kern.info kernel: [   39.000379] br-guest: port 2(wlan0) entered forwarding state
Tue Mar 29 12:43:38 2022 kern.info kernel: [   39.014721] br-lan: port 3(wlan0-1) entered blocking state
Tue Mar 29 12:43:38 2022 kern.info kernel: [   39.020457] br-lan: port 3(wlan0-1) entered disabled state
Tue Mar 29 12:43:38 2022 kern.info kernel: [   39.026451] device wlan0-1 entered promiscuous mode
Tue Mar 29 12:43:38 2022 kern.info kernel: [   39.050293] ath10k_pci 0000:00:00.0: rts threshold -1
Tue Mar 29 12:43:38 2022 kern.warn kernel: [   39.058405] ath10k_pci 0000:00:00.0: wmi: fixing invalid VHT TX rate code 0xff
Tue Mar 29 12:43:38 2022 kern.info kernel: [   39.066633] br-lan: port 3(wlan0-1) entered blocking state
Tue Mar 29 12:43:38 2022 kern.info kernel: [   39.072351] br-lan: port 3(wlan0-1) entered forwarding state
Tue Mar 29 12:43:38 2022 kern.warn kernel: [   39.196107] ath10k_pci 0000:00:00.0: failed to pull fw stats: -71
Tue Mar 29 12:43:39 2022 daemon.notice netifd: Wireless device 'radio0' is now up
Tue Mar 29 12:43:39 2022 kern.info kernel: [   40.199734] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
Tue Mar 29 12:43:39 2022 daemon.notice netifd: Network device 'wlan0' link is up
Tue Mar 29 12:43:39 2022 daemon.notice hostapd: wlan0: interface state HT_SCAN->ENABLED
Tue Mar 29 12:43:39 2022 daemon.notice hostapd: wlan0: AP-ENABLED
Tue Mar 29 12:43:39 2022 daemon.notice netifd: Network device 'wlan0-1' link is up
Tue Mar 29 12:43:39 2022 daemon.info hostapd: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Tue Mar 29 12:43:39 2022 daemon.notice netifd: Wireless device 'radio1' is now up
Tue Mar 29 12:43:39 2022 daemon.notice netifd: Network device 'wlan1' link is up

Try a non-DFS channel.

I believe that channel 116 is non-DFS for my country code (ZA) AFAICT: https://git.kernel.org/pub/scm/linux/kernel/git/sforshee/wireless-regdb.git/tree/db.txt?id=HEAD#n1729

1 Like

@lleachii in any case, what made you think to suggest trying a non-DFS channel? Are my logs akin to that of a DFS scan? And further, do you know if a DFS scan would bring down my WiFi temporarily as I described?

Correct -

It would...when radar on a DFS channel activates and is detected.

Your issue may be high usage of the channel in your area -

A WiFi analyzer app can show you who is using what channels in your area, your signal strength, and your signal-to-noise ratio (SNR).

Channel width can cause overlap.

As a test, try setting channel width to 40, then 20.

1 Like

Thanks for info and tips.

Your issue may be high usage of the channel in your area -
A WiFi analyzer app can show you who is using what channels in your area, your signal strength, and your signal-to-noise ratio (SNR).

Seems there are only two other 5GHz networks around me, both with a very low (< -80dbm) RSSI and on non-overlapping channels according to my WiFi analyzer.

Channel width can cause overlap.
As a test, try setting channel width to 40, then 20.

Same result of WiFi dropping with 40 and 20 widths.

What I have also tried is moving to channel 36 which does not seem to have this issue of the WiFi dropping. I wonder then if somehow my AP is still treating channel 116 as DFS, even though its not the case according to the reg db?

@anon89577378 any ideas?