WiFi fast roaming setup but devices prefer to stay on more distant AP

I have two dumb APs setup with identical SSID/password combos using fast roaming. There is a smart TV very close to one of the APs but it never connects to that particular AP. It always connects to the one much further away. When I look at the LuCI clients on the further AP, it has only two bars. I am wondering why it doesn't connect to the closer AP which I assume offers it a stronger signal.

For reference:

onfig wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/18000000.wmac'
	option channel '1'
	option band '2g'
	option cell_density '0'
	option txpower '14'
	option htmode 'HE20'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/18000000.wmac+1'
	option band '5g'
	option country 'US'
	option cell_density '2'
	option he_bss_color '8'
	option he_su_beamformee '1'
	option txpower '24'
	option beacon_int '100'
	option channel '100'
	option htmode 'HE160'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option network 'lan'
	option ssid 'MYSSID'
	option encryption 'sae-mixed'
	option key 'mypassword'
	option dtim_period '3'
	option wpa_disable_eapol_key_retries '1'
	option ieee80211w '2'
	option ieee80211r '1'
	option mobility_domain 'f457'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

I can force it to connect to the closer AP by turning the radio on the further one off.

802.11r does not always produce the desired result... some devices just don't work well with it enabled.

I usually recommend first tuning your APs for best standard (non-assisted) roaming... in many cases, this performs as well (or even better) than setups with 802.11r (including k/v/w) configured.

So, to start, I'd recommend turning off 802.11r and w and any 'roaming assist' technologies you've setup. Then, tune your APs... this video from Crosstalk Solutions does a good job of explaining how to do this (it uses Unifi as the example, but the concepts apply to all wifi, as long as you've got the appropriate controls).

1 Like

Thanks for the advice. My experience matches your description of the protocol at least in my use case. Perhaps if the two APs were further apart/bigger space it would preform better.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.