Wifi-Extender Setup help please

AP: AP121U (ALFA)
external Wifi-car: AR9271 (ALFA)

I am trying to set up a repeater.
However I am stuck now:
Managed to put the internal Wifi into Master(wlan0) and the external into Client-mode(wlan1) which is connected to the Network I want to repeat.

I am connected to the router through SerialUSB + MasterWIFI (internal-ap).

root@LEDE:/# ifconfig
eth1      Link encap:Ethernet  HWaddr 00:C0:CA:6F:01:14  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:4 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:88 errors:0 dropped:0 overruns:0 frame:0
          TX packets:88 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:7415 (7.2 KiB)  TX bytes:7415 (7.2 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:C0:CA:6F:01:16  
          inet addr:192.168.44.1  Bcast:192.168.44.255  Mask:255.255.255.0
          inet6 addr: fe80::2c0:caff:fe6f:116/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8185 errors:0 dropped:0 overruns:0 frame:0
          TX packets:635 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:664774 (649.1 KiB)  TX bytes:206006 (201.1 KiB)

wlan1     Link encap:Ethernet  HWaddr 00:C0:CA:72:67:A2  
          inet addr:192.168.0.19  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::2c0:caff:fe72:67a2/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1384 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7004 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:154433 (150.8 KiB)  TX bytes:686873 (670.7 KiB)

root@LEDE:/# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=57 time=16.095 ms
64 bytes from 8.8.8.8: seq=1 ttl=57 time=14.629 ms
64 bytes from 8.8.8.8: seq=2 ttl=57 time=15.680 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 14.629/15.468/16.095 ms

root@LEDE:/# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdb8:507a:4e00::/48'

config interface 'lan'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option auto '0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

config interface 'wan6'
        option ifname 'eth1'
        option proto 'dhcpv6'

config interface 'master'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.44.1'
        option netmask '255.255.255.0'

config interface 'client'
        option proto 'dhcp'

Now all I want is that TCP gets routed from the external Adapter to me, the client connected to the Master-AP.

In the GUI, under Physical Settings, on both, Client and Master, I checked "create a bridge over specified interfaces" and checked both Client and Master.
Unfortunatly that locks me out of the Router and I end up reflashing LEDE.

Bridge interfaces x creates a bridge over specified interface(s)
Interface
   Ethernet Adapter: "eth0" (lan)
   Ethernet Adapter: "eth1" (wan, wan6)
x Wireless Network: Master "b0x" (master)  
x Wireless Network: Client "manos222" (client)
   Custom Interface: 

I feel I am really close. Would be gratefull if someone could point me in the right direction.
Strange enough, the external card (client, wlan1) does not appear in /etc/config/network. why ?

there is a wifi-detect to detect new physical iface's . you should ensure that you installed correct kmod driver packages and reboot too, start doing a 'dmesg' when you plug it to see if it is detected and see the VID/PID and search for those to know which driver you need to install.

wifi detect # check output first to see if your USB WiFi dongle appears.
wifi detect > /etc/config/wireless # rewrite configuration

May be these could help too, you need something similar: https://gist.github.com/braian87b/821e9e4f399918510c55619192a31871 - https://gist.github.com/braian87b/8a524a8ad74a36407a8f481e9d16a5c9

There is a "travelmate" package now that allows to be able to keep a connection to the router even if it couldn't connect to the main AP. It is really useful on repeaters with only one wifi radio.

I recommend to start everything from scratch... first set up both wifi interfaces as AP to see if both work as intended when bridged to lan, then you could move one of them to wan as it appears on my notes and continue with the rest of setup.

WLANS don't show up in /etc/config/network...they show up in /etc/config/wireless

Thanks for the reply.
bridging 2 interfaces seems basic functionality, so shouldn´t it be done easily in the GUI ?

setup:
wlan0 (router): Mastermode with dhcp server 192.168.44.1
wlan1 (external card): dhcpclientmode 192.168.0.19

both are working and connected. router has internet-connection.
kmod-ath0k_btc module installed and working.

Shouldn´t checking master and client und physical interfaces and enable bridge mode already do the trick ? But if I do, I am getting locked out.
I need to set this up with urgency and happy to pay someone with paypal our crypto to spoon-feed me /ssh into the box. reply to: s.hunter@viajah.com.

No, bridging two wireless interfaces is not straightforward:
https://wiki.openwrt.org/doc/howto/clientmode

endless hours later:

echo 1 > /proc/sys/net/ipv4/ip_forward

#Reset iptables
iptables -F
iptables -X

iptables -A FORWARD -o wlan1 -i br-lan -s 192.168.0.0/24 -m conntrack --ctstate NEW -j ACCEPT
iptables -A FORWARD -m conntrack --ctstate ESTABLISHED,RELATED -j ACCEPT
iptables -A POSTROUTING -t nat -j MASQUERADE

in Firewall-Custom Rule did the trick !