Wifi & Ethernet backhaul for batman mesh?

I have a set of GL-Inet B2200 running 23.05 and they form a mesh network advertising several WiFi VLANs successfully. The main node 'gru' is connected to ethernet and ultimately all wifi traffic goes through gru. Each node advertises the SSIDs on 2.4 & 5Gz and there is a separate 5Ghz radio for the backhaul.

My problem is that one node 'bob' is quite remote and if a particular door is shut it loses the backhaul connection. It is close to an ethernet connection.

What I would like to do is connect 'bob' to the ethernet and use that as backhaul to 'gru'. Can I mix backhauls like this? The batman I have installed is
kmod-batman-adv 5.15.137+2023.1-4

On the ethernet is a separate OpenWRT box that handles connection to the internet and hands out local addresses on the LAN side so no B2200 directly connects to my ISP.

Here are the current network and wireless config files for gru & bob

# Bob Network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd37:c00e:5b9f::/48'
	option packet_steering '1'


config device
	option type 'bridge'
	option name 'br-home'
	list ports 'bat0.10'

config device
	option type 'bridge'
	option name 'br-work'
	list ports 'bat0.11'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'bat0.12'

config device                             
	option name 'br-default'
	option type 'bridge'
	list ports 'bat0.13'
	list ports 'eth0'

config device
	option name 'br-ios'
	option type 'bridge'
	list ports 'bat0.14'


config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option fragmentation '1'
        option gw_mode 'client'
        #option gw_sel_class '20'
        #option gw_bandwidth '100000/2000'
        option hop_penalty '30'
        option isolation_mark '0x00000000/0x00000000'
        option log_level '0'
        option multicast_mode '1'
        option multicast_fanout '16'
        option network_coding '0'
        option orig_interval '1000'

config interface 'mesh'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '1536'

config interface 'home'
	option proto 'static'
	option device 'br-home'
	option ipaddr '172.16.1.2'
	option netmask '255.255.255.0'
	option gateway '172.16.1.1'

config interface 'work'
	option proto 'static'
	option device 'br-work'
	option ipaddr '172.16.2.2'
	option netmask '255.255.255.0'
	option gateway '172.16.2.1'

config interface 'guest'
	option proto 'static'
	option ipaddr '172.16.3.2'
	option netmask '255.255.255.0'
	option device 'br-guest'
	option gateway '172.16.3.1'

config interface 'ios'
	option proto 'static'
	option ipaddr '172.16.4.2'
	option netmask '255.255.255.0'
	option device 'br-ios'
	option gateway '172.16.4.1'



config interface 'default'
    option device 'br-default'
	option proto 'static'
	option ipaddr '172.16.5.2'  ##static address on the new 172.16.5.0/24 network pool
	option netmask '255.255.255.0'
	option gateway '172.16.5.1'


config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 5 0'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 0'
# Bob Wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option channels '149 36'
	option band '5g'
	option htmode 'VHT80'
	option country 'GB'
	option txpower '23'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel '13'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '0'
	option country 'GB'

config wifi-iface 'wifinet6'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'home'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home-guest'
	option encryption 'psk2'
	option network 'guest'
	option key '<PASSWORD>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home-ios'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'ios'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option wps_pushbutton '1'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home-work'
	option network 'work'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option wps_pushbutton '1'

config wifi-iface 'wmesh'
	option device 'radio2'
	option network 'mesh'
	option mode 'mesh'
	option mesh_id 'MeshCloud'
	option encryption 'sae'
	option key '<PASSWORD>'
	option mesh_fwding '0'
	option mesh_ttl '1'
	option mcast_rate '24000'
	option disabled '0'

config wifi-iface 'wifinet7'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Home'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'home'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'


config wifi-iface 'wifinet8'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Home-work'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'work'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option wps_pushbutton '1'

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd37:c00e:5b9f::/48'
	option packet_steering '1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option reqaddress 'try'
	option reqprefix 'auto'
	option ip6assign '64'
	list ip6class 'wan6'



config device
	option type 'bridge'
	option name 'br-home'
	list ports 'bat0.10'

config device
	option type 'bridge'
	option name 'br-work'
	list ports 'bat0.11'

config device
	option type 'bridge'
	option name 'br-guest'
	list ports 'bat0.12'

config device                             
	option name 'br-default'
	option type 'bridge'
	list ports 'lan'
	list ports 'bat0.13'

config device
	option name 'br-ios'
	option type 'bridge'
	list ports 'bat0.14'

config interface 'bat0'
        option proto 'batadv'
        option routing_algo 'BATMAN_IV'
        option aggregated_ogms '1'
        option ap_isolation '0'
        option bonding '0'
        option bridge_loop_avoidance '1'
        option distributed_arp_table '1'
        option fragmentation '1'
        option gw_mode 'server'
        #option gw_sel_class '20'
        #option gw_bandwidth '10000/2000'
        option hop_penalty '30'
        option isolation_mark '0x00000000/0x00000000'
        option log_level '0'
        option multicast_mode '1'
        option multicast_fanout '16'
        option network_coding '0'
        option orig_interval '1000'

config interface 'mesh'
        option proto 'batadv_hardif'
        option master 'bat0'
        option mtu '1536'

config interface 'home'
	option proto 'static'
	option device 'br-home'
	option ipaddr '172.16.1.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	list ip6class 'wan6'


config interface 'work'
	option proto 'static'
	option device 'br-work'
	option ipaddr '172.16.2.1'
	option netmask '255.255.255.0'
	option ip6assign '64'
	list ip6class 'wan6'

config interface 'guest'
	option proto 'static'
	option ipaddr '172.16.3.1'
	option netmask '255.255.255.0'
	option device 'br-guest'

config interface 'ios'
	option proto 'static'
	option ipaddr '172.16.4.1'
	option netmask '255.255.255.0'
	option device 'br-ios'
	option ip6assign '64'
	list ip6class 'wan6'


config interface 'default'
	option device 'br-default'
	option proto 'static'
	option ipaddr '172.16.5.1'  ##static address on the new 172.16.5.0/24 network pool
	option netmask '255.255.255.0'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 5 0'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 0'

# Gru Wireless
config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option channels '149 36'
	option band '5g'
	option htmode 'VHT80'
	option country 'GB'
	option txpower '23'
	option cell_density '0'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'platform/soc/a000000.wifi'
	option channel '13'
	option band '2g'
	option htmode 'HT20'
	option cell_density '0'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/a800000.wifi'
	option channel '36'
	option band '5g'
	option htmode 'VHT80'
	option disabled '0'
	option country 'GB'

config wifi-iface 'wifinet6'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'home'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home-guest'
	option encryption 'psk2'
	option network 'guest'
	option key '<PASSWORD>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'

config wifi-iface 'wifinet4'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home-ios'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'ios'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option wps_pushbutton '1'

config wifi-iface 'wifinet5'
	option device 'radio1'
	option mode 'ap'
	option ssid 'Home-work'
	option network 'work'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option wps_pushbutton '1'

config wifi-iface 'wmesh'
	option device 'radio2'
	option network 'mesh'
	option mode 'mesh'
	option mesh_id 'MeshCloud'
	option encryption 'sae'
	option key '<PASSWORD>'
	option mesh_fwding '0'
	option mesh_ttl '1'
	option mcast_rate '24000'
	option disabled '0'

config wifi-iface 'wifinet7'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Home'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'home'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'


config wifi-iface 'wifinet8'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Home-work'
	option encryption 'psk2'
	option key '<PASSWORD>'
	option network 'work'
	option ieee80211r '1'
	option ft_over_ds '0'
	option ft_psk_generate_local '1'
	option wps_pushbutton '1'

Here is an excellent walk through of wired/wireless batman DIY MESH WiFi with batman-adv and OpenWrt

I used that when I originally set up the mesh, but I don't do well with video tutorials for a variety of reasons.

I think my mistake is that my main router 'heracles' is not part of the mesh and it probably needs to be to allow batman traffic through it between B2200s that happen to be wired in. This means that I also need to shift a lot of the responsibility 'gru' currently has onto 'heracles'. Once more into the breach.....

But what is your issue?
Sure you can run batman on wired only devices but technically it is not necessary.
Batman and batman adv was and is developed for wireless meshed networks. Yes you. Can also configure both, making batman aware of the wireless mesh interface and of a trunked Ethernet.
Pardon me but even after reading your post multiple times I fail to see the issue you are facing . Or are you just unsure and seek for confirmation?

I think I'm missing making batman aware of the ethernet so that two of my B2200 who cannot see each other over the 5GHz radio can see each other over the ethernet and maintain the connectivity. The diagram at this point https://youtu.be/t4A0kfg2olo?t=385 is what I think I need, but I'm getting lost in what I need to do it.

You do not need to use batman to use ethernet as backbone, You can just use vlans. Batman is needed only when you want to extend vlans over wireless.