Wifi drops after certain time (clients can't obtain IPs)

The router is World Vision Connect (Ukrainian brand), which is using MediaTek MT7620N chipset, according to the specs.

Model: WV-CONNECT
Firmware Version: OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530)
Kernel Version: 3.10.49

The intended setup is: optical wire -> modem -> router: wan interface (DHCP client) -> lan interface (DHCP server) which is linked to wifi -> Android/iOS/Windows clients.

I am trying to set up a wifi hotspot for a dozen clients. The problem currently is that after 2-3 hours or sooner if there are close to 8 clients connected, the wifi connection drops. Android phones are stuck at "Obtaining IPs" and my Windows 10 laptop shows as connected, but can't even access router GUI control panel (192.168.0.1). I haven't checked for SSH yet. After this happens, I can still use the internet and access the GUI control panel, if I connect via cable. Wifi works again only after rebooting.

What I've done during my last attempt to fix the problem:

  1. Set up regional settings, where I saw them.
  2. Removed ipv6 wan interface and IPv6 ULA-Prefix.
  3. Unchecked the authoritative DHCP flag.
  4. Changed the number of leased addresses (start 50, limit 150). The lease time is 12h.
  5. Set up password for the network.
    The rest are factory defaults.

I am new to OpenWRT and have to do with what I've got atm. I wasn't able to do extensive RTFM and network research due to current circumstances. Please, advice, what logs can be useful in figuring out the problem. I have only used the GUI control panel so far, but currently looking into SSH too.

Thank you kindly!

?
For routers running OpenWrt firmware,
The default address for router administration is 192.168.1.1

It is not quite clear if you're running the preinstalled OEM firmware (which might identify itself as OpenWrt, but probably is quite far away from it, using the vendor SDK and a semi-proprietary kernel with vendor wireless drivers) - or vanilla OpenWrt as released from openwrt.org. In the former case there isn't a whole lot we could help with, as the vendor wireless drivers have a pretty different behaviour than OpenWrt's (mainline-) mt76.

Not at all familiar with that chip
but
The MediaTek MT7621AT/MT7615N combination is known to have problems with the 5GHz WiFi.

The 5GHz WiFi problem is still present in the latest Stable release 21.02.2
Some of the snapshot releases mitigates/eliminates the 5GHz problem.

Did not find that brand listed as supported in OpenWrt.

The firmware is probably modified by the World Vision (the OP has a typo). I don't think there were major modifications, added brand name at the top of the administration panel. I forgot to include it, but here is the info from the GUI:

Model: WV-CONNECT
Firmware Version: OpenWrt Barrier Breaker 14.07 / LuCI Trunk (0.12+svn-r10530)
Kernel Version: 3.10.49

I can also run any SSH commands now if that can be helpful.

The brand is World Vision (there was a typo), although I do not think it's supported either. I think the router is just a no-name Chinese one or a knockoff of some sort.

The router does not support 5GHz, only 2.4GHz.

At this point as slh already hinted,
Since your device is using a modified software, not a standard OpenWrt firmware,
and even the basic login process to the router's menu is different...
Support is not possible.

A typical OpenWrt menu has the following:
Username: root
Password: default does not have any password

You will need to check with your ISP for such information if OpenWrt default username and blank password does not work.

As for trying to access the router's menu via SSH,
You would still need the username and password.

Login screen was default, as you describe it. The default username was "root" and no password. The only difference is the address being 192.168.0.1 instead of ..1.1. I have set up a password and successfully logged in via SSH using Windows Powershell.

The router wasn't provided by the ISP. It's the only one we found available in store.

I am currently looking into a possibility of flashing the device with vanilla OpenWrt or something else. If I do that and the problem persists with the vanilla version, I will create another thread.

The OpenWrt Barrier Breaker 14.07 was released back in 2014!
I don't even remember the interface anymore.

Was there any luck trying to access the menu using a web browser?

Yes, web GUI menu is the way I've been using to set up the device! Here's how it looks like:

I reckon I need to flash/update the firmware.

If you want to check the System Log to try locating WiFi drops,
Look under Status > System Log

You can take a browse through your wireless settings via,
Network > Wireless > Edit ...

Good luck.

Is this your router?

SSH in to the router and run (one at a time) -

cat /etc/config/wireless

cat /etc/config/network

cat /etc/config/dhcp

Redact any passwords and public IP addresses.

Post each result in preformatted text, by using the icon highlighted in red...

OpenWRT Posting Icons

Let's also look at your system log.

SSH in and run -

logread | grep STA

Post results in preformatted text.

Even assuming we were talking about genuine OpenWrt 14.07 (and not the proprietary vendor SDK), it doesn't make the slightest sense to debug 8 year old rt2x00/ mt76 drivers. Quite a few pretty nasty bugs have been fixed in rt2x00 - and mt76 is improving massively every few weeks.

1 Like

Yes, it is correct, I have this device.

/etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path '10180000.wmac'
        option htmode 'HT20'
        option txpower '20'
        option country 'UA'

config wifi-iface
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option encryption 'psk2'
        option ssid 'WV-CONNECT-2'
        option key '********'

/etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.0.1'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr 'f8:5e:3c:0f:6c:70'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr 'f8:5e:3c:0f:6c:71'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

/etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'

config dhcp 'lan'
        option interface 'lan'
        option limit '150'
        option leasetime '12h'
        option dhcpv6 'server'
        option ra 'server'
        option ra_management '1'
        option start '50'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'

config host
        option name 'bellerophon'

I agree! I am planning to flash the device with a newer system.

Apparently this is a rebranded ZBT WE1626 which is not supported (officially). I've found some firmware that might work but need to research what bootloader I have and how all of this works.

So I fixed the problem by updating OpenWrt via the web interface.

From these articles: https://openwrt.org/toh/zbt/we526, https://openwrt.org/toh/zbt/wr8305rt I figured that I can update using a sysupgrade image for ZBT WR8305RT. VW Connect is basically a copy with 2 less antennas and double the memory.

The upgrade went smoothly. Now the device is running OpenWrt 21.02.2 and everything works as intended.

There are plenty other firmware available for this device that I found on another forum, but those would involve a bootloader to install.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.