Wifi drop connection everytime (possible wrong driver?)

Hello anyone
i having MediaTek MT7628AN ver:1 eco:2
but i had no related driver for it
can somehow you guys help me how to install it?

somehow i found it on forum some ppl having "disconnected" by the wifi (wifi dissapear and then re-appear)
and someone told that it's because driver issue

so how i can fix this?
when i scroll it on software list
i had kmod-mt76-core
i think this why my devices miss behave....
when it's idle and i connect with ethernet
it's working perfectly fine

but when i using my phone or connect laptop to it
they will slap me with disconnect every 5 min

can anyone help me with this
or atleast help with driver finding?

i had no idea
already 2 hour now and still confused how to install the right ones
since the ones who come with the base script is seems wrong

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7628AN ver:1 eco:2",
        "model": "Xiaomi Mi Router 4C",
        "board_name": "xiaomi,mi-router-4c",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "ramips/mt76x8",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd50:8180:4751::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.2.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr 'a4:a9:30:56:24:dd'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'
        option force_link '1'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'
        option force_link '1'
        option reqaddress 'try'
        option reqprefix 'auto'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '4 2 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 6t'

config interface 'wwan'
        option proto 'dhcp'
        option force_link '1'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option channel '7'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'
        option country 'ID'
        option frag '2346'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'sta'
        option network 'wwan'
        option ssid 'hiddenname'
        option bssid '76:6F:88:36:20:0A'
        option encryption 'none'
        option macaddr '74:6F:88:36:20:0A'
        option wpa_group_rekey '604800'
        option skip_inactivity_poll '1'
        option disassoc_low_ack '0'
        option short_preamble '0'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid 'hiddenname'
        option encryption 'sae-mixed'
        option wmm '0'
        option isolate '1'
        option wpa_group_rekey '604800'
        option disassoc_low_ack '0'
        option key 'Hiddenpw'
        option ieee80211w '0'
        option network 'lan'
        option skip_inactivity_poll '1'
        option short_preamble '0'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'relay'
        option ra 'relay'
        option ndp 'relay'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

config dhcp 'wan6'
        option interface 'wan6'
        option ignore '1'
        option master '1'
        option ra 'relay'
        option dhcpv6 'relay'
        option ndp 'relay'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        list network 'lan'

config zone
        option name 'wan'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'
        list network 'wan'
        list network 'wan6'
        list network 'wwan'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

root@OpenWrt:~#

does anything wrong on my setting?

You've got a lot of stuff going on in the wireless config -- I suspect part of that is to blame for the issues you're seeing.

Start by resetting to defaults. Change your lan address then setup the wwan network interface and connect it to the upstream wifi network. Don't change any other settings other than those that are strictly necessary (such as the country code). Leave channel on auto, don't add things like the frag, cell density, wpa_group_rekey, etc.)... keep it entirely simple.

On your AP mode network, use wpa2 or wpa3, but not mixed mode. Don't isolate, don't specify the rekey or 802.11w, inactivity, etc... again, keep it entirely simple and touch as few settings as you can.

Then test again.

here the things
rekey normally is 300sec right?
then every 5 min the wifi goes dead and up
i found the solution to make it higher,...
that's why i set it up
the problem keep coming but gladly it's not always up and down every 5 min
but it's still up and down

it's 1.
second when i edit it isolate... because i sure some of user is impostor (ie, they using deauther)

and next question
how can i reset it to default?
i using luci

somehow after doing full reset on system the wifi can't active at all
Encryption: WPA2 PSK (CCMP)
Channel: 0 (0.000 GHz)
Tx-Power: 14 dBm
Signal: 0 dBm | Noise: 0 dBm
Bitrate: 0.0 Mbit/s | Country: ID

Somehow after ALOT try error and reset
i manage to make it works with
update something
and not touch any setting at all

lets see it's disconnected or not

use an ssh session and issue this command:

firstboot -y && reboot

Then, connect via ethernet and configure the device

already doing that
now it's still same issue
but the wifi drop isn't 5 min
but more

random between 10 min to 30 min

Thu May 30 16:05:55 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-DISCONNECTED bssid=76:6f:88:36:20:0a reason=4 locally_generated=1
Thu May 30 16:05:55 2024 daemon.notice netifd: Network device 'phy0-sta0' link is down
Thu May 30 16:05:55 2024 daemon.notice netifd: Interface 'wwan' has link connectivity loss
Thu May 30 16:05:56 2024 daemon.notice netifd: wwan (4435): udhcpc: received SIGTERM
Thu May 30 16:05:56 2024 daemon.notice netifd: wwan (4435): udhcpc: unicasting a release of 20.40.17.198 to 20.40.16.1
Thu May 30 16:05:56 2024 daemon.notice netifd: wwan (4435): udhcpc: sending release
Thu May 30 16:05:56 2024 daemon.notice netifd: wwan (4435): udhcpc: entering released state
Thu May 30 16:05:56 2024 daemon.notice netifd: wwan (4435): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wwan" } (Permission denied)
Thu May 30 16:05:56 2024 daemon.notice netifd: Interface 'wwan' is now down
Thu May 30 16:05:56 2024 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Thu May 30 16:05:56 2024 daemon.notice netifd: Network device 'phy0-ap0' link is down
Thu May 30 16:05:56 2024 kern.info kernel: [ 9538.177505] br-lan: port 2(phy0-ap0) entered disabled state
Thu May 30 16:05:58 2024 daemon.notice netifd: bridge 'br-lan' link is down
Thu May 30 16:05:58 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Thu May 30 16:05:58 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 16:06:00 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: SME: Trying to authenticate with 76:6f:88:36:20:0a (SSID='hidden<networksource>' freq=2412 MHz)
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.349607] phy0-sta0: authenticate with 76:6f:88:36:20:0a
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.349753] phy0-sta0: 80 MHz not supported, disabling VHT
Thu May 30 16:06:00 2024 daemon.notice hostapd: handle_probe_req: send failed
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.564570] phy0-sta0: send auth to 76:6f:88:36:20:0a (try 1/3)
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.687442] phy0-sta0: send auth to 76:6f:88:36:20:0a (try 2/3)
Thu May 30 16:06:00 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: Trying to associate with 76:6f:88:36:20:0a (SSID='hidden<networksource>' freq=2412 MHz)
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.698500] phy0-sta0: authenticated
Thu May 30 16:06:00 2024 daemon.notice netifd: Network device 'phy0-sta0' link is up
Thu May 30 16:06:00 2024 daemon.notice netifd: Interface 'wwan' has link connectivity
Thu May 30 16:06:00 2024 daemon.notice netifd: Interface 'wwan' is setting up now
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.707845] phy0-sta0: associate with 76:6f:88:36:20:0a (try 1/3)
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.713848] phy0-sta0: RX AssocResp from 76:6f:88:36:20:0a (capab=0x1c21 status=0 aid=5)
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.714136] phy0-sta0: associated
Thu May 30 16:06:00 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: Associated with 76:6f:88:36:20:0a
Thu May 30 16:06:00 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-CONNECTED - Connection to 76:6f:88:36:20:0a completed [id=0 id_str=]
Thu May 30 16:06:00 2024 daemon.notice netifd: Network device 'phy0-ap0' link is up
Thu May 30 16:06:00 2024 daemon.notice netifd: bridge 'br-lan' link is up
Thu May 30 16:06:00 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.767633] br-lan: port 2(phy0-ap0) entered blocking state
Thu May 30 16:06:00 2024 kern.info kernel: [ 9541.767680] br-lan: port 2(phy0-ap0) entered forwarding state
Thu May 30 16:06:00 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Thu May 30 16:06:00 2024 daemon.notice netifd: wwan (4704): udhcpc: started, v1.36.1
Thu May 30 16:06:00 2024 daemon.notice netifd: wwan (4704): udhcpc: broadcasting discover
Thu May 30 16:06:00 2024 daemon.notice netifd: wwan (4704): udhcpc: broadcasting select for xxx.40.17.198, server xxx.40.16.1
Thu May 30 16:06:00 2024 daemon.notice netifd: wwan (4704): udhcpc: lease of xxx.40.17.198 obtained from xxx.40.16.1, lease time 600
Thu May 30 16:06:00 2024 daemon.notice netifd: Interface 'wwan' is now up
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using nameserver xxx.40.16.1#53
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using nameserver 1.1.1.1#53
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using nameserver 1.0.0.1#53
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Thu May 30 16:06:00 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Thu May 30 16:06:01 2024 user.notice firewall: Reloading firewall due to ifup of wwan (phy0-sta0)
Thu May 30 16:06:01 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 16:06:01 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 16:06:02 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 16:06:03 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED c6:08:a2:36:45:51
Thu May 30 16:06:03 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 IEEE 802.11: authenticated
Thu May 30 16:06:03 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 IEEE 802.11: associated (aid 2)
Thu May 30 16:06:03 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED c6:08:a2:36:45:51 auth_alg=open
Thu May 30 16:06:03 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 WPA: pairwise key handshake completed (RSN)
Thu May 30 16:06:03 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED c6:08:a2:36:45:51
Thu May 30 16:06:03 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.2.112 c6:08:a2:36:45:51
Thu May 30 16:06:03 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.2.112 c6:08:a2:36:45:51
Thu May 30 16:06:03 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 16:06:03 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 16:06:04 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 16:06:04 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 16:06:05 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 16:06:05 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS

You disabled WMM which is absolutely mandatory from WiFi4 onwards WPA3 included.
Just reset the device and set up wifi without clicking boxes you do not understand.

wait, so i can't turn it off? on my old router when i turned it off it far more faster
i will try this setting again then with wmm enabled

i will report the feedback tomorrow

Disabling WMM means reducing the maximum speed to 54 MBit/s.

1 Like

after alot of try
resetting to default setting
and trying all suggestion here

somehow i still confused they keep down at some random point

Thu May 30 19:21:18 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:19 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:20 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED c6:08:a2:36:45:51
Thu May 30 19:21:20 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 IEEE 802.11: disassociated
Thu May 30 19:21:20 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 IEEE 802.11: authenticated
Thu May 30 19:21:20 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 IEEE 802.11: associated (aid 1)
Thu May 30 19:21:20 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED c6:08:a2:36:45:51 auth_alg=open
Thu May 30 19:21:20 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 WPA: pairwise key handshake completed (RSN)
Thu May 30 19:21:20 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED c6:08:a2:36:45:51
Thu May 30 19:21:20 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.2.112 c6:08:a2:36:45:51
Thu May 30 19:21:20 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.2.112 c6:08:a2:36:45:51
Thu May 30 19:21:20 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:20 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:21 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:21 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:22 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:22 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:23 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:24 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:24 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-DISCONNECTED bssid=76:6f:88:36:20:0a reason=4 locally_generated=1
Thu May 30 19:21:24 2024 daemon.notice wpa_supplicant[1073]: BSSID 76:6f:88:36:20:0a ignore list count incremented to 2, ignoring for 10 seconds
Thu May 30 19:21:24 2024 daemon.notice netifd: Network device 'phy0-sta0' link is down
Thu May 30 19:21:24 2024 daemon.notice netifd: Interface 'wwan' has link connectivity loss
Thu May 30 19:21:25 2024 daemon.notice netifd: wwan (11485): udhcpc: received SIGTERM
Thu May 30 19:21:25 2024 daemon.notice netifd: wwan (11485): udhcpc: unicasting a release of xx.40.17.198 to xx.40.16.1
Thu May 30 19:21:25 2024 daemon.notice netifd: wwan (11485): udhcpc: sending release
Thu May 30 19:21:25 2024 daemon.notice netifd: wwan (11485): udhcpc: entering released state
Thu May 30 19:21:25 2024 daemon.notice netifd: wwan (11485): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wwan" } (Permission denied)
Thu May 30 19:21:25 2024 daemon.notice netifd: Interface 'wwan' is now down
Thu May 30 19:21:25 2024 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Thu May 30 19:21:26 2024 daemon.notice netifd: Network device 'phy0-ap0' link is down
Thu May 30 19:21:26 2024 kern.info kernel: [21267.214192] br-lan: port 2(phy0-ap0) entered disabled state
Thu May 30 19:21:27 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:27 2024 daemon.notice netifd: bridge 'br-lan' link is down
Thu May 30 19:21:27 2024 daemon.notice netifd: Interface 'lan' has link connectivity loss
Thu May 30 19:21:30 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: SME: Trying to authenticate with 76:6f:88:36:20:0a (SSID='hidden' freq=2412 MHz)
Thu May 30 19:21:30 2024 kern.info kernel: [21271.885167] phy0-sta0: authenticate with 76:6f:88:36:20:0a
Thu May 30 19:21:30 2024 kern.info kernel: [21271.885301] phy0-sta0: 80 MHz not supported, disabling VHT
Thu May 30 19:21:30 2024 kern.info kernel: [21272.101257] phy0-sta0: send auth to 76:6f:88:36:20:0a (try 1/3)
Thu May 30 19:21:31 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: Trying to associate with 76:6f:88:36:20:0a (SSID='hidden' freq=2412 MHz)
Thu May 30 19:21:31 2024 kern.info kernel: [21272.345834] phy0-sta0: authenticated
Thu May 30 19:21:31 2024 daemon.notice netifd: Network device 'phy0-sta0' link is up
Thu May 30 19:21:31 2024 daemon.notice netifd: Interface 'wwan' has link connectivity
Thu May 30 19:21:31 2024 daemon.notice netifd: Interface 'wwan' is setting up now
Thu May 30 19:21:31 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: Associated with 76:6f:88:36:20:0a
Thu May 30 19:21:31 2024 kern.info kernel: [21272.354712] phy0-sta0: associate with 76:6f:88:36:20:0a (try 1/3)
Thu May 30 19:21:31 2024 kern.info kernel: [21272.358578] phy0-sta0: RX AssocResp from 76:6f:88:36:20:0a (capab=0x1c21 status=0 aid=5)
Thu May 30 19:21:31 2024 kern.info kernel: [21272.358865] phy0-sta0: associated
Thu May 30 19:21:31 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-CONNECTED - Connection to 76:6f:88:36:20:0a completed [id=0 id_str=]
Thu May 30 19:21:31 2024 daemon.notice netifd: Network device 'phy0-ap0' link is up
Thu May 30 19:21:31 2024 daemon.notice netifd: bridge 'br-lan' link is up
Thu May 30 19:21:31 2024 daemon.notice netifd: Interface 'lan' has link connectivity
Thu May 30 19:21:31 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Thu May 30 19:21:31 2024 kern.info kernel: [21272.405350] br-lan: port 2(phy0-ap0) entered blocking state
Thu May 30 19:21:31 2024 kern.info kernel: [21272.405398] br-lan: port 2(phy0-ap0) entered forwarding state
Thu May 30 19:21:31 2024 daemon.notice netifd: wwan (11790): udhcpc: started, v1.36.1
Thu May 30 19:21:31 2024 daemon.notice netifd: wwan (11790): udhcpc: broadcasting discover
Thu May 30 19:21:31 2024 daemon.notice netifd: wwan (11790): udhcpc: broadcasting select for xx.40.17.198, server xx.40.16.1
Thu May 30 19:21:31 2024 daemon.notice netifd: wwan (11790): udhcpc: lease of xx.40.17.198 obtained from xx.40.16.1, lease time 600
Thu May 30 19:21:31 2024 daemon.notice netifd: Interface 'wwan' is now up
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using nameserver xx.40.16.1#53
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using nameserver 1.1.1.1#53
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using nameserver 1.0.0.1#53
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Thu May 30 19:21:31 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Thu May 30 19:21:32 2024 user.notice firewall: Reloading firewall due to ifup of wwan (phy0-sta0)
Thu May 30 19:21:32 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:32 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:33 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:34 2024 daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED c6:08:a2:36:45:51
Thu May 30 19:21:34 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 IEEE 802.11: authenticated
Thu May 30 19:21:34 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 IEEE 802.11: associated (aid 1)
Thu May 30 19:21:34 2024 daemon.notice hostapd: phy0-ap0: AP-STA-CONNECTED c6:08:a2:36:45:51 auth_alg=open
Thu May 30 19:21:34 2024 daemon.info hostapd: phy0-ap0: STA c6:08:a2:36:45:51 WPA: pairwise key handshake completed (RSN)
Thu May 30 19:21:34 2024 daemon.notice hostapd: phy0-ap0: EAPOL-4WAY-HS-COMPLETED c6:08:a2:36:45:51
Thu May 30 19:21:34 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.2.112 c6:08:a2:36:45:51
Thu May 30 19:21:34 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.2.112 c6:08:a2:36:45:51
Thu May 30 19:21:34 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:34 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:35 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:35 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:36 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:36 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:37 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:38 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:39 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:40 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:41 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:42 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:43 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:44 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:44 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-DISCONNECTED bssid=76:6f:88:36:20:0a reason=4 locally_generated=1
Thu May 30 19:21:44 2024 daemon.notice wpa_supplicant[1073]: BSSID 76:6f:88:36:20:0a ignore list count incremented to 2, ignoring for 10 seconds
Thu May 30 19:21:44 2024 daemon.notice netifd: Network device 'phy0-sta0' link is down
Thu May 30 19:21:44 2024 daemon.notice netifd: Interface 'wwan' has link connectivity loss
Thu May 30 19:21:45 2024 daemon.notice netifd: wwan (11790): udhcpc: received SIGTERM
Thu May 30 19:21:45 2024 daemon.notice netifd: wwan (11790): udhcpc: unicasting a release of xx.40.17.198 to xx.40.16.1
Thu May 30 19:21:45 2024 daemon.notice netifd: wwan (11790): udhcpc: sending release
Thu May 30 19:21:45 2024 daemon.notice netifd: wwan (11790): udhcpc: entering released state
Thu May 30 19:21:45 2024 daemon.notice netifd: wwan (11790): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "wwan" } (Permission denied)
Thu May 30 19:21:45 2024 daemon.notice netifd: Interface 'wwan' is now down
Thu May 30 19:21:45 2024 daemon.warn dnsmasq[1]: no servers found in /tmp/resolv.conf.d/resolv.conf.auto, will retry
Thu May 30 19:21:45 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: SME: Trying to authenticate with 76:6f:88:36:20:0a (SSID='hidden' freq=2412 MHz)
Thu May 30 19:21:45 2024 kern.info kernel: [21286.866165] phy0-sta0: authenticate with 76:6f:88:36:20:0a
Thu May 30 19:21:45 2024 kern.info kernel: [21286.866298] phy0-sta0: 80 MHz not supported, disabling VHT
Thu May 30 19:21:45 2024 kern.info kernel: [21287.081263] phy0-sta0: send auth to 76:6f:88:36:20:0a (try 1/3)
Thu May 30 19:21:46 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: Trying to associate with 76:6f:88:36:20:0a (SSID='hidden' freq=2412 MHz)
Thu May 30 19:21:46 2024 kern.info kernel: [21287.194115] phy0-sta0: send auth to 76:6f:88:36:20:0a (try 2/3)
Thu May 30 19:21:46 2024 kern.info kernel: [21287.198904] phy0-sta0: authenticated
Thu May 30 19:21:46 2024 daemon.notice netifd: Network device 'phy0-ap0' link is down
Thu May 30 19:21:46 2024 daemon.notice netifd: Network device 'phy0-sta0' link is up
Thu May 30 19:21:46 2024 daemon.notice netifd: Interface 'wwan' has link connectivity
Thu May 30 19:21:46 2024 daemon.notice netifd: Interface 'wwan' is setting up now
Thu May 30 19:21:46 2024 kern.info kernel: [21287.204796] phy0-sta0: associate with 76:6f:88:36:20:0a (try 1/3)
Thu May 30 19:21:46 2024 kern.info kernel: [21287.209127] phy0-sta0: RX AssocResp from 76:6f:88:36:20:0a (capab=0x1c21 status=0 aid=5)
Thu May 30 19:21:46 2024 kern.info kernel: [21287.209407] phy0-sta0: associated
Thu May 30 19:21:46 2024 kern.info kernel: [21287.209612] br-lan: port 2(phy0-ap0) entered disabled state
Thu May 30 19:21:46 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: Associated with 76:6f:88:36:20:0a
Thu May 30 19:21:46 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-CONNECTED - Connection to 76:6f:88:36:20:0a completed [id=0 id_str=]
Thu May 30 19:21:46 2024 daemon.notice netifd: Network device 'phy0-ap0' link is up
Thu May 30 19:21:46 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
Thu May 30 19:21:46 2024 kern.info kernel: [21287.260437] br-lan: port 2(phy0-ap0) entered blocking state
Thu May 30 19:21:46 2024 kern.info kernel: [21287.260485] br-lan: port 2(phy0-ap0) entered forwarding state
Thu May 30 19:21:46 2024 daemon.notice netifd: wwan (11949): udhcpc: started, v1.36.1
Thu May 30 19:21:46 2024 daemon.notice netifd: wwan (11949): udhcpc: broadcasting discover
Thu May 30 19:21:46 2024 daemon.notice netifd: wwan (11949): udhcpc: broadcasting select for xx.40.17.198, server xx.40.16.1
Thu May 30 19:21:46 2024 daemon.notice netifd: wwan (11949): udhcpc: lease of xx.40.17.198 obtained from xx.40.16.1, lease time 600
Thu May 30 19:21:46 2024 daemon.notice netifd: Interface 'wwan' is now up
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: reading /tmp/resolv.conf.d/resolv.conf.auto
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using nameserver xx.40.16.1#53
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using nameserver 1.1.1.1#53
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using nameserver 1.0.0.1#53
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using only locally-known addresses for test
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using only locally-known addresses for onion
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using only locally-known addresses for localhost
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using only locally-known addresses for local
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using only locally-known addresses for invalid
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using only locally-known addresses for bind
Thu May 30 19:21:46 2024 daemon.info dnsmasq[1]: using only locally-known addresses for lan
Thu May 30 19:21:46 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:47 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:48 2024 user.notice firewall: Reloading firewall due to ifup of wwan (phy0-sta0)
Thu May 30 19:21:48 2024 daemon.warn odhcpd[1248]: No default route present, overriding ra_lifetime!
Thu May 30 19:21:48 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:49 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS
Thu May 30 19:21:50 2024 daemon.notice wpa_supplicant[1073]: phy0-sta0: CTRL-EVENT-BEACON-LOSS

Try to run client alone, also you need compatible wds if ap and sta names are ideneical as in your config.

ummm thanks but can you explain what u mean by
-> try to run client alone
i grab wifi (which access point, paid by voucher. i already bought the voucher, then reshare it on new AP) now booth access point and ethernet that i connected to... on openwrt broken...
every x min (usually 5 or more min) they disconnect AND OR request timeout
while on past i using Tenda N301
i never encounter this issue
-> need compatible wds
what it's? and how to check

Pretty simple you connect to accesspoint then re-share it under same name. You need to use WDS in this case.

Umm can you show me where i can set WDS?
i using luci
i didn't found any WDS setting as far as i know

Just use travelmate and do not clone others' access point names.

what u really mean on here?
can someone use really simple basic english?
"do not clone others' access point names."

when i clone other's access point?

all i do is set 2 network
1 as Client, connect to Wifi A to get internet
then create 1 as AP, the name difference from wifi A or any nearby wifi

THE ISSUE WAS
IT'S KEEP DISCONNECT AND DOWN
AND THEN AFTER FEW SECOND IT UP AGAIN

this problem down and up is the main issue
any new solution?

all solution above
proven not working at all

if ppl maybe think
this because the AP that i get internet BROKEN
then WRONG

i been using it for many many year with Tenda N301
but since tenda N301 had bug i can't even change mac
i buy MI Router 4C and SLAP OPENWRT on it

now the issue and first issue that until now i not yet found the solution is
HOW I SHOULD FIX THIS?
this is really sad man...

every 5-10 min
the wifi AND OR ethernet always down
then after few second it's up
then next it will down again

and keep repeating it again and again
any solution?

Your post shows same SSID in both sides. Which pretty much explains random disconnects.