`wifi config` does nothing though driver working

I have install OpenWRT x86 firmware on LXC of my PROXMOX.

My wireless LAN card is RTL8852BE and it is pass-throughed.

I have read the manual and every manual starts with "type wifi config" but it just creates empty /etc/config/wireless on my OpenWRT.

How can I enable wireless setup in my OpenWRT?

FYI, iw dev shows the correct device name:

phy#0
        Interface wlan0
                ifindex 4
                wdev 0x1
                addr c8:8a:d8:17:0c:14
                type managed
                txpower 20.00 dBm
                multicast TXQ:
                        qsz-byt qsz-pkt flows   drops   marks   overlmt hashcol tx-bytes        tx-packets
                        0       0       0       0       0       0       0       0               0

Also, iwinfo wlan0 scan shows tons of SSIDs, so I think the device itself is working correctly, and I don't think it is a driver issue.

Cell 01 - Address: 28:6D:97:9A:C4:D8
          ESSID: "[fridge]_E30AJT5103004V"
          Mode: Master  Frequency: 2.412 GHz  Band: 2.4 GHz  Channel: 1
          Signal: -55 dBm  Quality: 55/70
          Encryption: WPA2 PSK (CCMP)
          HT Operation:
                    Primary Channel: 1
                    Secondary Channel Offset: no secondary
                    Channel Width: 20 MHz
...

What is the quuestion?

Please post output of

ubus call system board

And lsusb/lspci along the crucial fact whether device is connected via USB or PCI form proxmox AND OpenWRT guest.

iw list | grep -A3 combination

Thank you for reply. My question is,

How can I enable wireless setup in my OpenWRT?

I have tried the instruction which tells wifi config will generate configuration file but when I follow the instruction, it just creates empty /etc/config/wireless` file, so I have no clue here.

Here's outputs:

# ubus call system board
{
        "kernel": "6.8.8-2-pve",
        "hostname": "myhostname",
        "system": "Intel(R) N100",
        "model": "Default string Default string",
        "board_name": "default-string-default-string",
        "rootfs_type": "zfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.3",
                "revision": "r23809-234f1a2efa",
                "target": "x86/64",
                "description": "OpenWrt 23.05.3 r23809-234f1a2efa"
        }
}
# lspci | grep RTL
04:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8852BE PCIe 802.11ax Wireless Network Controller
# iw list | grep -A3 combination
        valid interface combinations:
                 * #{ managed } <= 1, #{ AP, P2P-client, P2P-GO } <= 1,
                   total <= 2, #channels <= 1
        HT Capability overrides:

All outputs are from OpenWRT guest including my original post.

You can have only one client and one other function at the time. Can you run logread -f in a terminal session while enabling access point via luci?

You can have only one client and one other function at the time.

I am afraid that I don't understand what you mean here client. I am noob for this kind of management so please bear with me.

I can't enable access point via luci. There's no wireless related setup page in my luci.

Where did this firmware come from?

OpenWrt 23.05.3 uses kernel 5.15.150. Yours is different:

Can you provide some insight into why this is the case?

My OpenWRT is running in LXC on PROXMOX. LXC kernel is shared with host's kernel, so it is proxmox's kernel.

Ah... so you're virtualized. Running wireless (or any direct hardware) in a virtualized environment is a bit of a different animal.

Try booting bare-metal into OpenWrt (you can do it with a USB drive if you want) and see if the wireless driver is working as expected. If so, the problem is in the virtual envionment, and not OpenWrt.

I have just tried with USB stick but I couldn't build the driver for RTL8852BE for small partition in the image.

Anyway, I have already shown that the driver is working in LXC using iwinfo. Or, am I missing something?

container will not do anything with network configurations. LXC isolation is sometimes lacking eg you can access like v4l1 unrestricted, but for mangling routes and network bridges and nftables you will need at least a virtual machine. Especially dangerous is to believe container contains anything running as root.
After verifyingvwith usb boit that netcard works and you can properly attribute shortages.

I will try in VM first then. At least, I need an environment to build the driver before trying bare metal.

You have to try on pure machine first to confirm adapter functions with openwrt, then polish virtual machine to match real hardware.