WiFi communication with VLAN interface not working

I have a TP-Link EAP245v3 WAP running

OpenWrt SNAPSHOT r18781-8d8d26ba42 / LuCI Master git-22.025.79016-22e2bfb

without any installation issues. I'm having a problem getting a WiFi network to use a VLAN (2104) interface. Here are my configs:

/etc/config/network

config interface 'loopback'
    option device 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdce:e223:c86d::/48'

config device
    option name 'br-lan'
    option type 'bridge'
    list ports 'eth0.1'

config interface 'lan'
    option device 'br-lan'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option ip6assign '60'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0t 2 5'
    option vid '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option ports '0t 2t'
    option vid '2104'
    option description 'vlan-family5'

config interface 'family5'
    option device 'eth0.2104'
    option type 'bridge'
    option proto 'none'

/etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option path 'pci0000:00/0000:00:00.0'
    option channel '36'
    option band '5g'
    option htmode 'VHT80'
    option cell_density '0'

config wifi-device 'radio1'
    option type 'mac80211'
    option path 'platform/ahb/18100000.wmac'
    option channel '1'
    option band '2g'
    option htmode 'HT20'
    option disabled '1'

config wifi-iface 'wifinet0'
    option device 'radio0'
    option mode 'ap'
    option wmm '0'
    option key 'deleted'
    option network 'family5'
    option ssid 'test'
    option encryption 'sae'

Clients can connect to the test wifi network but cannot obtain an IP address. The weird thing is that if I change the "family5" interface to proto "dhcp" (i.e. a dhcp client), it gets an IP from the router without any issue. If I use "unmanaged" for use by the WiFi network, it seems no traffic gets to the interface.

Any ideas?

try WPA2. See if that helps.

WPA2 didn't change anything.

Thanks for the suggestion though!

I think I found the issue:

Create a bridge device, then make tie the interface to the bridge as shown:

config device
    option name 'br-family5'
    option type 'bridge'
    list ports 'eth0.2104'

config interface 'family5'
    option device 'br-family5'
    option proto 'none'

Okay, so I had done a bridged interface before on another openwrt WAP that worked. I had read you could connect a wifi interface directly to a VLAN so had been trying that. I did try to reproduce my original configuration with bridges on this WAP but was unsuccessful. (I've been using Luci for all configuration, btw.)

Anyway, with that said, I was skeptical but tried your suggestion (since I'd already done it before). It worked BUT I had to fix the config luci generated:

config interface 'family5'
        option type 'bridge'
        option proto 'none'
        option device 'br-family5'

config device
        option type 'bridge'
        option name 'br-family5'
        list ports 'eth0.2104'

It differed from yours. So I removed the "option type 'bridge'" from the family5 interface... and that fixed it!

Looks like I ran into a bug with Luci?

Also thank you so much. I was losing my sanity trying to debug this when a previous configuration on a different WAP worked just fine!

The root cause is that implicit bridge device creation from config interface sections is being deprecated.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.