Wifi clients keep disconnecting intermittently on 5Ghz

I'm using a Netgear R7800. Here are the logs:

daemon.info hostapd: phy0-ap0: STA ${mac-address} IEEE 802.11: disconnected due to excessive missing ACKs
daemon.notice hostapd: phy0-ap0: AP-STA-DISCONNECTED {mac-address}

I've tried reducing the transmission power, setting the channel to auto, and reduced channel width to 40 MHz from 80 MHz

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel 'auto'
	option band '5g'
	option htmode 'VHT40'
	option cell_density '0'
	option txpower '20'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'pri_interface'
	option mode 'ap'
	option ssid 'ssid'
	option key 'key'
	option encryption 'psk2+ccmp'
	option log_level '0'
	list maclist 'mac-address'
	list maclist 'mac-address'
	list maclist 'mac-address'

config wifi-iface 'wifinet2'
	option device 'radio0'
	option mode 'ap'
	option ssid 'ssid_2'
	option encryption 'psk2+ccmp'
	option key 'new_key'
	option network 'guest_interface'

Any help is appreciated!

Could try unchecking Disassociate On Low Acknowledgement.

At the bottom of the advanced interface settings in Luci. Or in the config file:
option disassoc_low_ack '0'

I updated the config as you suggested. However, I’m still facing the same issue

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'pri_interface'
	option mode 'ap'
	option ssid 'ssid'
	option key 'key'
	option encryption 'psk2+ccmp'
	option log_level '0'
	list maclist 'mac-address'
	list maclist 'mac-address'
	list maclist 'mac-address'
	option disassoc_low_ack '0'