WIFI client as WAN, no WAN traffic (18.06.1 AC58U)

So I have somebody else using an AC58U with OpenWrt as a range extender of some sort. He needs to extend a ISP provided access point that has both 2.4 and 5ghz radios.

First he tried extending the 2.4 network with relayd but if offered poor performance. He needs only 2.4 because none of the computers there support 5ghz.

Seeing this I gave the dude a suggestion: what if you connect the OpenWrt router to 5ghz, and then broadcast the 2.4ghz signal from it. E.g. to use 5ghz just as a "network cable". E.g. 5ghz client 2.4ghz AP.

So I entered with TeamViewer, clicked join network to 5ghz but, no matter how I change the settings, I can't get the internet traffic (wwan to wan which goes to lan then 2.4 AP)

The ISP provided AP has the IP of .1.1, so he needs to set the OpenWrt router to .1.2. Does that have to do with wan not getting anything from the 5ghz client?

Every other setting should work, wwan firewall zone is set to wan, we tried every single bridge combination but still no access.

The 5ghz client is obviously connected to the ISP router, but in some bridge configurations it doesn't longer connect. In any way there is no internet reaching the WAN->LAN.

Any advice is greatly appreciated. I cannot replicate this environment on my AC58U so I can't help.

The router's LAN must be a different subnet than the AP. For example:

ISP's gateway (the hotspot) is
Your WAN interface will be 192.168.1.something. Your router gets that IP from the ISP by acting as a DHCP client.
your router's LAN static IP
users of your router 192.168.50.X. Their IP is assigned by the DHCP server running on the LAN of your router.

You are on the right track to use 5 Ghz for the "backhaul" and 2 Ghz for users. You do not need a "wwan" network. Use the existing wan network and firewall rules that are in a default configuration. The 5 GHz client should be attached to the WAN network. Remove the ethernet port that is there by default from the WAN network. The WAN network must not be a bridge and must have only the wifi client in it.

Okay, I removed wwan, disabled the bridge and only assigned the 5ghz client to wan, and now I see some tx/rx in wan. It's a start, thank you!

But there's still no connectivity to the router, ping doesn't work

I'm not sure how can I change the router's static LAN address. I don't have physical access to it, and Luci always reverts to .1.2. It is connected via Ethernet to the laptop I'm into TeamViewer with, that laptop being connected to another wifi network.

In "associated stations", the 5ghz client says "Host: ?"

The wan rx/tx keeps increasing but there is no internet to the router

Is it still because lan is the same subnet? I tried changing it but the Ethernet just disconnects and reconnects again with the previous settings after 60s.

It is normal to see "?" if the other side doesn't supply their hostname.

Yes you must have wan and lan in different subnets.

Since you can't change the wan network, you need to change lan then get the PC back on the same new network as the router. This generally means you'd unplug and replug the Ethernet cord to force the PC to re-DHCP, then enter the new address into the web browser.

I gave the guy the link to your post, I'll return with updates.

At least I've made it half-work and he doesn't need to use relayd anymore with the 5ghz backbone. :slight_smile:

Now I've got disconnected from that crappy TeamViewer so I can't see anymore :slight_smile: But he anyways needs to phisically reconnect the Ethernet port.

Thanks again!

He got access to the router again, factory reset again and set lan ip to, so other subnet.

Still doesn't work

With removed wwan and even messing around with the firewall. Any more advice? Unfortunately I couldn't save any logs because file transfer and screenshots are blocked from that TeamViewer instance.

Start with a default configuration.

Change the LAN IP to

Remove the Ethernet port from WAN physical settings.

Manually set up the wifi client. Do not click the "connect to this network" button on the scan page. Instead go to the wifi setup page create a new interface and select Client, enter the SSID, encryption type and key (if needed) and pull down to select the WAN network. Save those settings then click the button in the top part of the page to globally enable the radio.

Make sure the wifi client is selected in the wan physical settings and that the "bridge" box is not checked.

On the main status page you should now see the wifi has associated with the AP and a WAN IPv4 address has been obtained. It should now work to access the Internet through the router.

I'll try it right now. Until now it couldn't get itself an IPv4 address.

Still can't get it to work. I managed to take some screenshots. Last two are logs (system and dmesg, but there isn't much info I know).


This is weird. Now WAN is showing some traffic, but still no IPv4 address under Status. The weird thing is, the router is connected via Ethernet with the laptop I'm into TeamViewer with via wifi (the 2.4 AP of the ISP, I'm trying to connect this router to it's 5ghz network), the TeamViewer connection now started to randomly drop! So the router "injects" some conflict to the laptop while trying to get an IP from the ISP router.

What am I doing wrong? The LAN is set to Static with DHCP enabled. Tha WAN is set to everything default except bridge off and wifi client instead of Ethernet wan port. It doesn't seem to understand what it needs to do :confused:

Okay, he got it to work by also setting wan to static and messing around with the gateway. I installed some packages (upnp, adblock, etc) and now I'm waiting to see if the 2.4 AP works.

Does it need DHCP, as I'm assuming the router is creating it's own network?

Sorry for the spam, there's no auto post merging

Is there a way I can leave the default wan there and use wwan as if it was wan? I mean wan seems to be just a normal network interface which got configured in /etc/config/network and happened to carry the name wan. So I should be able to achieve the same functionality with another interface configured in /etc/config/network that have any other name, e.g. wwan? Or does OpenWrt treat the interface carrying the name wan differently from other user-created interfaces?

I have been trying to understand what is going on here but got really confused. And please forgive me to ask an even noob question: how do the packets send to wan from internet get broadcasted to lan? I never see wan appear anywhere in br-lan's ifname list. We don't need a bridge here?

Reusing the “WAN” network and zone is convenient, not required. Nothing special about the name.

When a client sends an outbound packet to a remote server, it is allowed out by the forward rule and it gets “remembered” by conntrack and usually NAT. On return, the “matching” packets are allowed because of a conntrack “related” rule having precedence over the general forward WAN-to-LAN rule.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.