WiFi Bridge Only Outbound Connections Work

Hello,

I'm trying to configure the WiFi bridge on TP-Link RE305 V3.

I followed the above guide to every detail, and the image resembles my desired configuration. At first sight everything works. Client Hosts 1/2 (on the left) get assigned an IP from the 192.168.1.0/24 subnet and can talk to LAN Hosts 1/2 (on the right).

Though LAN Hosts 1/2 (on the right) cannot talk to Client Hosts 1/2 (on the left), they can only talk to the W-LAN Client (192.168.1.30 in this example).

I'm confused as to what could be happening here. Has anyone encountered something similar?

Can you not use WDS as described here:

I use that and works rather well. Can be set up very quickly from LuCi and even can support separate guest and lan WiFi networks if you have the right hardware.

Just to clarify, you mean setting option wds '0'?

Also forgot to mention, I don't need a functioning wireless repeater, I just need to use the single LAN port on the RE305, so it can be bridged to my main network (over WiFi).

So I think you can do all this in LuCi - you just set on your main AP radio to type 'WDS AP', and then you connect the repeater as a 'WDS client' (taking care to disable DHCP on the WDS client - and the other minor steps outlined in that link), and you don't need to setup any AP's on your repeater device - you just plug in devices to the LAN port, and they should get the IP address from your main AP.

It's pretty well detailed here I think:

Make sense?

Just checking - is your AP an OpenWrt device?

Makes perfect sense, I'll try as a WDS client now, though the AP I'm connecting to is Unifi. I'm thinking that shouldn't present a problem?

The AP needs to be setup to use WDS. I wonder if you can put OpenWrt on your Unifi device? WDS may not even be needed here.

I'm pretty weak in this area: @patrakov, @frollic or @slh, I suspect you are all far better equipped than I to help @StepFresh out here. Could you possibly offer some tips to help @StepFresh here?

He just wants to be able to connect LAN devices to his TP-Link RE305 V3, and connect the latter to his WiFi network.

The wireless mode should be Client (WDS) <- Works
and the Network in Interface Configuration has to be changed from wwan to lan. <- Fails

I have tried this step multiple times, and it always loses connection, meaning I have to wait 90s for a revert.


BSSID is intentionally hidden

Yeah the thing is your AP needs to support WDS AP... if it doesn't then this mode won't work. If you can put OpenWrt on your Unifi device you should consider that.

See e.g. here: https://community.ui.com/questions/can-unifi-AP-do-wireless-WDS/e4a303ee-6e0a-4e08-8664-070f7d5be5e6

I went the OpenWRT route on my RE305 just because it's LAN device would sometimes lose connection, and a reboot would fix it. So what I'm trying to do here is more than possible on the repeater hardware, though god knows how it was implemented in the official firmware.

Anyways, I just wanted to automate reboots and doesn't seem to be another way to root the RE305 other than flashing the entire firmware.

This entire re-configuration presents a huge hurdle, let alone reflashing my main AP to OpenWRT, for which I'm too big of a noob.

Sounds like you had something pretty much working - maybe a minor tweak or two could be applied to make that work. OpenWrt is worth persevering with so long as it fully supports your hardware.

fwiw, your issue may be similar to this recent topic.
https://forum.openwrt.org/t/relayd-double-nat-issue/134702/

fwiw, are you able to temporarily install another AP (ie. not Unifi), to test whether relayd is functioning correctly? (I'm speculating it perhaps could be an AP compatibility issue in both cases?)

1 Like

Tried to reflash the original FW from this page:

And it seems to have bricked itself.

All lights turn blue, and then the signal light turns red, rinse repeat.

Somehow OpenWrt needs to make it harder to brick devices. Otherwise it is potentially contributing to electronic waste.

I think it was hard enough since it showed me a popup, something along the lines of firmware image not verified blabla, and I just checked the force checkbox.

I figured if I could flash OEM -> OWRT, it would be as simple to revert the changes, turns out it's not.

\F/u\c/k tplink

Also, I've managed to dig out an old WA850RE V2, it has the same problems on the official FW, as I did with the RE305 V3 on OpenWRT - Main network devices can't see the repeater side devices.

Any recommendations for a simple device that would do the job?

The darling device for OpenWrt at the moment is the RT3200, which in the UK costs around £50. I have three - one as main router and two as WDS repeaters. If you just search RT3200 on this forum you will see tons of discussion about it. They work perfectly with OpenWrt.

imho, given you witness same issue with both openwrt on RE305, and stock FW on WA850RE, you may have difficulty finding a 'compatible' wireless bridge device without a lot of trial and error (stock, openwrt, padavan, freshtomato, ddwrt etc) ?

fwiw, as you are using Unifi kit, perhaps you can install another unifi AP device and configure it to link wirelessly to existing unifi network. Then connect your ethernet device to the new PoE switch which powers the new unifi device or to the secondary ethernet port on the unifi device?

Based on my experience, cross-manufacturer WDS setups work just fine, as long as both sides are on OpenWRT.

I appreciate all of you taking the time to read through the post.

I think I'm just going to go out and buy a used RE305 and use the stock FW.

I wouldn't bother with all this hackery if there was even a slight chance of routing copper to the end device, but for my current situation, reinventing the wheel doesn't seem worth the time.

Perhaps if we lived in an idyllic non-proprietary world, we wouldn't be having these problems, but that world would then simply be called communism. So for now I'm guessing we're all stuck with proprietary shit until we learn to make our own.