WIFI 5G issue with 23.05.0-rc3 WRT32X

Hello,

I run a LinkSys WRT32X router with 23.05.0-rc3.
Yesterday I came across with the WIFI 5G "Device is not active" and disabled.
As I am on the way to setup this new version, I reinstalled it this morning from .img.
After enter the security WPA password both channels was working. I didn't test it a lot though.
Then after checking with an analyser, for both I changed the channel and for the 5G the width.
Now and again, 2.4G is working fine, 5G is "Device is not active" and disabled even the button left to "Edit" shows "Disable". I can't get it back working.

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option channel '44'
	option band '5g'
	option htmode 'VHT80'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'sae-mixed'
	option macaddr 'xx:xx:e0:ce:80:12'
	option key 'xxxxxxx'

config wifi-device 'radio1'
	option type 'mac80211'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option channel '11'
	option band '2g'
	option htmode 'HT40'
	option country 'FR'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'sae-mixed'
	option macaddr 'xx:xx:xx:ce:80:11'
	option key 'xxxxxxx'

config wifi-device 'radio2'
	option type 'mac80211'
	option path 'platform/soc/soc:internal-regs/f10d8000.sdhci/mmc_host/mmc0/mmc0:0001/mmc0:0001:1'
	option channel '34'
	option band '5g'
	option htmode 'VHT80'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

Is it my mistake? Is it a bug?

Many thanks

Par Toutatis et Bélénos, try to set encryption to WPA2 instead of WPA3.

1 Like

Merci,
I found that my devices are not working with WPA3, no back compatibility (SAE)
But this was not the point as the radio was disabled. I tried different parameters then I rebooted the router. Maybe a reboot is mandatory, not only a restart.
Now it's working again but I don't know exactly why.
It looks a bit sensible. I'll keep an eye on it.
So, thanks for you help.
Le bonsoir du 54

1 Like

Must be groundhog day again…. :smile:

…WRT 1900/3200/32X driver does not support WPA3 at all, it also does not support several other OpenWRT advanced WiFi parameters. It does not support Mu-MIMO and it has issues with certain client Wifi chips. Although it has 4 antennas, it only is 3x3. Activating more than 2 SSIDs per radio seem to cause issues.

You have to be careful with activating the third radio, as the third radio uses another driver, which may conflict with the driver of radio 0 and 1 on certain country code combinations, causing unexpected reduced transmit power an radio 0 and 1. The third radio (not available on 1900) is 1x1 (single antenna) and has no good range anyway.

The Wifi driver of Wifi 0 and 1 is abandoned and has several more ugly bugs since 2017 that can‘t get fixed by OpenWRT due to lack of code support of the vendor. It is one of the worst OpenWRT Wifi drivers around.

On top, OpenWRT V21 has additional Wifi issues, V22 has on top VLAN-bugs and VLAN-related security issues, so there is a known wide gap between v19 and v23. On top, some of the devices as of now start to show worn down capacitors (leading to system instabilities) and faded-out blue LEDs after 5-6 years of continuous operation.

Nevertheless it is still surprisingly a very common device and surprisingly only few of its users seem to be aware of these deficits.

If the HW is not worn down yet, the CPU is still kind of powerful and 512MB RAM is still kind of up to date, but other than that, users strongly recommend to stay away from these devices completely, if you need good WiFi, or otherwise be aware of and accept the ugly WiFi deficits.

5 Likes

Thanks a lot for the advices.

I was told or this is what I understood few years ago that radio2 was only to scan other WiFi around to set the good value to radio0 and radio1. So I'll try to disable it.

Could you tell me what exactly. Could you read my thread and add your advises?
Need help to setup v23 DSA network

This is what I have, almost invisible blue lights in left and middle places. Ports led are good.
Do you have a link to a DIY how to fix it?

This is the first time I can read that, all these issues. It had a good judgement at the time I bought it.
Unfortunately, I don't have the budget to change it. I hope it will last long.

Edit: 03 Sep
I have read that the LEDs are not good and need to be replaced. Another user said the capacity 450uF 16V just at the power connector could be faulty.
Inside voltage at the capacitor was 12.3V
As I had some capacitors with the same value (but 105 degrees C) I changed it.
Voltage is still the same. LEDs are still weak and I can't see any improvement.
I took the voltage at the Power LED, 3.2V. With this voltage it should be very luminous.
If someone know the type or ref of these LEDS, I could replace them.
Many thanks

1 Like

The compromise of course is to keep what is a really good router and buy a standalone AP to handle the wifi you can lick up a Draytek for about GBP30 on ebay....

This was solely to inform unaware users about the known issues of that particular platform, to avoid config problem discussions, which are actually due to hard device limits of that platform.
Users can combine it in any way they like, to make the best of what they have.

In your other thread, you seem to create a problem, where there there seems to be no problem.
Just use your device with v23 and stop worrying about DSA or VLAN at all. According to your post and the answers in the other thread, just use v23 out of the box as is.
Out of the box config is fully sufficient and secure for your use case, just do not change the default network config and accept that the newer config of v23 looks a bit different (thats simply technical progress, not something to worry) . Do not try to import any config from older non-DSA-versions. just use the default network config that came with v23 and you are good to go.
(And if you think that you do not have a default use case then explain it (in the other thread, to avoid further confusion))

2 Likes

True, as a matter of interest, what would you upgrade to if your WRT320/died?

My spare lab unit. Disabled wifi , running with a good AP or two.

I do know what I’ve got as far as it’s flaws go, but it is still a beast of a router paired with good AP’s and a managed switch for my use case. I do relegate guest and IOT networks to the radio1. Never had a stability issue with it for this use.

Beyond that, look to X86-64.

From my perspective, any „Mediatek Filogic“ device (plus optional x86 router, if needed)
I for myself have recently gotten a Mercusys MR90X (Filogic based), was available in Germany for 120€ - has great Wifi throughput, can be installed without serial cable, performant CPU, AX for 2.4 and 5 ( but no Wifi6/6E/7, no USB and no wall mounting holes, so may not be everyones favorite). So far the OpenWRT driver is rocksolid without issues.

E.g. go through the table of hardware, filtering for Mediatek Filogic 830 / 880 devices. All brandnew, them just got added for v23. Recently there were around 10 supported devices. Check their features, not all of them may fit your requirements (e.g. not all have USB) and not all might be available in your country. Also vendors for sure to release even more such devices in the coming months, so no need to rush it.

Qualcom also has new recent interesting Wifi chips, but I have no experience at all in Qualcom based devices, you might check discussion threads about them. People claim Mediatek to have the much better open source support. Or keep an eye on the hardware section of this forum for a few weeks, people often report recent bargains and recommendations.

It's not just with 5G, 2.4Ghz.
I do have a TP-LINK WR1043N V5 and WIFI was working fine yesterday until I had the brilliant idea of checking about new Openwrt release and updates.
No new releases. But there was 13 updates. I applied all updates and I realised that WIFI was no more. One of the updates is breaking WIFI.

This is the list of packages AFTER first breaking. I had to backup things, reset to defaults, setup everything again.

[23:45:38] <TP-Link> wpad-basic-mbedtls  2023-06-22-599d00be-1.2  >> 2023-09-08-e5ccbfc6-3   
[23:45:38] <TP-Link> ubus                2022-06-15-9913aa61-1    >> 2023-06-05-f787c97b-1   
[23:45:38] <TP-Link> ucode-mod-ubus      2023-04-03-51638672-1    >> 2023-06-06-c7d84aae-1   
[23:45:38] <TP-Link> ucode-mod-uci       2023-04-03-51638672-1    >> 2023-06-06-c7d84aae-1   
[23:45:38] <TP-Link> netifd              2023-06-04-ec9dba72-1    >> 2023-09-19-7a58b995-1   
[23:45:40] <TP-Link> ubusd               2022-06-15-9913aa61-1    >> 2023-06-05-f787c97b-1   
[23:45:41] <TP-Link> ucode-mod-math      2023-04-03-51638672-1    >> 2023-06-06-c7d84aae-1   
[23:45:43] <TP-Link> luci-mod-status     git-23.210.72323-b6dc2f2 >> git-23.236.53405-9b3c7d3
[23:45:44] <TP-Link> ucode-mod-fs        2023-04-03-51638672-1    >> 2023-06-06-c7d84aae-1   
[23:45:46] <TP-Link> ucode               2023-04-03-51638672-1    >> 2023-06-06-c7d84aae-1   
[23:45:47] <TP-Link> luci-base           git-23.219.80063-bece581 >> git-23.236.53405-fc638c8
[23:45:49] <TP-Link> libucode20220812    2023-04-03-51638672-1    >> 2023-06-06-c7d84aae-1   
[23:45:50] <TP-Link> luci-mod-network    git-23.218.31344-f74f1cb >> git-23.233.52805-3a0ef93
[23:45:52] <TP-Link> hostapd-common      2023-06-22-599d00be-1.2  >> 2023-09-08-e5ccbfc6-3   
[23:45:53] <TP-Link> urngd               2020-01-21-c7f7b6b6-1    >> 2023-07-25-7aefb47b-1   
[23:45:55] <TP-Link> 15 updates available..

That's a "bot" I ran on an IRC network. It just does basic things like displaying updates.

I'm not skilled to setup or finetuning issues like this one. I guess I have to reset to defaults and apply the safe packages manually and avoid the letal ones for later....