Wifi 41Mbps, LAN 321Mbps

1.
Network map is in pic.


Main router - Orange Pi R1+ LTS, Linux wrt 5.4.154, LuCI openwrt-21.02 branch (git-21.295.67054-13df80d) / OpenWrt 21.02.1 r16325-88151b8303
dumb AP - TPLink Archer C6 v3.2. Linux OpenWrt 5.10.162, LuCI Master (git-22.361.69865-deed682) / OpenWrt SNAPSHOT (r21714-9ac377d0e0)

2.
AP /etc/config/network:

onfig interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fdf2:5299:319b::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.2.2'
	option gateway '192.168.2.1'
	list dns '192.168.2.1'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option auto '0'

config interface 'wan6'
	option device 'wan'
	option proto 'dhcpv6'
	option auto '0'
	option reqaddress 'try'
	option reqprefix 'auto'

config interface 'Guest'
	option proto 'static'
	option ipaddr '192.168.3.1'
	option netmask '255.255.255.0'
	list dns '9.9.9.9'
	list dns '149.112.112.112'

AP /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option country 'CZ'
	option htmode 'HT20'
	option cell_density '0'
	option channel '11'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid '..............'
	option encryption 'sae-mixed'
	option key '...........'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
	option band '5g'
	option htmode 'VHT80'
	option cell_density '0'
	option channel 'auto'
	option country 'CZ'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid '............'
	option encryption 'sae-mixed'
	option key '.......'
	option network 'lan'

config wifi-iface 'wifinet3'
	option device 'radio0'
	option mode 'ap'
	option ssid 'Guest'
	option encryption 'none'
	option isolate '1'
	option network 'Guest'
	option disabled '1'

Main router /etc/config/network:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd6c:a70b:5c1b::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'eth1'

config device
	option name 'eth1'
	option macaddr '..........'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.2.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device
	option name 'eth0'
	option macaddr '.........'

config interface 'wan'
	option device 'eth0'
	option proto 'dhcp'
	option peerdns '0'
	list dns '9.9.9.9'
	list dns '149.112.112.112'

config interface 'wan6'
	option device 'eth0'
	option proto 'dhcpv6'

config interface 'docker'
	option device 'docker0'
	option proto 'none'
	option auto '0'

config device
	option type 'bridge'
	option name 'docker0'

No /etc/config/wireless on the main router.

3.
The cables are ok, changed them, the issue persisted.

this config seems incorrect to me:

  1. dumb AP config should consist of interfaces without IP addressing (except the management interface).

e.g. this should be something like:

config interface 'Guest'
	option proto 'none'
    option  device ...

the whole point of **dumb** AP is that it is really dumb, just provides physical connectivity and all high(er) level network services are provided by the main router (e.g. dhcp, dns etc)

  1. guest interface has no device assigned - not sure if this is copy-paste error or indeed this is your config.

  2. there is no guest network configuration on main, how do you want to use guest network?

there are plenty of guides how to create dumb AP + guest vlan, first you should fix that.

I followed this guide to setup the dumb AP.
For the Guest interface, I used this guide.

there are plenty of guides how to create dumb AP + guest vlan, first you should fix that.

Could you point me to some? Most of the ones I found were almost the same as the ones I followed, the other ones were from older version of OpenWrt and didn't work. Does this have something to do with my speed problem, or is it a separate issue?

most likely it is unrelated.

but imho the guest guide is wrong: that simply creates a guest network but according to screenshots there is wan connection and firewall config, neither of which would be set on a real dumb AP. 3rd video on first guide explains how to extend a guest wifi to a dumb AP (in your case it would a guest network on main without wifi, extended as guest vlan and joined by a wlan on the dumb ap).

have you tried to connect your AP directly to ISP modem and measure performance?

The two links from above are correct, but may be misunderstood and/or applied incorrectly. The dumb AP guide (first link) is accurate for creating a simple single network dumb AP.

The second link builds on that concept to create a routed guest network within the dumb AP. This is for situations where the main router does not have a guest network configured (for example, many routers using the stock firmware and/or those from ISPs do not have the ability to setup VLANs).

It probably would be useful to either expand upon the existing standard dumb AP guide, or create a companion guide that handles VLANs and multiple unique SSIDs.

I've Meraki mr16 AP, first it was a dumb AP. Then I found the second link, and I created a guest network. My main router is opensense without wifi cards.
Everything is working fine. Guest haven't access to main network, the ar isolate from themself.

or the one about guest network on "dumb" AP is poorly worded ... but anyhow, the questionable title debate will not solve OP's problem regarding poor wifi unfortunately.

Since your main router does have VLAN capbility, you may want to consider creating a guest VLAN and then using the dumb AP as purely a dumb AP for both VLANs, rather than routing the guest network on the dumb AP... but this is not the root if your issue, so you can deal with that at a later time, if you want.

Can you elaborate about what is poorly worded? Input is always welcome since we can update the articles to make it more clear.

That is true. I only pointed out the fact that the two articles are correct and applicable because it seemed that you believed they had lead the OP astray. If there are issues with those articles such that they are unclear and led to some confusion, let's fix that. As you have pointed out, this is tangential to the OP's issue, so to avoid further cluttering this thread, feel free to create a new thread (probably under the documentation section) and/or reach out to me by PM with pointers about what needs to be improved in those articles.

Yes, my main router does have a VLAN and I have manage switches too, but I never play with VLAN.
I saw on YT Chanel MarcOneFifty, he show how to do that with all stuff like guest, IoT and main wifi.

I wonder what kind of benefits I can get with VLAN (I know the guest and main LAN are separate, and the guest client cann't browse the main LAN and vica verse.
But if I do a firewall rules I can get the same situation.
(Like on the second link "Guest wifi on dumb AP" if I remmeber correct the title of article on openWRT.))

Setting the guest network up on the main router and using the AP is a dual-SSID dumb AP will ultimately produce the same result, but there are two benefits: 1) all routing occurs on the router -- this simplifies administration and troubleshooting, and 2) if you have multiple APs, you can have all APs working with both/all of your networks.

But this is still not related to your speed issues, just general network admin stuff.

well, people tend to believe everybody thinks the way they do and making assumptions accordingly but this can lead to confusion. i'll rather reach out you in PM why the guide is problematic in my opinion.

to OP: if there is any chance, as suggested earlier, to put the owrt router in place of main for testing purpose to verify if the owrt router has the issue or the original main router in combination with owrt, and/or relocate the owrt ap, i think could be a good test.