Wifi 41Mbps, LAN 321Mbps

Hi, I have setup a dumb AP and a wireless network, but when I connect to it I get very slow speeds, the upload stays the same (23Mbps), but the download is at 41Mbps, instead of 321Mbps, which my ISP provides and I normaly get through LAN. How can I get the same speeds on wireless as I do on wired?

What router device is running OpenWrt? (Looks like a single band device from your image?)

What type of wifi adapter is fitted to the device you are using to measure the speed?

eg. most budget phones only have a 1x1 adapter, so to expect anything up to 60 Mbps in Wireless N on 2.4 GHz (20 MHz) is being optimistic.

If you want faster speeds, you need to use 5 GHz wifi. OpenWrt may still struggle for 300 Mbps over wireless on most budget routers.

fwiw, if you want best performance and compatibility in dumb AP mode, use a router or AP running stock firmware.

The AP is Tp-Link Archer C6 v3.2 (main router is Orange Pi R1 LTS), wifi card is Intel 6250.

have you tried using 5 ghz wifi on the C6 to see what speeds you can get on OpenWrt?

Intel 6250 is a 2x2 wireless N card. Card will max out at around 150 Mbps in theory on 5 GHz in 40MHz mode.

(fwiw, I had Intel 6200, 6205, 6300 cards in former laptops and never saw more than 45 mbps on 2.4 ghz wifi on routers running OpenWrt)

Otherwise, I suggest running stock firmware on the C6 if it is only to be used as a dumb AP.

If you want faster 5 GHz speeds, consider replacing the 6250 card with a 7260 AC 2x2 wifi card. Note that a lot of HP and Lenovo laptops use white listed BIOS, so you may encounter problems with trying to get the replacement wifi card working in the laptop.

On 5GHz I get 140Mbps, but the coverage is poorer than 2.4GHz.
I'll look at the 7260 AC, the whitelisting won't be an issue, I'm running SeaBIOS. Thanks for the help, it's good to know that it is a harware limitation.

I have the same issue on r6220. Router work as dumb AP, the measured wifi speed is max 50MBps download and 200MBps upload (LibreSpeed on docker).
LAN is working fine.
The another problem is that, I cann't connect to wifi with mobile (Xiaomi,Motorola), Lenovo Yoga connecting with a long time, but after connected I get No Internet Connection, but when I plug the LAN cable to router and Lenovo, the Internet is working fine.
The problem is present on 2.4GHz on 5GHz only speed is working fine, but connection is the same problem as 2.4GHz

Do you have the Network card selected? It's under Network->Wireless-> edit your device

tip: avoid 7260 wifi cards made for HP and Lenovo unless the seller can confirm it will work in your computer.

I mean, it shouldn't be a problem, I have no whitelist present, I'm running SeaBIOS+coreboot. And from what I checked, people have succesfully installed the AC7260 on the *20/30 models of thinkpads, example. Is there anything else you had in mind that will cause it to not work?


on 2.4GHz the recommended channels are 1,6,11 for maximum performance. could you try to change to a different channel from the configured 9?

also, in general wifi != wired performance wise, there are so many factors impact wifi performance that you can expect the same speed as on wired network, or you can expect the advertised maximum theoretical N/AX,AX speed but you'll unlikely to achieve in real life environment: wall type & layout, neighbor's wifi, wifi client (it is not enough that your AP can shout loudly if client can whisper only) etc etc.

sorry, I'm not familiar with seabios until you mentioned Thinkpad.

fwiw, there is an unbranded AX mini PCI card (mpe-ax3000h) but they are quite expensive. I think they use Intel ax200 wifi chipset and drivers.

I don't know if I understand you correct, you mean the Network card on my laptop??
Yes I have a correct wifi card.
In openWRT setting i checked Force 40MHz (noscan 1) and the width chanel 40MHz, unchecked the "b" standard, only N. ON Meraki MR16 I have the same config and the speed I get is about 157MBps UP/DW (measured).

Here is my topic:

I still get the same speeds on 6/11. I know that wireless != wired, but I got better speeds (around 200) on my phone (LG V20) when on the stock proprietary modem my ISP gave me, and now I get 46/130 max, that's what made me wonder.

Thanks, I'll take a look.

How did you meausered it??
iperf?? or intenet speed (by a page like speedtest)??
The better option is to get it with iperf or librespeed on docker. You measure only your wifi speed not ISP speed.

I always used a service like speedtest.net. I'll try it with another method like you mentioned.

the problem is that, you measur wifi and ISP speed, so your wifi maybe is ok, but ISP have a problem.
Or another the ISP is correct you can get 1GB but your wifi have issue and you get only 10MB :wink:

I don't think it's an issue on the ISP's side, because I get 321Mbps through LAN, which corresponds with the advertised speed I signed up for.

Yes in your case is true. You have problem with wifi.

ok, then start from basics:

  1. simple diagram of your network, e.g. ISP - main router - dumb AP with hardware & software version details.
  2. content of /etc/config/network and /etc/config/wireless from both main and dumb AP. obscure any sensitive information.
  3. assuming main and dumb is connected via cable please check or replace cable.