Wifi 2.4GHz keeps blocking after 19.7.2 upgrade (archer c2 V1)

I'm using Openwrt on some devices. The last is an Archer C2 V1 that was working well with 19.7.1.
Some days ago I updated to .2 (keeping configuration) and from that moment I have a lot of problems on wifi 2.4Ghz. Randomly, it blocks all connections on 2.4ghz (i have around 10 home automation devices connected h24) but the 5ghz keeps working on phones or pc's. The router is configured as a Dumb AP (DHCP is on another device).
The only solution I found as for now it's a reboot from Luci.

How can I find the problem? Any suggestion?

Happened with me before
Remove wpad-basic and Install wpad
Install Wireless kernel modules for your router
For example my chipset was mediatek 7628
So the wireless modules was kmod-76x8

Thanks for the answer. Here's the results.

  • kmod-mt76x0-common was already installed
  • I removed wpad-basic but now opkg doesn't find the wapd package. Seems like opkg has no connection and i'm trying tio fix that.
    Obviously i have no wifi at all at the moment without Wpad. Can tou please tell me me differences netween wpad and wpad-basic?

Edit: I installed wpad by hand and next days I will test the config.

If “Opkg update” gives you an error that there is no connectivity check your wan config and make sure you can access internet

Ok, I solved the opkg problem, installed wpad and removed wpad-basic.

Nothing changed. This morning, 2.4 devices were all disconnected.
In the logs I have full of these lines:

Sun Mar 22 08:18:59 2020 daemon.notice hostapd: wlan1: STA xx:xx:xx:xx:xx:xx IEEE 802.11: did not acknowledge authentication response

on different mac addresses.
In the wireless menu, all 2.4 devices were marked ad "disabled". 5 ghz devices are working correctly.

Maybe that devices were disabled because of this setting?

Disassociate On Low Acknowledgement: Allow AP mode to disconnect STAs based on low ACK condition

It was flagged on the 2.4 radio. I took off the flag and the radio restart working but i supsect that saving the setting simply restart the interface. However it's flagged on the 5ghz too...

Nothing solved the problem. It's a week that i switched back to 19.7.1 and with that i have no problem at all.
I hope that devs will find the problem for the next 19.7.3. I know that it's not the best choice to stay with a older version...

Did a new version solved your problem?