Wi-Fi Not Working on Sophos AP55

"Wi-Fi Not Working on Sophos A55 in OpenWrt - Firmware Issues and Driver Problems"

Hello, I am trying to get Wi-Fi working on my Sophos A55 AP with OpenWrt, but I am facing several issues related to the Wi-Fi firmware and drivers. Here is what I have encountered:

System Details:

  • Device: Sophos A55
  • OpenWrt Version: [Enter your OpenWrt version]
  • Wi-Fi Chipset: QCA988X

Problem Summary:

  1. Firmware Missing:
    When trying to load the Wi-Fi driver (ath10k_pci), I am getting errors related to missing firmware files:

pgsql

CopyEdit

Failed to find firmware-N.bin (N between 2 and 6) from ath10k/QCA988X/hw2.0: -12

I have tried to download the firmware from GitHub, but the files are not available (404 error).
2. Board Files Not Found:
I cannot find board.bin or board-2.bin files in the directory /lib/firmware/ath10k/QCA988X/hw2.0/. I have tried downloading them from the official repository, but I’m still facing issues. The device does not seem to recognize the firmware.
3. Driver Loading Issues:
The driver ath10k_pci is not initializing properly and returns an error message:

csharp

CopyEdit

[Error] could not init core (-145)

This prevents Wi-Fi from working correctly.
4. Commands I Have Tried:

  • Installing necessary packages:

nginx

CopyEdit

opkg install kmod-ath10k ath10k-firmware-qca988x
  • Checking dmesg for errors related to Wi-Fi:

perl

CopyEdit

dmesg | grep ath10k
  • Manually transferring board.bin to /lib/firmware/ath10k/QCA988X/hw2.0/
  • Trying to load the driver with:

nginx

CopyEdit

modprobe ath10k_pci
```But still no success in bringing up the Wi-Fi interface.

### What I Have Done So Far:

* Downloaded and transferred the `board.bin` file manually.
* Installed required firmware packages.
* Tried reloading the `ath10k_pci` module.
* Checked the system logs and firmware directory.

### Request for Help:

Can anyone help me with the following:

* Where can I get the correct `board.bin` and firmware files for QCA988X?
* How can I make sure the driver is loaded correctly?
* Is there something specific to **Sophos A55** that needs to be configured for the Wi-Fi to work?

Any suggestions or solutions would be greatly appreciated!

Thank you!

Isn't support here AFAIK, what openwrt image are you using ?

OpenWrt Version:

  • OpenWrt 24.10.0 (Build ID: r28427-6df0e3d02a)
  • LuCI version: openwrt-24.10 branch 25.014.55016~7046a1c

Device Information:

  • Model: Sophos AP55
  • Architecture: Qualcomm Atheros QCA9558 (ver 1 rev 0)
  • Target Platform: ath79/generic
  • Kernel Version: 6.6.73

System Information:

  • Hostname: OpenWrt
  • Local Time: 2025-03-14 09:13:39
  • Uptime: 0h 24m 52s
  • Load Average: 0.00, 0.00, 0.00

never mind, there's typo in your 1st post, and topic.

A55 <> AP55.

please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# ubus call system board
t /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
{
        "kernel": "6.6.73",
        "hostname": "OpenWrt",
        "system": "Qualcomm Atheros QCA9558 ver 1 rev 0",
        "model": "Sophos AP55",
        "board_name": "sophos,ap55",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "24.10.0",
                "revision": "r28427-6df0e3d02a",
                "target": "ath79/generic",
                "description": "OpenWrt 24.10.0 r28427-6df0e3d02a",
                "builddate": "1738624177"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd91:e413:3d6f::/48'
        option packet_steering '1'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option ifname 'eth0'
        option proto 'dhcp'

config interface 'wigeguard'
        option proto 'wireguard'
        option private_key 'CIR9fdXNvbGYEdvqOt5lbIQpf0xlRBi1ajJP1wcfJEw='
        list addresses '192.168.10.1'

root@OpenWrt:~# cat /etc/config/wireless
root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@OpenWrt:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port 68,
# see https://dev.openwrt.org/ticket/4108
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        68
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://github.com/openwrt/openwrt/issues/5066
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        500
        option proto            udp
        option target           ACCEPT


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:11:22:33:44:66
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        80
#       option dest                     lan
#       option dest_ip          192.168.16.235
#       option dest_port        80
#       option proto            tcp

# port redirect of remapped ssh port (22001) on wan
#config redirect
#       option src              wan
#       option src_dport        22001
#       option dest             lan
#       option dest_port        22
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port 80
#       option dest             wan
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.45.2
#       option src_mac  00:11:22:33:44:55
#       option src_port         1024
#       option src_dport        80
#       option dest_ip  194.25.2.129
#       option dest_port        120
#       option proto    tcp
root@OpenWrt:~#

might want to generate new keys now ...

seems there's no radio detected ?

post dmesg.

root@OpenWrt:~# dmesg
[    0.000000] Linux version 6.6.73 (builder@buildhost) (mips-openwrt-linux-musl-gcc (OpenWrt GCC 13.3.0 r28427-6df0e3d02a) 13.3.0, GNU ld (GNU Binutils) 2.42) #0 Mon Feb  3 23:09:37 2025
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019750 (MIPS 74Kc)
[    0.000000] MIPS: machine is Sophos AP55
[    0.000000] SoC: Qualcomm Atheros QCA9558 ver 1 rev 0
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0
[    0.000000] Kernel command line: console=ttyS0,115200n8 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes, linear)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 32480
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 119968K/131072K available (6819K kernel code, 604K rwdata, 900K rodata, 1204K init, 233K bss, 11104K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 51
[    0.000000] CPU clock: 720.000 MHz
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 5309056796 ns
[    0.000001] sched_clock: 32 bits at 360MHz, resolution 2ns, wraps every 5965232126ns
[    0.008362] Calibrating delay loop... 358.80 BogoMIPS (lpj=1794048)
[    0.075007] pid_max: default: 32768 minimum: 301
[    0.090103] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.097896] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.114756] RCU Tasks Trace: Setting shift to 0 and lim to 1 rcu_task_cb_adjust=1 rcu_task_cpu_ids=1.
[    0.129491] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.140004] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.149897] pinctrl core: initialized pinctrl subsystem
[    0.158585] NET: Registered PF_NETLINK/PF_ROUTE protocol family
[    0.165459] thermal_sys: Registered thermal governor 'step_wise'
[    0.167550] /ahb/apb: Fixed dependency cycle(s) with /ahb/apb/interrupt-controller@18060010
[    0.196419] clocksource: Switched to clocksource MIPS
[    0.212729] NET: Registered PF_INET protocol family
[    0.218170] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.227345] tcp_listen_portaddr_hash hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.236360] Table-perturb hash table entries: 65536 (order: 6, 262144 bytes, linear)
[    0.244644] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.252817] TCP bind hash table entries: 1024 (order: 1, 8192 bytes, linear)
[    0.260361] TCP: Hash tables configured (established 1024 bind 1024)
[    0.267806] MPTCP token hash table entries: 512 (order: 0, 6144 bytes, linear)
[    0.275733] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.282742] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.291078] NET: Registered PF_UNIX/PF_LOCAL protocol family
[    0.297215] PCI: CLS 0 bytes, default 32
[    0.305512] workingset: timestamp_bits=14 max_order=15 bucket_order=1
[    0.314138] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.320395] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.338555] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 251)
[    0.349838] pinctrl-single 1804002c.pinmux: 544 pins, size 68
[    0.357151] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.368832] printk: console [ttyS0] disabled
[    0.373854] 18020000.uart: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 2500000) is a 16550A
[    0.383202] printk: console [ttyS0] enabled
[    0.392110] printk: bootconsole [early0] disabled
[    0.432558] spi-nor spi0.0: mx25l12805d (16384 Kbytes)
[    0.437928] 5 fixed-partitions partitions found on MTD device spi0.0
[    0.444410] OF: Bad cell count for /ahb/spi@1f000000/flash@0/partitions
[    0.451169] OF: Bad cell count for /ahb/spi@1f000000/flash@0/partitions
[    0.458128] Creating 5 MTD partitions on "spi0.0":
[    0.463002] 0x000000000000-0x000000040000 : "u-boot"
[    0.470954] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.478191] 0x000000050000-0x000000060000 : "art"
[    0.484871] OF: Bad cell count for /ahb/spi@1f000000/flash@0/partitions
[    0.491946] 0x000000060000-0x000000070000 : "config"
[    0.499188] OF: Bad cell count for /ahb/spi@1f000000/flash@0/partitions
[    0.506174] 0x000000070000-0x000001000000 : "firmware"
[    0.513822] 2 uimage-fw partitions found on MTD device firmware
[    0.519883] Creating 2 MTD partitions on "firmware":
[    0.524925] 0x000000000000-0x000000280000 : "kernel"
[    0.531769] 0x000000280000-0x000000f90000 : "rootfs"
[    0.538539] mtd: setting mtd6 (rootfs) as root device
[    0.543746] 1 squashfs-split partitions found on MTD device rootfs
[    0.550062] 0x0000006a0000-0x000000f90000 : "rootfs_data"
[    0.986921] ag71xx-legacy 19000000.eth: connected to PHY at mdio.0:04 [uid=004dd072, driver=Qualcomm Atheros AR8035]
[    0.998305] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode: rgmii-id
[    1.005380] i2c_dev: i2c /dev entries driver
[    1.012726] NET: Registered PF_INET6 protocol family
[    1.026348] Segment Routing with IPv6
[    1.030201] In-situ OAM (IOAM) with IPv6
[    1.034343] NET: Registered PF_PACKET protocol family
[    1.039552] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.052968] 8021q: 802.1Q VLAN Support v1.8
[    1.079859] PCI host bridge to bus 0000:00
[    1.084036] pci_bus 0000:00: root bus resource [mem 0x10000000-0x11ffffff]
[    1.091057] pci_bus 0000:00: root bus resource [io  0x0000]
[    1.096726] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    1.104808] pci 0000:00:00.0: [168c:003c] type 00 class 0x028000
[    1.110954] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x001fffff 64bit]
[    1.117905] pci 0000:00:00.0: reg 0x30: [mem 0x00000000-0x0000ffff pref]
[    1.124783] pci 0000:00:00.0: supports D1
[    1.128870] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    1.135734] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 00
[    1.142511] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x101fffff 64bit]
[    1.149963] pci 0000:00:00.0: BAR 6: assigned [mem 0x10200000-0x1020ffff pref]
[    1.169756] clk: Disabling unused clocks
[    1.183424] VFS: Mounted root (squashfs filesystem) readonly on device 31:6.
[    1.194872] Freeing unused kernel image (initmem) memory: 1204K
[    1.200920] This architecture does not have kernel memory protection.
[    1.207480] Run /sbin/init as init process
[    1.211637]   with arguments:
[    1.211642]     /sbin/init
[    1.211648]   with environment:
[    1.211653]     HOME=/
[    1.211658]     TERM=linux
[    1.944791] init: Console is alive
[    1.948666] init: - watchdog -
[    3.524032] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.612365] usbcore: registered new interface driver usbfs
[    3.618059] usbcore: registered new interface driver hub
[    3.623555] usbcore: registered new device driver usb
[    3.637739] gpio_button_hotplug: loading out-of-tree module taints kernel.
[    3.655478] ehci-platform 1b000000.usb: EHCI Host Controller
[    3.661336] ehci-platform 1b000000.usb: new USB bus registered, assigned bus number 1
[    3.669438] ehci-platform 1b000000.usb: irq 12, io mem 0x1b000000
[    3.696437] ehci-platform 1b000000.usb: USB 2.0 started, EHCI 1.00
[    3.703944] hub 1-0:1.0: USB hub found
[    3.708347] hub 1-0:1.0: 1 port detected
[    3.717671] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.735514] init: - preinit -
[    8.066449] random: crng init done
[   12.277859] eth0: link up (1000Mbps/Full duplex)
[   13.536170] jffs2: notice: (535) jffs2_build_xattr_subsystem: complete building xattr subsystem, 46 of xdatum (44 unchecked, 2 orphan) and 70 of xref (8 dead, 0 orphan) found.
[   13.558031] mount_root: switching to jffs2 overlay
[   13.595617] overlayfs: upper fs does not support tmpfile.
[   13.609102] urandom-seed: Seeding with /etc/urandom.seed
[   13.977263] eth0: link down
[   13.994051] procd: - early -
[   13.997376] procd: - watchdog -
[   14.748576] procd: - watchdog -
[   14.753181] procd: - ubus -
[   14.967445] procd: - init -
[   17.729276] kmodloader: loading kernel modules from /etc/modules.d/*
[   18.937187] Loading modules backported from Linux version v6.12.6-0-ge9d65b48ce1a
[   18.944791] Backport generated by backports.git v6.1.110-1-35-g410656ef04d2
[   19.364633] urngd: v1.0.2 started.
[   20.199061] PPP generic driver version 2.4.2
[   20.204656] NET: Registered PF_PPPOX protocol family
[   20.356835] wireguard: WireGuard 1.0.0 loaded. See www.wireguard.com for information.
[   20.364794] wireguard: Copyright (C) 2015-2019 Jason A. Donenfeld <Jason@zx2c4.com>. All Rights Reserved.
[   21.096134] ath10k_pci 0000:00:00.0: enabling device (0000 -> 0002)
[   21.104809] ath10k_pci 0000:00:00.0: pci irq legacy oper_irq_mode 1 irq_mode 0 reset_mode 0
[   23.090410] ath10k_pci 0000:00:00.0: qca988x hw2.0 target 0x4100016c chip_id 0x043202ff sub 0000:0000
[   23.099828] ath10k_pci 0000:00:00.0: kconfig debug 0 debugfs 1 tracing 0 dfs 1 testmode 0
[   23.110561] ath10k_pci 0000:00:00.0: firmware ver 10.2.4-1.0-00047 api 5 features no-p2p,raw-mode,mfp,allows-mesh-bcast crc32 35bd9258
[   23.673247] ath10k_pci 0000:00:00.0: board_file api 1 bmi_id N/A crc32 bebc7c08
[   29.876429] ath10k_pci 0000:00:00.0: wmi unified ready event not received
[   30.220165] ath10k_pci 0000:00:00.0: could not init core (-145)
[   30.226294] ath10k_pci 0000:00:00.0: could not probe fw (-145)
[   30.285210] ath: phy1: eeprom contains invalid mac address: 4b:6c:f4:2e:2f:9a
[   30.292518] ath: phy1: random mac address will be used: de:c0:5e:28:2b:34
[   30.300397] ath: EEPROM regdomain: 0xdbe2
[   30.300407] ath: EEPROM indicates we should expect a country code
[   30.300422] ath: invalid regulatory domain/country code 0x9be2
[   30.300429] ath: Invalid EEPROM contents
[   30.304428] ath9k 18100000.wmac: failed to initialize device
[   30.310209] ath9k: probe of 18100000.wmac failed with error -22
[   30.318585] kmodloader: done loading kernel modules from /etc/modules.d/*
[   31.236533] usb_vbus: disabling
[   48.110840] br-lan: port 1(eth0) entered blocking state
[   48.116169] br-lan: port 1(eth0) entered disabled state
[   48.121562] ag71xx-legacy 19000000.eth eth0: entered allmulticast mode
[   48.128441] ag71xx-legacy 19000000.eth eth0: entered promiscuous mode
[   51.252422] eth0: link up (1000Mbps/Full duplex)
[   51.258095] br-lan: port 1(eth0) entered blocking state
[   51.263419] br-lan: port 1(eth0) entered forwarding state

this can't be good.
ART is where the wifi calibration data is stored, it could explain why the radios aren't working.

Thanks everyone for your help with the Wi-Fi radiator issue on my device. As mentioned before, the ART (Access Radio Transmit) section seems to be missing or corrupted, which is causing the issue.

Does anyone have a solution for this problem? It would be useful to get a suggestion for possibly repairing or restoring the ART data.

Thanks in advance for all suggestions and help!

Kind regards,

ART is unique for each unit, if it's corrupted, there's not much you can do.