I changed the Wi-Fi modules several times while I was choosing the best one, during this time there were few records left in the list of wireless devices about modules already disconnected from the system, I was able to remove information about their presence in the system, so now only one wireless module is listed in gui, but there is such a problem that after power on the system, the Wi-Fi module does not work, in gui, it hangs in the running status, but the icon displays the absence of a signal, so that it works, I need to turn it off through the button and then start it. Please tell me how to fix this without resetting the settings.
please tell us something else than "it doesn't work".
connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </>
" button:
Remember to redact passwords, MAC addresses and any public IP addresses you may have:
ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
root@OpenWrt:~# ubus call system board
{
"kernel": "5.15.150",
"hostname": "OpenWrt",
"system": "AMD Ryzen Threadripper 1950X 16-Core Processor",
"model": "ASROCK X399 Taichi",
"board_name": "asrock-x399-taichi",
"rootfs_type": "squashfs",
"release": {
"distribution": "OpenWrt",
"version": "23.05.3",
"revision": "r23809-234f1a2efa",
"target": "x86/64",
"description": "OpenWrt 23.05.3 r23809-234f1a2efa"
}
}
cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd75:10ca:7db4::/48'
config device
option name 'br-lan'
option type 'bridge'
option ipv6 '0'
list ports 'eth0'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.0.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'eth1'
option proto 'dhcp'
option type 'bridge'
config device
option name 'eth0'
option ipv6 '0'
config device
option name 'phy0-ap0'
option ipv6 '0'
config device
option name 'eth1'
option ipv6 '0'
option macaddr '*******'
cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:00/0000:00:1c.0/0000:01:00.0'
option channel 'auto'
option band '2g'
option htmode 'HE80'
option legacy_rates '1'
option cell_density '0'
option country 'RU'
option noscan '1'
config wifi-iface 'wifinet0'
option device 'radio3'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2+ccmp'
option key '******'
option network 'lan'
config wifi-iface 'wifinet1'
option device 'radio0'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2+ccmp'
option key '*******'
option network 'lan'
option wpa_group_rekey '1800'
option wmm '0'
cat /etc/config/dhcp
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '1'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option cachesize '1000'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option filter_aaaa '0'
option filter_a '0'
config dhcp 'lan'
option interface 'lan'
option start '2'
option limit '250'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
cat /etc/config/firewall
config defaults
option syn_flood '1'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
list network 'lan'
config zone
option name 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'
list network 'wan'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config include 'homeproxy_pre'
option type 'nftables'
option path '/var/run/homeproxy/fw4_pre.nft'
option position 'table-pre'
config include 'homeproxy_post'
option type 'nftables'
option path '/var/run/homeproxy/fw4_post.nft'
option position 'table-post'
I recently started using openvrt, I have not yet learned where the most important system configurations are stored.
post lspci
too, thnx.
lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller
00:01.0 VGA compatible controller: Device 1234:1111 (rev 02)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Control ler #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Device 000c
00:1c.1 PCI bridge: Intel Corporation Device 000c
00:1c.2 PCI bridge: Intel Corporation Device 000c
00:1c.3 PCI bridge: Intel Corporation Device 000c
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controll er #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Control ler #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (r ev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SA TA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 Network controller: MEDIATEK Corp. MT7922 802.11ax PCI Express Wireless Network Adapter (rev 01)
05:01.0 PCI bridge: Intel Corporation Device 0001
05:02.0 PCI bridge: Intel Corporation Device 0001
05:03.0 PCI bridge: Intel Corporation Device 0001
05:04.0 PCI bridge: Intel Corporation Device 0001
06:12.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controll er (rev 03)
06:13.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controll er (rev 03)
root@OpenWrt:~# lspci
00:00.0 Host bridge: Intel Corporation 82G33/G31/P35/P31 Express DRAM Controller
00:01.0 VGA compatible controller: Device 1234:1111 (rev 02)
00:1a.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation Device 000c
00:1c.1 PCI bridge: Intel Corporation Device 000c
00:1c.2 PCI bridge: Intel Corporation Device 000c
00:1c.3 PCI bridge: Intel Corporation Device 000c
00:1d.0 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev 92)
00:1f.0 ISA bridge: Intel Corporation 82801IB (ICH9) LPC Interface Controller (rev 02)
00:1f.2 SATA controller: Intel Corporation 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA Controller [AHCI mode] (rev 02)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 02)
01:00.0 Network controller: MEDIATEK Corp. MT7922 802.11ax PCI Express Wireless Network Adapter (rev 01)
05:01.0 PCI bridge: Intel Corporation Device 0001
05:02.0 PCI bridge: Intel Corporation Device 0001
05:03.0 PCI bridge: Intel Corporation Device 0001
05:04.0 PCI bridge: Intel Corporation Device 0001
06:12.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 03)
06:13.0 Ethernet controller: Intel Corporation 82540EM Gigabit Ethernet Controller (rev 03)
I would clean up a bit the wireless config file by deleting the wifinet0
stanza and then renaming wifinet1
to wifinet0
Unfortunately, it did not help, also after the reboot the status is turned off, but the turn off button is assigned, not turn on, and there is also an inscription 'Wireless is not associated'
HE80 is not possible on 2 GHz. Setting wmm to 0 prevents operation at speeds higher than 54 Mb (g standard). No wifi-device named radio3 exists so you should remove that interface from your configuration.
It may be better to remove the entire /etc/config/wireless file then reboot to let the firstboot scripts build a new one that matches your hardware. Then configure wireless again.
If there is a button to turn wireless on/off (unusual on x86), OpenWrt does that through a script in /etc/rc.button. You can remove the script or chmod it to have no execute permission to disable the button. Laptops may have wifi enabled/disabled through the BIOS, in that case it is out of the OS control and you'll need to set up the default state in BIOS.
I remove /etc/config/wireless, configure it again, but still wireless is inactive after reboot, only manual disable and enable perform it to work.
cat /etc/config/wireless
config wifi-device 'radio0'
option type 'mac80211'
option path 'pci0000:00/0000:00:1c.0/0000:01:00.0'
option channel 'auto'
option band '2g'
option htmode 'HE40'
option country 'RU'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'psk2+ccmp'
option key '*******'
What is this manual button connected to? Most desktops do not have a wifi enable button. Again I suggest you should look through the BIOS settings to see if it is involved in enable/disable wifi and if there is a way to have it default to on.
If you run /sbin/wifi up
after reboot, will it bring it up? If so, add it in /etc/rc.local
.
Is it different between reboot and cold poweron?
Can you place card in different pcie slot?
Reset BIOS to defaults?
Try setting the channel to a definite number instead of auto. Scan for neighbor's networks and choose a channel to best avoid them. Auto selection will delay startup. Also I'm not sure if it works properly on selectable dual band cards.
This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.