Wi-Fi connections drop even due to playing a YouTube video

I am using Netgear R6120 with mt76x8. My Wi-Fi connections (5GHz and 2.4GHz) drop even due to playing a YouTube video at 720p on a single device. I have to manually disconnect and reconnect it. I never saw that issue with factory firmware. This issue is quite similar to this one here, which is quite old. Is there any solution yet? Do you suggest flashing the proprietary firmware again?

I bought the R6120 to evaluate dd-wrt. I failed twice with NMRPflash to restore factory default, following openwrt's flashing instructions. There are 2 other asuswrt clone images which support this 1core/2thread MT7621 router.

Thanks for the reply. Is that mean I am now stuck with this bug?

I think we're in the same boat for now. There is a golden orb firmware from of mice and men in Australia which defaults with the wifi enabled after a system reset, based on openwrt. The other way to get wifi set up is to use the imagebuilder. dd-wrt is a licensed broadcom shop, but the R6120 is Mediatek based.

Possible workaround/shot in the dark...

  • Just use one radio.

  • Enable legacy mode under wifi settings.

1 Like

Do you know whether this problem also exist on Modems and Men or DD-WRT? I couldn't find Netgear R6120, R6850, RAX10 in DDWRT or ROOter database.

I won't know until I remove dd-wrt from my R6120.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.

Reopening at the request of @_openwrtuser (marked solution didn’t actually fix the problem)

Thanks for letting me post the updated situation.

Thank you for the reply.

This issue persists, although it has been significantly reduced.

This has the same effect but throttled down the speed to 1/4.

Were you using Apple device?

If it's true, then you may try this, extending max_inactivity (default 300 seconds) to longer period of time (e.g. 360 or longer).

Just add

        option max_inactivity '360'

in your corresponding section in /etc/config/wireless.

Thank you for the reply. I have experienced this issue on Fedora, Windows, macOS and, Android.

This problem has been solved since version 23.05.0. Thank you for the support.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.