Why this config is non-working, and how to correct? (TP-LINK 3220 BB14.07)

Hi there,
I tried to modify my (working) routed WiFi config, to bridged one, and this does not work:


root@Laurent_Home_OpenWrt_3220_second:/# iwconfig 
lo        no wireless extensions.

eth1      no wireless extensions.

wlan0-1   IEEE 802.11bgn  Mode:Master  Tx-Power=17 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:off
          
wlan0     IEEE 802.11bgn  ESSID:"IoT"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: DA:5D:4C:B9:E7:08   
          Bit Rate=135 Mb/s   Tx-Power=17 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-35 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0

eth0      no wireless extensions.

br-lan    no wireless extensions.

root@Laurent_Home_OpenWrt_3220_second:/# ifconfig br-lan
br-lan    Link encap:Ethernet  HWaddr 54:E6:FC:B9:8F:63  
          inet addr:192.168.10.55  Bcast:192.168.10.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:157 errors:0 dropped:39 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:27000 (26.3 KiB)  TX bytes:252 (252.0 B)
root@Laurent_Home_OpenWrt_3220_second:/# brctl show                          
bridge name     bridge id               STP enabled     interfaces           
br-lan          7fff.54e6fcb98f63       no              eth0                 
                                                        eth1                 
                                                        wlan0
root@Laurent_Home_OpenWrt_3220_second:/#"

Syslog shows EVERYTHING (attach to AP, "IoT" WiFi works ok with ~10 "Tasmotized" Sonoffs, bridge says "port forwarding state") work, but IP doesn't. -> ping 192.168.10.30 (AP "IoT" WiFi IP) goes to nothing (no answer, not even ARP resolved). :frowning:

Here is my /etc/config/wireless & /network.
wireless:


config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0'
        option country 'PL'
        option channel '11'
        option txpower '20'
        option htmode 'HT40'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'IoT2'
        option encryption 'psk2'
        option wds '0'
        option key 'password2'
        option network 'IoT2'

config wifi-iface
        option encryption 'psk2'
        option device 'radio0'
        option wds '1'
        option disabled '0'
        option ssid 'IoT'
#       option ssid 'adelin3'
        option mode 'sta'
        option key 'password2'
#       option key 'password1'
        option network 'lan'
        option bssid 'DA:5D:4C:B9:E7:08'
#       option bssid 'D8:5D:4C:B9:E7:08'"

network


config interface 'loopback'
        option ifname 'lo' 
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
                                  
config globals 'globals'
        option ula_prefix 'fdb9:e615:11e4::/48'
                                               
config interface 'lan'
        option force_link '1'
        option type 'bridge' 
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'           
        option ipaddr '192.168.10.55'
        option dns '194.204.152.34 194.204.159.1'
        option _orig_ifname 'eth0 wlan0'         
        option _orig_bridge 'true'      
        option ifname 'eth0 eth1' 
        option metric '10'       
                          
config switch
        option name 'switch0'
        option reset '1'     
        option enable_vlan '1'
                              
config switch_vlan
        option device 'switch0'
        option vlan '1'        
        option ports '0 1 2 3 4'
                                
config interface 'IoT2'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'"

When I set it up with WiFi0 as ROUTED, and LAN (br-lan) have 192.168.20.0/24 address (wlan0 192.168.10.55) it looks working.
Where did I mistake and how to correct this?

W want just to set it as "repeater" node, I have similar setup on other 3220 box (only bridge over eth0, eth1, wlan0, wlan0-1) and it works for years.

https://openwrt.org/docs/guide-user/network/wifi/relay_configuration

You pointed me to quite complex setup.
And I can repeat: ""repeater" node, I have similar setup on other 3220 box (only bridge over eth0, eth1, wlan0, wlan0-1) and it works for years". Just ("native") bridge over Eth (all ports eth0 + eth1) and 2 WiFi (ap and sta-wds).

So I am making some kind of stupid error.
Should I clone that other setup, changing only SSID for AP? (and IP for br-lan, of course).

Please put your configurations in code blocks using the </> button on the top bar. This formats them in monospace font in a scrollable box which is much easier to read.

It should work to put a STA(WDS) in a bridge, if the other end of the link is a compatible AP(WDS). Are you trying to bridge multiple networks separately or only one? For bridiging multiple networks BATMAN mesh should be considered (even with only two nodes) because VLANs can be run on the same mesh link.

Also version 14.07 is way obsolete and should no longer be used.

1 Like

Ok (for quotes).
Only 1 (L2) network. As I said earlier, both ends (STA & AP) are in WDS, without this it is not possible to use bridge. And iwconfig shows it is connected!

Should work, (as syslog says), but is NOT.
To the AP in question another 3220 IS connecting as WDS STA, and bridges w/o problem, with its own AP (no WDS), and Ethernet.

If I change IP of br-lan to "lan" and connect Ethernet, it works (ethernet, not wifi), so device seems to be operational.

If it is needed I may post console output (have serial conn to device).

[and I know BB is obsolete, but it fits 4/32 device with all I need :slight_smile: ]

Ok, captured console output. Attached.
Looks "OK" but doesn't work.
This is what I don't understand.
Only things change from (working) setup are: SSID, password, IP/default route, BSSID.

Bootlog

[   25.080000] Restarting system.


U-Boot 1.1.4 (Nov  4 2010 - 19:24:46)

AP99 (ar7241 - Virian) U-boot
DRAM:
sri
ar7240_ddr_initial_config(133): virian ddr1 init
#### TAP VALUE 1 = 0xf, 2 = 0x10 [0x0: 0x1f]
32 MB
id read 0x100000ff
sector count = 64
Flash:  4 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
Virian MDC CFG Value ==> 4
: cfg1 0xf cfg2 0x7014
eth0: 00:03:7f:09:0b:ad
eth0 up
Virian MDC CFG Value ==> 4
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
ATHRS26: resetting s26
ATHRS26: s26 reset done
eth1 up
eth0, eth1
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...



OpenWrt kernel loader for AR7XXX/AR9XXX
Copyright (C) 2011 Gabor Juhos <juhosg@openwrt.org>
Looking for OpenWrt image... found at 0xbf022000
Decompressing kernel... done!
Starting kernel at 80060000...

[    0.000000] Linux version 3.10.49 (laurent@laptop4) (gcc version 4.8.3 (OpenWrt/Linaro GCC 4.8-2014.04 r48549) ) #3 Fri Jul 3 21:20:45 CEST 2020
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU revision is: 00019374 (MIPS 24Kc)
[    0.000000] SoC: Atheros AR7241 rev 1
[    0.000000] Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:5.000MHz
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 02000000 @ 00000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x00000000-0x01ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x00000000-0x01ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
[    0.000000] Kernel command line:  board=TL-MR3220 console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 128 (order: -3, 512 bytes)
[    0.000000] Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
[    0.000000] Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 28784k/32768k available (2222k kernel code, 3984k reserved, 594k data, 252k init, 0k highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:51
[    0.000000] Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
[    0.080000] pid_max: default: 32768 minimum: 301
[    0.080000] Mount-cache hash table entries: 512
[    0.090000] NET: Registered protocol family 16
[    0.100000] MIPS: machine is TP-LINK TL-MR3220
[    0.500000] registering PCI controller with io_map_base unset
[    0.550000] bio: create slab <bio-0> at 0
[    0.550000] PCI host bridge to bus 0000:00
[    0.560000] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[    0.560000] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.570000] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.570000] pci 0000:00:00.0: fixup device configuration
[    0.580000] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1000ffff 64bit]
[    0.580000] pci 0000:00:00.0: using irq 40 for pin 1
[    0.590000] Switching to clocksource MIPS
[    0.590000] NET: Registered protocol family 2
[    0.600000] TCP established hash table entries: 512 (order: 0, 4096 bytes)
[    0.600000] TCP bind hash table entries: 512 (order: -1, 2048 bytes)
[    0.610000] TCP: Hash tables configured (established 512 bind 512)
[    0.610000] TCP: reno registered
[    0.620000] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.620000] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.630000] NET: Registered protocol family 1
[    0.650000] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.660000] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.670000] msgmni has been set to 56
[    0.670000] io scheduler noop registered
[    0.680000] io scheduler deadline registered (default)
[    0.680000] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.710000] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
[    0.720000] console [ttyS0] enabled, bootconsole disabled
[    0.720000] console [ttyS0] enabled, bootconsole disabled
[    0.730000] ath79-spi ath79-spi: master is unqueued, this is deprecated
[    0.740000] m25p80 spi0.0: found en25f32, expected m25p80
[    0.750000] m25p80 spi0.0: en25f32 (4096 Kbytes)
[    0.750000] 5 tp-link partitions found on MTD device spi0.0
[    0.760000] Creating 5 MTD partitions on "spi0.0":
[    0.760000] 0x000000000000-0x000000020000 : "u-boot"
[    0.770000] 0x000000020000-0x000000122600 : "kernel"
[    0.770000] mtd: partition "kernel" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.790000] 0x000000122600-0x0000003f0000 : "rootfs"
[    0.790000] mtd: partition "rootfs" must either start or end on erase block boundary or be smaller than an erase block -- forcing read-only
[    0.810000] mtd: device 2 (rootfs) set to be root filesystem
[    0.810000] 1 squashfs-split partitions found on MTD device rootfs
[    0.820000] 0x000000360000-0x0000003f0000 : "rootfs_data"
[    0.830000] 0x0000003f0000-0x000000400000 : "art"
[    0.830000] 0x000000020000-0x0000003f0000 : "firmware"
[    0.860000] libphy: ag71xx_mdio: probed
[    1.410000] ag71xx-mdio.1: Found an AR7240/AR9330 built-in switch
[    2.450000] eth0: Atheros AG71xx at 0xba000000, irq 5, mode:GMII
[    3.000000] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.1:04 [uid=004dd041, driver=Generic PHY]
[    3.010000] eth1: Atheros AG71xx at 0xb9000000, irq 4, mode:MII
[    3.020000] TCP: cubic registered
[    3.030000] NET: Registered protocol family 17
[    3.030000] 8021q: 802.1Q VLAN Support v1.8
[    3.040000] VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
[    3.050000] Freeing unused kernel memory: 252K (80321000 - 80360000)
procd: Console is alive
procd: - watchdog -
[    5.810000] usbcore: registered new interface driver usbfs
[    5.820000] usbcore: registered new interface driver hub
[    5.830000] usbcore: registered new device driver usb
[    5.840000] SCSI subsystem initialized
[    5.860000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    5.860000] ehci-platform: EHCI generic platform driver
[    5.870000] ehci-platform ehci-platform: EHCI Host Controller
[    5.870000] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1
[    5.880000] ehci-platform ehci-platform: irq 3, io mem 0x1b000000
[    5.910000] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00
[    5.910000] hub 1-0:1.0: USB hub found
[    5.920000] hub 1-0:1.0: 1 port detected
[    5.920000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
procd: - preinit -
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
jffs2 is ready
No jffs2 marker was found
[   11.010000] jffs2: notice: (325) jffs2_build_xattr_subsystem: complete building xattr subsystem, 20 of xdatum (1 unchecked, 19 orphan) and 33 of xref (0 dead, 19 orphan) found.
switching to overlay
procd: - early -
procd: - watchdog -
procd: - ubus -
procd: - init -
Please press Enter to activate this console.
[   12.890000] Loading modules backported from Linux version master-2014-05-22-0-gf2032ea
[   12.900000] Backport generated by backports.git backports-20140320-37-g5c33da0
[   12.920000] nf_conntrack version 0.5.0 (453 buckets, 1812 max)
[   12.940000] usbcore: registered new interface driver usbserial
[   12.950000] usbcore: registered new interface driver usbserial_generic
[   12.960000] usbserial: USB Serial support registered for generic
[   13.010000] xt_time: kernel timezone is -0000
[   13.060000] ip_tables: (C) 2000-2006 Netfilter Core Team
[   13.070000] cfg80211: Calling CRDA to update world regulatory domain
[   13.070000] cfg80211: World regulatory domain updated:
[   13.080000] cfg80211:  DFS Master region: unset
[   13.080000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   13.090000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   13.100000] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   13.110000] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (N/A, 2000 mBm), (N/A)
[   13.120000] cfg80211:   (5170000 KHz - 5250000 KHz @ 160000 KHz), (N/A, 2000 mBm), (N/A)
[   13.130000] cfg80211:   (5250000 KHz - 5330000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   13.130000] cfg80211:   (5490000 KHz - 5730000 KHz @ 160000 KHz), (N/A, 2000 mBm), (0 s)
[   13.140000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   13.150000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 0 mBm), (N/A)
[   13.240000] usbcore: registered new interface driver pl2303
[   13.250000] usbserial: USB Serial support registered for pl2303
[   13.270000] PPP generic driver version 2.4.2
[   13.310000] usbcore: registered new interface driver option
[   13.320000] usbserial: USB Serial support registered for GSM modem (1-port)
[   13.340000] PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
[   13.360000] ath: phy0: Enable LNA combining
[   13.410000] ieee80211 phy0: Atheros AR9285 Rev:2 mem=0xb0000000, irq=40
[   13.430000] cfg80211: Calling CRDA for country: US
[   13.460000] cfg80211: Regulatory domain changed to country: US
[   13.460000] cfg80211:  DFS Master region: FCC
[   13.470000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   13.480000] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[   13.480000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[   13.490000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[   13.500000] cfg80211:   (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[   13.510000] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
procd: - init complete -
[   23.960000] device eth0 entered promiscuous mode
[   23.980000] device eth1 entered promiscuous mode
[   24.850000] cfg80211: Calling CRDA for country: PL
[   24.850000] cfg80211: Regulatory domain changed to country: PL
[   24.860000] cfg80211:  DFS Master region: ETSI
[   24.860000] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[   24.870000] cfg80211:   (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm), (N/A)
[   24.880000] cfg80211:   (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 2000 mBm), (N/A)
[   24.890000] cfg80211:   (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2000 mBm), (0 s)
[   24.900000] cfg80211:   (5490000 KHz - 5710000 KHz @ 80000 KHz), (N/A, 2700 mBm), (0 s)
[   24.900000] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[   28.220000] device wlan0 entered promiscuous mode
[   28.860000] wlan0: authenticate with da:5d:4c:b9:e7:08
[   28.880000] wlan0: send auth to da:5d:4c:b9:e7:08 (try 1/3)
[   28.890000] wlan0: authenticated
[   28.900000] wlan0: associate with da:5d:4c:b9:e7:08 (try 1/3)
[   28.910000] wlan0: RX AssocResp from da:5d:4c:b9:e7:08 (capab=0x31 status=0 aid=8)
[   28.920000] wlan0: associated
[   28.940000] br-lan: port 3(wlan0) entered forwarding state
[   28.940000] br-lan: port 3(wlan0) entered forwarding state
[   30.940000] br-lan: port 3(wlan0) entered forwarding state



BusyBox v1.22.1 (2020-07-03 12:51:28 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 BARRIER BREAKER (Barrier Breaker, r48549)
 -----------------------------------------------------
  * 1/2 oz Galliano         Pour all ingredients into
  * 4 oz cold Coffee        an irish coffee mug filled
  * 1 1/2 oz Dark Rum       with crushed ice. Stir.
  * 2 tsp. Creme de Cacao
 -----------------------------------------------------
root@Laurent_Home_OpenWrt_3220_second:/# ping 192.168.10.30
PING 192.168.10.30 (192.168.10.30): 56 data bytes
^C
--- 192.168.10.30 ping statistics ---
7 packets transmitted, 0 packets received, 100% packet loss
root@Laurent_Home_OpenWrt_3220_second:/#

As you can see, even ping does not work (nor ARP).
WTF?

@laurentppol What mk24 is asking is that you put your original post in code blocks, with separations for each print - so one for your iwconfig output, one for your /etc/config/wireless contents, etc. so people can see what's what.

1 Like

Ok, look at it now, is that what was I asked for?

1 Like

That looks A-OK :ok_hand:

I presume adding a gateway to your network config does not make a difference?

Don't think, but will try as soon as I regain access to device over serial (will replace USB/serial converter as npw it outputs 1-2 lines then nothing, until I exit and re-enter minicom).
ARP did NOT work (after ping arp -n showed unresolved address)

[edit]
Managed to change IP of br-lan, then access over Ethernet / ssh. Definitively bridging is NOT working, as in L2 this device has 2 connections to "main" router -> over Eth (192.168.1.0/24) and over WiFi (192.168.10.0/24). On "main" (WR1043ND with BB too) this one IS listed as "connected client", what is in accordance with iwconfig output. But NO IP over WiFi.

root@Laurent_Home_OpenWrt_3220_second:~# ifconfig br-lan
br-lan    Link encap:Ethernet  HWaddr 54:E6:FC:B9:8F:63  
          inet addr:192.168.1.55  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:529 errors:0 dropped:81 overruns:0 frame:0
          TX packets:438 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:50638 (49.4 KiB)  TX bytes:36433 (35.5 KiB)

root@Laurent_Home_OpenWrt_3220_second:~# ifconfig br-lan:1 192.168.10.55
root@Laurent_Home_OpenWrt_3220_second:~# ping 192.168.10.30
PING 192.168.10.30 (192.168.10.30): 56 data bytes
^C
--- 192.168.10.30 ping statistics ---
4 packets transmitted, 0 packets received, 100% packet loss
root@Laurent_Home_OpenWrt_3220_second:~# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 br-lan
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
192.168.10.0    0.0.0.0         255.255.255.0   U     0      0        0 br-lan

root@Laurent_Home_OpenWrt_3220_second:~# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.54e6fcb98f63       no              eth0
                                                        eth1
                                                        wlan0

The SHOULD be a "packet storm" as I know about Ethernet (as STP is OFF).

Is the AP properly configured? Correct network, netmask and IP?

Use brctl show to see which interfaces are in a bridge. When a WDS STA connects to a WDS AP, the AP's network bridge will add a new interface such as wlan0.sta1 which is dedicated to that station.

The "main" AP IS ok -> works with another 3220 as bridge (WDS), other 3220 as simple WiFi client, 8 Sonoffs as client...
I know about dynamically adding WiFi interfaces to bridge.
But for NOW there is ONLY 1 WiFi iface:

root@Laurent_Home_OpenWrt_3220_second:~# iwconfig 
lo        no wireless extensions.

eth1      no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"IoT"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: DA:5D:4C:B9:E7:08   
          Bit Rate=135 Mb/s   Tx-Power=17 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=68/70  Signal level=-42 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1  Invalid misc:15   Missed beacon:0

eth0      no wireless extensions.

br-lan    no wireless extensions.

Adding an AP will be next step.

[EDIT]
And THIS is my "AP" /etc/config/wireless:


config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/ath9k'
        option htmode 'HT40'
        option txpower '20'
        option country 'PL'
        option hwmode '11g'
        option disabled '0'
        option channel '11'

config wifi-iface
        option encryption 'psk2'
        option device 'radio0'
        option key 'password2'
        option disabled '0'
        option wds '1'
        option network 'lan'
        option ssid 'adelin3'
        option mode 'ap'

config wifi-iface
        option encryption 'psk2'
        option device 'radio0'
        option disabled '0'
        option ssid 'IoT'
        option mode 'ap'
        option key 'password1'
        option network 'IoT'
        option wds '1'

Reverted changes I have made:

  • ssid, wpa_key,
  • IP, gateway,
    SURPRISE it works.
    What is the problem (I guess it is located at 1043, config or bug).
    Any ideas? (other than trying to migrate "IoT" AP to 3220? (as it serves already as backup link(s) - WiFi to phone and 3G USB modem - I'd like not to modify it's config)

[I have had some other problems with this device - impossible to make work AP (WDS) + STA (non WDS). This config WORKS on 3220.]