Why the switch to unstable ath10k-ct?

If you run make menuconfig, deselect the ct driver and firmware package and select the original ath10k driver and firmware package, you will and up with these lines somewhere in your configuration:

# CONFIG_PACKAGE_ath10k-firmware-qca988x-ct is not set
# CONFIG_PACKAGE_kmod-ath10k-ct is not set
# CONFIG_PACKAGE_kmod-hwmon-core is not set

If you run ./scripts/diffconfig.sh > my_diffconfig, these will be preserved.
Note: At least on my platform the ath10k-ct driver depends on the kmod-hwmon-core package, while the default driver does not (nor does any of my other packages), so it's deselected as well. Depending on your hardware/configuration, you may still need the kmod-hwmon-core package.

In addition, you can also choose to build one of the firmware packages as a module that does not get included in the firmware image. That should avoid the error as well and gives you the option to manually install the other firmware package (using the opkg --force-overwrite option), so you can test the two firmwares against each other. In this case I would make sure to make a backup of the file /lib/firmware/ath10k/QCA99X0/hw2.0/board-2.bin though, as it will get deleted once you uninstall either of the two firmware packages.

1 Like

Escalade: I opened a bug for your crash file, see link below. It has a binary you can test:

silentcreek: I opened a bug to track your 988x slowdown report.

At this point, I don't plan to work on it, but good to have the bug open in case others see something similar or I get interested in debugging it more in the future.

Hello everyone I have a UBNT AP AC Lite with openWrt 18.06.1.
I want to use the ath10k-ct driver, but as a newbie I don't know how to switch to it. The package for the CT driver says. "This firmware will NOT be used unless the standard ath10k-firmware-qca988x is un-selected"

How does one "un-select" a firmware?

Do I just install the "ath10k-firmware-qca988x-ct" package and uninstall the "ath10k-firmware-qca988x" package and reboot in order to "un-select"?

Is there a guide for this? I tried all the google-fu I could to find answers.

Deselecting primarily refers to building OpenWrt from source (there make menuconfig (kconfig) gives you an ncurses (text-)GUI to select/ deselect options), if you use a prebuilt image, like 18.06.1, you do indeed use opkg to remove ath10k kmods and firmware and then install their ath10k-ct variants instead.

1 Like


Thanks for the help! To confirm I did the following opkg commands below... It seems to work, but my it is unstable under dumb AP mode. https://openwrt.org/docs/guide-user/network/wifi/dumbap

Unstable as in once I start a speed on my phone. It suddenly disconnects and web GUI is frozen. After waiting web GUI comes back up.

However when my UBNT AP AC Lite is in router mode with the eth0 set as WAN and the WiFi chips on LAN it's stable.

opkg update
opkg install ath10k-firmware-qca988x-ct
opkg install ath10k-firmware-qca988x-ct-htt
opkg remove kmod-ath10k
opkg remove ath10k-firmware-qca988x

1 Like

I'd do the removals first - and you can only install either ath10k-firmware-qca988x-ct XOR ath10k-firmware-qca988x-ct-htt; furthermore ath10k-ct has seen significant improvements past 18.06.1, which means the 18.06.1 versions are not quite representative to the current ones (master/ snapshots).

1 Like

I see how do I get the master / snapshots on openwrt?



1 Like

For me the ct driver+firmware is unstable in the TCP/UDP connection sense - no crashing. I use TP-Link Archer C7 v4 router. I saw lot of repeated "authenticated" lines from hostapd, "disassociated" due to inactivity (during an active Skype call...), the Skype call had problems sharing the screen (it disappeared three times during 40 minutes of Skype call) - all seen via logread command. No error from the driver in logread, though (I haven't checked dmesg, sorry). I recompiled the firmware with non-ct driver+firmware and just repeated the Skype call (~90 minutes) with screen sharing and there was not a single line in logread, it just works™.

That the ath10k-ct drivers still do not support 802.11s, at least as far as I can tell from the documentation and the output of iw, is a show stopper.

On what model?
On IPQ40xx 802.11s works on ath10k-ct on both radios while on ath10k it only works on 2.4GHz

On ar71xx / ath79, Archer C7 v2 and GL.iNet AR750 both support mesh on 5 GHz with the ath10k driver (non-CT). I have been sucesfully running 802.11s on 5 GHz on the Archer C7 units for close to a year now.

"mesh point" is absent from the output of iw phy with the ath10k-ct driver and firmware for at least the 5 GHz band.

1 Like

On my Archer A7 v5, with an image built from git, ath10k-ct is noticeably slower than ath10k.

My 802.11ac device (a Pixelbook running a web-based speed test) reports a download speed of ~140Mbps using ath10k-ct, and ~250Mbps after reverting to plain ath10k.

Hi, some issues with QCA9984 and latest current master ath10k-ct drivers, low speed (about 400 mbit) and i can't use VHT160 on it. On stable build 18.06.2 (2018-05-12-952afa49-1) speeds is about 1gbit and VHT160 works without problems, but some times wifi crashes. Is there any users who uses QCA9984 or QCA9994?

1 Like

Have you tried changing to non CT drivers?

Yes, now i have found stable combination — ath10k-ct drivers + non-CT (classic) firmware, on VHT80 speeds is about 600 mbit (sometimes up to 800), but VHT160 on QCA9984/9994 did not works in all versions and combinations, more detailed i have describe here — 160MHz on Netgear R7800
Only have success with VHT160 on 18.06.2 :frowning:

Hmm, don't think I've ever gotten 160mhz to work.
If you make master branch use the standard ath10k driver and the same firmware version from 18.06.2, doesn't it work?
Btw, 160mhz uses channel 50 or 114, I can't select any of them, closest I have is 52.
(some sites say 36, maybe 50 is for US?)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.