Why OpenWrt is bad in wifi ( Mt76x )?

No DHCP

PandoraBox network


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '192.168.1.242'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '20:76:93:52:0a:db'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '20:76:93:52:0a:dc'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t 7t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 7t'
        option vid '2'

PandoraBox wireless


config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'VHT80'
        option disabled '0'
        option channel '108'
        option country 'FR'
        option legacy_rates '1'

config wifi-iface
        option network 'lan'
        option ssid 'Livebox-2270_5GHz'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'sta'
        option bssid '44:D4:54:19:22:70'
        option key '1234567890A'

En ce moment cela fonctionne très bien : Je reagarde la TV !!!

as i said this drivers are 100 years old, that do not even work on wpa3, i senteed you a firmware really good. live alone pandorabox, we are talking about openwrt, and that really is maling me very mad, because the reality is that mtk work best on openwrt, and i know wath i'm saying.

ok i see now i compiled a firmware with mtk wifi drivers not sure if you can understand that, mabie luci is tricking you, because you see the voice wifi and not mtkwifi?

OpenWRT uses newer Linux kernel which old MTK drivers need to be ported.
MTK has to do this port, not OpenWRT developers.

guys please leave mtk wireless drivers alone. i did it on openwrt kernel stable.
mabie this drivers are to complicate to configure. i tryed to help but that does not work, that's why i like to not talk about that.
if for me work, that mean the drivers are ok.

read this :slight_smile: Mt76 driver - replacement [for test]

well men all my devices mtk are the best wireless i have for speed and for ax, but the best openwrt devices are always and always will be ath9k devices, i'll stop here.
no more support here to much time for nothing.

Some clarification (FAQ) from somebody who hosted mtk drivers on thieir GitHub page: Nossiac/mtk-openwrt-feeds:

  1. What's the relationship with the mt76 project?

In short, they are totally different implemantions.

The mt76 driver is GPL licensed. It was written from scratch by Felix@OpenWrt. It's much modernized. It follows the latest linux wireless architecture, and uses the latest kernel APIs.

The early stage of mt76's development once got supported by MTK, I guess that is the only connection between the two.

MTK's WiFi driver is non-open, aims for help MTK's clients and vendors make serious products. It runs not only under linux, but also under eCos and VxWorks (that's why its code looks weired). It's not friendly for beginners, as well as hackers.
5. Which one is better for me, MTK's driver or open source driver?

For end users and hackers, you should always try mt76 first. If you are not happy with the current quality, you can fall back on MTK's drivers.

If you are running a serious business, you should consider more, like stability, performance, advanced features, technical support, ...

Here's a short list you should take a look:

Advantages of mtk drivers

Better performance. (if you configure it properly......)
Full chips series coverage.
More advanced features.
Support eCos, VxWorks, ...
Posible technical support from MediaTek.

Disadvantages of mtk drivers

Does not support mac80211/cfg80211. Although cfg80211 is paritially supported in some drivers, but not quite ready for production.
Does not support OpenWrt's uci configuration. That's why I wrote the "mtk-luci-plugin".
Does not support the latest kernel. (depends on how this project goes)
No GPL source code available.

I have seen that Ryder Lee, who is an active developer for Mediatek - according to his LinkedIn - , pushed commits to mt76, so I would assume this open source driver is supported by Mediatek as of December 2022, but there is limited support for older devices. If some devices have still issues after years, it could just mean that they have given up on fixing those issues and turned their attention to newer devices. An open source driver would allow ANYBODY to test and propose fixes and enhancements to the driver, which is possible with mt76 to a large degree, as far as I am aware. They have the potential to eventually become better than mtk drivers, because they are open source and have room for improvement, but ONLY if people actively and actually develop them. The MTK drivers apparently are closed source and while they may work to a certain degree for your specific device(s), on the grand theme of things, just like mt76, they may not be perfect either. Because the mtk drivers are to a large degree not open source, it will be hard to impossible for the OpenWRT community to improve them and that indeed may explain why there has not been any change to mtk drivers since April 2019 (at least to the mtk drivers I found). Linux aims to be Open Source software. OpenWRT does too, since it is Linux based and as such, I would assume it is no coincidence that mt76 is the standard driver. Please correct me, if my understanding is erroneous.

You are free to choose whatever, but I think some clarification was needed here.

NEWIFI-D2_3.4.3.9L-100.trx

there really is a problem with OpenWrt
I just tried quickly Padavan and everything works.
repeater, AP, Orange TV , samba with good speed > 100 Mb/s ....
very good speed for Wifi 5Ghz

Then maybe use "Padavan" if it covers all your use cases.

use padavan or old pandorabox, that's for sure

but that does not solve the problems with OpenWrt ...

or to warn users that there are problems and not to insist with OpenWrt if it does not work correctly and to find other solutions

i'm back to normal person, lol.
this is just my opinion, mtk drivers are the best stable drivers under OpenWrt, the just work, speed, stable, range,and sometimes easy, very easy,but not for every custom usage. leave alone padavan, and other fake copy of official firmwares. &ath9k& is another planet under wrt, but let's leave that alone too.
i love mt76 too, but that is just different.

mt76 isn't perfect, mostly the unfinished ax functionality which is currently unofficial anyway. The rest runs sufficiently good for everyday usecases, with the usual exceptions.


MT7976AN with iphone xs. (Xiaomi-AX6000)

(Before that I had a mir3g with mt7603 and mt7612 as a daily driver which worked really well after the mt7530 patches)

ok retested that with openwr 22 and all is working,.
so mark it as solved, nothing about openwrt

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.