Why OpenWrt is bad in wifi ( Mt76x )?

I use this :

Box Internet < -- WifI 5 GHz --> OpenWrt Newifi D2 tested with 19.01 or 21.02
The wifi does not work

Box Internet < -- Wifi 5GHz --> Paadorabox 18.12
The wifi work including the Orange TV

Same parameters

Why openwrt is bad in wifi ( Mt76x ) ?

Try 22.03.2
Make sure it's properly configured including setting radio country code. It sounds like your use case is a routed wifi client, where the wan device is the wifi radio in client (STA) mode.
"Does not work" is not specific enough for us to know how to help.

2 Likes

22.03.2 same problem

pandorabox parameters ( same for openwrt )

network


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option delegate '0'
        option ipaddr '192.168.1.242'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr '20:76:93:52:0a:db'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr '20:76:93:52:0a:dc'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t 7t'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '6t 7t'
        option vid '2'

wireless


config wifi-device 'ra'
        option type 'rtwifi'
        option macaddr '20:76:93:52:0a:dd'
        option hwmode '11g'
        option channel 'auto'
        option txpower '100'
        option htmode 'HT20'
        option country 'FR'
        option txburst '1'
        option noscan '0'
        option smart '1'

config wifi-device 'rai'
        option type 'rtwifi'
        option macaddr '20:76:93:22:0a:de'
        option hwmode '11a'
        option txpower '100'
        option htmode 'VHT80'
        option txburst '1'
        option noscan '1'
        option country 'FR'
        option disabled '0'
        option channel '108'

config wifi-iface
        option ssid 'Livebox-2270_5GHz'
        option encryption 'psk2'
        option device 'rai'
        option mode 'sta'
        option bssid '44:D4:54:19:11:70'
        option key '1234567890'
        option network 'lan'

dhcp nothing

speedtest is some correct 250 /: 250

country radio is good

Is this official OpenWrt? Official OpenWrt (from downloads.openwrt.org) is not swconfig, and doesn't use radio type 'rtwifi'.

In any case, a STA radio cannot be in a bridged interface, it needs to have its own network, usually called wwan or wan.

1 Like

Also, this is incorrect. Set your correct country for both.

:spiral_notepad: They must be identical.

2 Likes

That is parameters for pandorabox running fine
CN country is not used ( 2.4 Ghz )
FR is used for 5 Ghz

I'm not sure what you response means; but again - the setting is incorrect.

  • This is not legal
  • The community cannot assist with such configs

Again:

1 Like

I replaced CN by FR and it does not change anything

If you want the files with openwrt which does not work I have to replace the firmware but the box is used at the moment

Please describe the actual issues you're having. Use as much detail as possible.

The problem is that openwrt see the orange box fine

I can validate the SSID and its password but it doesn't work in sta / lan mode.
It only works in sta / wwan mode

Lan, you mean bridge???

If so, that won't work.

Yes, exact in bridge

But then why Pandorabox works

config wifi-iface
option ssid 'Livebox-2270_5GHz'
option encryption 'psk2'
option device 'rai'
option mode 'sta'
option bssid '44:D4:54:19:11:70'
option key '1234567890'
option network 'lan'

Before edited - you had STA - this will work.

AP - will not work.

STA it doesn't work between OpenWrt and the Livebox

STA / LAN mode only works with OpenWrt and a second OpenWrt box but not with the Livebox

1 Like

Provide information on this device.

Set WiFi correctly?

Who is STA?

(Everything I've posted is referencing OpenWrt.)

For the device i use at this time a NEWIFI - D2

Now I don't have many old boxes that have Pandorabox compatible firmware to try out
I still have a WR1200JS but I think it will be the same

I use:

Fiber Box Orange Livebox 6 < -- Wifi 5Ghz --> STA Openwrt or PandoraBox < --- LAN

For me this is not very important because i finally found a solution with Pandorabox which also plays Orange TV which i never managed to make work with OpenWrt (in relay mode)

The information is for the community hoping that this old problem will be ""solved one day"

I'm leaving the forum for a while: There's football France England. I watch with the NEWIFI-D2 !!!

Test OpenWrt 18.06 at this time with WR1200JS

network


config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.1.252'
        option gateway '192.168.1.1'
        option dns '192.168.1.1'
        option delegate '0'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'd4:5f:25:ea:f9:94'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'd4:5f:25:ea:f9:95'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 4 6t'
        option vid '1'

wireless


config wifi-device 'radio0'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'HT20'
        option disabled '1'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
        option htmode 'VHT80'
        option disabled '0'
        option channel '108'
        option country 'FR'
        option legacy_rates '1'

config wifi-iface
        option network 'lan'
        option ssid 'Livebox-2270_5GHz'
        option encryption 'psk2'
        option device 'radio1'
        option mode 'sta'
        option bssid '44:D4:54:19:22:70'
        option key '1234567890A'

same error as before

when i start wifi i have this msg ( i have no IPV6 )

root@OpenWrt:/etc/config# wifi

root@OpenWrt:/etc/config# [ 1559.429958] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready

luci error:

SSID: Livebox-2270_5GHz | Mode: Client
Wireless is not associated

option network lan can never work on a sta interface, because lan is a bridge. That is due to the nature of wifi MAC addresses. There are ways around this, which may be incorporated invisibly in other firmware's radio drivers. OpenWrt does not include that though.

The OpenWrt ways to "bridge" into a wifi AP are relayd, which is not an actual bridge though it kind of works like it. Or use STA-WDS, which also requires the AP to support WDS mode (most that are not OpenWrt will not). WDS is however a true bridge.

1 - WDS is not possible with the LiveBox 6 ( only with OpenWrt )

2 - With OpenWrt & relayd TV orange not working

With this problem I cannot use my new boxes with WIFI-AX because it only works if there are Pandorabox firmware

So it would be "awesome" if the feature was added

yes it can.
he is mix things up
sta can be bridged nice with mtk wifi.

i thik here is a mix of mt76 drivers with mtk wifi config