Why is there no build of the latest version of openwrt for my router hardware?

I have been using openwrt for a few years on my Linksys WRT32X router, but recently I noticed that the latest version for it (22.03.2) isn't the latest version available (22.03.5)

I notice other routers with the cortexa9 processor have a build for the latest version but this one is missing. Is there a reason why it is no longer supported? Is there anything I can do other than to upgrade the hardware?



The search function will give you the full details, but a rather serious security issue affecting the switch drivers of your device has been found in kernel v5.10 and the openwrt-22.03 releases (all releases), which is why no new known-broken 22.03.x releases are being built for these anymore. The issue has been fixed with kernel >=v5.15 in master and 23.05~, for which images are being built.

tl;dr: upgrade to 23.05.0-rc2, now (as the also non-broken 21.02.x is EOL and no longer security supported).


You could look at the Divested Community Builds that targets the Linksys WRT series.

It’s running currently at kernel 6.1. Anecdotally, the combination of an updated mwlwifi driver running on kernel 6.1 seems to have improved on the wifi experience.
Latest build for your device is here.

1 Like

Thanks for the replies and the explanation, I did try to search for the reason that my router was missing, but I didn't find anything relevant when I was looking.

I will try out the rc release and hope that a full release will be coming soon, and if I have any problems I can always try the divested build

Thanks for the suggestion, I tried this release candidate and it works well, but it's missing the luci-app-wireguard package so my VPNs won't work. (I have created a separate post about this as well)

Do you know when it's likely there will be a full release, or why this one package is missing from this release? Thanks!

I'm tried out the rc, thanks for the suggestion, the only problem is it seems to be missing the luci-app-wireguard package in opkg and my VPNs don't work without it. Do you know when a full release is likely to be available or why this package is missing? Can I build it myself?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.