Why does the wwan device disable and enable it, causing the gateway to be missing?

Why does the wwan device disable and enable it, causing the gateway to be missing?
And the wwan interface is disabled and then enabled to repair the gateway.

BusyBox v1.28.4 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 OpenWrt 18.06.5, r7897-9d401013fc
 -----------------------------------------------------
root@openwrt_domywifi:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.50.1    0.0.0.0         UG    0      0        0 wlan0
192.168.2.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.50.0    *               255.255.255.0   U     0      0        0 wlan0
root@openwrt_domywifi:~# ifconfig wlan0 down && ifconfig wlan0 up
root@openwrt_domywifi:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.2.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.50.0    *               255.255.255.0   U     0      0        0 wlan0
root@openwrt_domywifi:~# ifdown wwan && ifup wwan
root@openwrt_domywifi:~# route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.50.1    0.0.0.0         UG    0      0        0 wlan0
192.168.2.0     *               255.255.255.0   U     0      0        0 br-lan
192.168.50.0    *               255.255.255.0   U     0      0        0 wlan0
root@openwrt_domywifi:~#

Please, post your "/etc/config/network" file here.

root@openwrt_domywifi:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth1.1'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
        option ip6assign '64'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'static'
        option auto '0'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqaddress 'try'
        option reqprefix '56'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '2 3 4 5 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '1 0t'

config interface 'wwan'
        option proto 'static'
        option ipaddr '192.168.50.254'
        option netmask '255.255.255.0'
        option gateway '192.168.50.1'
        option dns '192.168.50.1'

root@openwrt_domywifi:~#

Is WLAN0 bridged to LAN or WWAN?
Restarting WWAN fixes it because is where the gateway is configured.