Why do TP-Link routers kick wireless users off and prompt for password?

Sorry. I will post config again. I have an TP link MR3420 running OpenWrt 18.06.1 / LuCI openwrt-18.06 branch.

It's configured as AP. luci-proto-relay is installed. Frequently, after some hours, the router asks for wi fi password again.

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'platform/10300000.wmac'
	option htmode 'HT20'
	option disabled '0'
	option legacy_rates '1'
	option channel '11'
	option country 'BR'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'psk2'
	option key '****'

config wifi-iface
	option network 'wwan'
	option ssid '3COM'
	option encryption 'psk2'
	option device 'radio0'
	option mode 'sta'
	option bssid '********'
	option key '*******'







config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdfe:6736:1dd0::/48'

config interface 'lan'
	option type 'bridge'
	option ifname 'eth0.1'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config device 'lan_dev'
	option name 'eth0.1'
	option macaddr 'b0:4e:26:6d:4a:2e'

config interface 'wan'
	option ifname 'eth0.2'
	option proto 'dhcp'

config device 'wan_dev'
	option name 'eth0.2'
	option macaddr 'b0:4e:26:6d:4a:2f'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '1 2 3 4 6t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 6t'

config interface 'wwan'
	option proto 'dhcp'

config interface 'Bridge'
	option proto 'relay'

I didn't undestand all your question. But I have just disabled legacy rates. How do I disable power savings?

Are your clients that connect to the router via WiFi that keep getting disconnected running Linux on them? If so, to find out what model of chipset the wireless adapter is can be found typically by running 'lspci | grep 802.11' in a terminal.

If your clients that connect to the router via WiFi run Linux and use NetworkManager, you need to do the following as root or sudo to disable power management for the wireless adapter on those clients:

touch /etc/NetworkManager/conf.d/wifi-powersave-off.conf

Then using your favorite text editor, add the following to that file:

[connection]
#Values are 0 (use default), 1 (ignore/don't touch), 2 (disable) or 3 (enable).
wifi.powersave = 2

Then restart NetworkManager using 'systemctl'